Western Digital external hard drive problem

By delux269 · 77 replies
Nov 27, 2008
  1. delux269

    delux269 TS Rookie Topic Starter

    I downloaded and ran the DiskView utility, and Under the "physical disks" category, it is only showing the internal hard drive in my laptop.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    So for all we've tried doing with your WD USB hard drive,
    - Windows does see it as a USB device but
    - Windows does not see the device as a disk.

    The distinction being
    - Device is the hardware. Think of the device as what's needed for data and control information to be transferred between Windows and a hardware device. Windows recognizes the USB drive hardware when connected and installs two hardware device drivers (that's what's in Device Manager). Device manager doesn't report any errors (based on what you saw using msinfo32 tool)
    - "Disk" is how the data on the hardware device is organized.

    It seems Windows and the device can transfer data back and forth. But windows can't interpret that data as consistent with being a Windows disk.

    I'd guess either
    - There is a hardware problem with the drive and/or cable
    - There's software on the PC that's interfering with that data stream between the Windows Logical Disk Manager and the USB device.

    1. So let me ask again (i don't think you answered yet): Did you ever install Daemon Tools or Alcohol 120%? (even if it was later uninstalled?)
    2. Try booting into Safe Mode (so minimum software/drivers) are loaded and then connecting
    3. Driver filters might interfere but need get back to you with info later
    4. You can still try connecting your USB to other non-XP SP3 computer or boot your computer into a non-Windows system and then try USB drive connect
    5. There's also the Acronis disk director but you'd probably need some instruction and if so, there's no point in downloading and starting your 15day free clock running until you have instructions
  3. delux269

    delux269 TS Rookie Topic Starter

    I have never installed Daemon Tools or Alcohol 120%. I will try the Safe Mode soon.
  4. delux269

    delux269 TS Rookie Topic Starter

    Sorry I am being slow about things lately, I have finals for college and I haven't had much time. I will get back to this as my main focus in a few days.
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    No worries. Definitely focus on finals
  6. delux269

    delux269 TS Rookie Topic Starter

    Okay so should I go ahead and do the Acronis free 15 day trial?
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    no... check back here in a few minutes.. i was working on a draft about bgeneral tools for testing this problem.

    Will post the draft here but as it's a draft (and parts not yet finished) can fill in the blanks for you

    /** EDIT **/
    OK. See below. For the initial purpose of just seeing if your computer can detect the drive when booted from CD you can use instructions (plus some i still need provide to boot up) to build Gparted-Live-CD. Then you can use gparted and TestDisk to try detection. we'll then see if need to manage the partition or if problem is all in the drive hardware

    ****** DRAFT FOR A GENERAL POST ********
    When Windows refuses to recognize your USB hard drive

    Drawing the battle lines
    At some point during the Windows battle one needs to determine if the problem is due to:
    ==> Your computer and its installed software (Windows + all else you’ve loaded)
    ==> Your computer hardware (BIOS, boards, USB ports, etc)
    ==> Your USB hard drive (including AC power supply and USB cable)

    One way to rule out Windows and other installed software
    • Create a non-Windows boot CD
    • Boot from CD. Your computer only loads/runs the CD based software
    • Test if your computer now recognizes the USB drive AND if it’s recognized correctly. Windows and your other computer based software are now removed from the testing equation
    You'll find instructions below on how to create / test with either of two different boot CDs which offer a total of three different test/recovery tools
    • Acronis Disk Director
      This is a user friendly commercial product which provides for hard drive partition management and data recovery. As a commercial product it offers Disk Director as a 15day free-to-try tool you can download and create and run your yourself. It provides the option of having it integrated with Acronis True Image so Disk Managment functions can be integrated into a product that handle ghosting/backups/restores of your drive.
    • Gparted-Live-CD
      Provides an assortment of freeware / public source code based tools. In particular, these include:
      • Gparted. A disk partition editor and recover recovery tool (the tool itself is named Gparted)
      • TestDisk. Yet another partition editor and recovery tool

    I think all three tools will perform comparably for your first test: Detecting a USB hard drive when your computer has been booted from a non-Windows CD. on your computer when booted from For the first test, WhenI find each tool equally capable of working within its boot environment to detect a usb hard drive (if, in fact, it can be detected!) They vary when it comes to managing USB hard drive partitions and/or performing data recovery
    • A lot of people use Acronis and Gparted to manage their partitions without problem. That said, problems still happen so i can't 100% say what's best for your case
    • I've never used TestDisk but (from reading) appears it's strength is at data recovery. It may not have all the manage partition functions found in the other tools but not sure you will need them
    • For my own own personal case, i use Acronis
    • For more input, you might try searching “problem after gparted” vs. “problem after acronis disk director” etc.
    • Consider what you need for product documentation, level of support and $ cost for your tool of choice between freeware vs. commercial products
    Gparted Live-CD
    Gparted Live-CD boots into Linux (another Operating System). The Gparted Live-CD includes these tools (among others)
    • Gparted. Gparted is the Gnome Partition Editor. (If you like interesting acronyms: Gnome is part of GNU). You can use Gparted to help detect, manage and recover your USB hard disk partitions and data. Some usage and examples are presented later in this doc. For more detailed Gparted info
    • TestDisk. TestDisk is yet another partition editor/ recovery program included in the Gparted-Live CD. TestDisk can also be used to help detect, manage and recover your USB hard disk partitions and data.

      I don’t think TestDisk offers as as many partition management functions as in Gparted or in Acronis though don’t know if you need all those options either.) I’ve read about (never used) TestDisk. Many have said it has helped recover their data but, as always, results vary from case-to-case. An example is provided later in thid document. For more detailed info:
    Creating a Gparted Live CD
    containing a tool named Gparted as well as other usefthe name of a CD image file (CD image files have an .iso file extension ).

    1. Download the latest Gparted-Live-CD.iso file. (pronounced EYE - soh

    2. Click here to go to the Gparted-Live-CD download page
    3. The download page lists the current and past stable releases. Find the current release at the top of the list
    4. Click on the .iso file in that latest release to download it. Save it on your hard drive
    5. Use your burning software to copy the .iso file and burn it to CD. (Pretty much all CD burning software handles .iso files. It's typically treated as a "copy file and burn" function in the software)
    Using a Gparted Live CD
    ///NOTE/// It is recommended to do a whole disk or partition image backup before you use GParted to resize or move your partition. Some free (GPL) disk or partition image tools, which provide live CD or USB flash drive so that you do not have to install or configure, are available:
    • Clonezilla
    • G4L
    • g4u
    • Partimage​
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    suggest you
    1. build the Gparted-live-cd
    2. When you boot, have all usb devices disconnected
    3. when it asks any questions just keep hitting ENTER for default value
    4. When it starts, it starts in the Gparted tool on the screen and you'll see info about the internal hard drive
    5. Now connect the usb drive. wait maybe 30-60 seconds. then in gparted you need to tell it to scan again for devices
    6. Then see if you click on the device pulldown in gparted (u'll find it on the right of the window) to see devices. hopefully there is now a choice of two devices

    and oh btw.. should it come to it.. i found somewhere that said the screw for the case on your WD HD is hidden under a rubber pad (probably used ot stand up the drvie)
  9. delux269

    delux269 TS Rookie Topic Starter

    I just opened the drive by brute force. It appears that the drive just snaps out of and back into place. All of the screws were tightly attached.

    I will create the boot CD tomorrow

    I am going to create the Gparted CD after graduation today. If that does not work I am just about at the point where I want to just dispose of this dr4ive and invest in a new one
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Well congrats on graduation!

    As for the Gparted-CD
    - may as well test for the drive detection using both gparted and TestDisk. (JUST see if it's detected don't do anymore yet if it is deteced
    - Most likely if one of those tools doesn't recognized the hard drive the other won't either. But since there both on that CD may as well try both
    - I'll add some instructions for TestDisk either this evening or tomorrow
    - And test on both your computers. If in fact it STILL can't be detected that it has to be related to the USB hard drive hardware
    - While you probably want to get a new drive if is hard drive issue THERE IS STILL ONE LAST THING to try if only to recover your data (tho may also give you the usable drive again) If hardware problem it's probably either with the hard drive case or drive itself. You can go to a store and buy a cheap case and open old case, remove drive, and try the disk in new case. If still doesn't work you should be able to return the new case (of course, double check before buying it's returnable)

    /* Edit */
    And if you actually CAN detect the hard drive, your next steps start here to make sure your internals drives and as well as external USB are clean from any malware infection
  11. delux269

    delux269 TS Rookie Topic Starter

    I bought a Seagate 1 TB external drive today. The computer picked up the drive just fine, and installed the hardware in no time and it is working properly. I still would like to get the other drive working to see i fI can get the data off of it and transfer it over. I will have the results of the Gparted CD tomorrow.
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Seems like WD drives have more then their fair-share of problems. Good you got something different.

    As for Linux and USB Hard drive detection let me first mention the sequence I see with normal windows start
    ==> I power on.. BIOS starts POST test. I see my USB drive power light come on (it's a Buffalo something-or-other) and I hear the drive spin-up
    ==> Soon after BIOS POST completes power light goes off and I hear drive spin down
    ==> Not until sometime shortly after Windows desktop appears does my drive come alive again (light on , drive spin up)

    Just out of curiousity now (as occurred to me I never did ask) do you recall if you heard the drive spin up as usual while having this problem?

    My Gparted post instructions say boot without USB then connect the drive. Detection successful 100% of the time that way (assuming the drive worked of course!). But i vaguely recall one or two rare times when connected while booting that my drive wasn;t there on Linux startup. Though it did appear if I simply unplug/replug for those cases

    So stuff to know when you run Gparted or TestDisk
    ==> If Gparted doesn’t see USB drive then you connect or reconnect USB you must tell Gparted to Scan for Devices before it sees the change
    ==> With TestDisk is easiest to simply Quit then maybe 30-60 seconds after connecting usb till u rerun it
    ==> Under Linux, device names assigned to my internal hard drive and CD start /dev/hda. USB drive starts /dev/sda (just fyi to make sure you identify the USB device correctly)
    ==> To run TestDisk from a Linux window. If you are in the Gparted app double click the window icon you see up top. When Linux window opens just enter TestDisk and select a log option when prompted
    ==> TestDisk then shows you a list of devices. If usb device there make sure it's description is correct (size-wise)

    I mentioned some things earlier but here’s a summary of things-to-do-to help avoid USB hard drive issues
    1. Unless you need to plug that drive into a machine that needs FAT32 (for example some game machines) I recommend you reformat to NTFS. (Or use convert command if you already have data there)
    2. Turn off System Restore monitoring of your USB drives
    3. Open Device Manager. Rt click the USB drive device select Properties. Click Policies tab. Check Optimize for Quick Removal
      Your USB drive will have slightly slower performance but will greatly reduce the odds of file corruption if the drive is abruptly disconnected. (Even if religious about “Safely Remove Hardware” we still all have system crashes and other unexpected events which disconnect it from time-to-time
    4. Set Power Management options to NOT allow computer to turn off your USB drive to conserve power
    5. Also see this helpful link The Care and Feeding of USB Storage Devices in XP
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    And more (i think) useful info
    Been playing around with Gparted-Live-CD myself the last coupla days. In the Gparted tool window (which starts automatically after Linux)
    - Double click the Window icon to open a Linux window
    - Enter dmesg to view the current system log.

    Among system log entries you'll find log entries detailing Linux' system-level attempts to connect and communicate with your USB hard drive. So...
    • Open a Linux window and type dmesg to see the current log and its last entries
    • Plug in your usb hard drive
    • Open another Linux window and enter dmesg. Scroll to the end and find the new entries added to the log. These detail the Linux I/O activity and low system-level attempts on a device name which begins with /dev/sda
      >>>>>>> Note: Your USB drive will be a /dev/sda device. But depending on your system hardware/configuration it may also have other /dev/sda devices. Finding the entries which appear immediately after plugging in the USB drive and reading error message content will help you identify it is in fact for the USB drive
    • Go back to Gparted tool and tell it to refresh devices
      ==> If Gparted doesn't display the new device AND you aren't finding any new log entries, your hardware is never detected at USB port
      ==> If Gparted doesn't display the new device AND you do find new log entries they are almost certainly going to be error entries (e.g. I/O errors or messages about corrupt and/or missing physical data).
      >>>>>>> For this case, none of the CD based tools can help! The USB drive system-level errors result in Linux never even providing for application-level access to the device. Therefore, no application tool has any way to access (let alone know of) the hardware device.
      ==> If Gparted does display the new device you can attempt to fix/recover the disk data. Note: for this case you will certainly find system log entries but you may or may not find any error entries among them
  14. delux269

    delux269 TS Rookie Topic Starter

    Sorry for the delay in me responding. I have been busy getting ready for Christmas. I will do these things very soon.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    No apologies needed. Certainly there's other stuff that needs to (and should!) take a higher priortity. Be sure to tend to those things first. I'm not going anywhere. And, besides, i'm damn curious to see how all of this finally plays out!
  16. ackalaka

    ackalaka TS Rookie

    Hello, sorry to interupt but my 1 tb WD My Book Essential did the same thing last night. I searched for a solution to my problem and stumbled onto this thread. Mine is still in original format FAT32 and I've only had it for about 3 months. Up until last night it had performed flawlessly. Anways i was using it with my xbox and when i started to change what file i was playing it began to react very slowly and so i unplugged it and when i re-plugged it in, my xbox didn't recognize it so I moved to the computer and still no luck. I believe its the same symptoms as discussed before; device powers up and connects but the computer doesn't see it as a hdd and doesn't assign a drive letter. When i click on safely remove hardware, i can see it but it doesn't have a drive letter next to it.
    I had read somewhere last night while searching for a cure that some people had removed the drive from the case and connected it directly to their computer and were able to use it fine. So does that mean that its not a hdd failure, just a hardware failure somewhere else like the SATA cable and what-not? Just thought i might mention this since it hasn't been yet... If it comes down to it I might have to buy a new device similar to this one and then work on recovering all my data from this one.
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. Will see if should get your post moved to another thread
    2. As you discovered, the last thing to do, if at all possible to avoid it, is abruptly disrupt/disconnect your external drive. If you happen to catch it at just the wrong moment (e.g. in the middle of critical information being written to the drive) you may corrupt it
    3. The things you'll find listed here are some things to do/ test for / might help when your computer is connected to the drive. Don't know what the instructions should be / you should do when connected from an Xbox (i don't own nor ever used an Xbox. i'm "game challenged" :D )
    4. Tho can state that if you plan to also connect the drive to Xbox, you must continue formatting the drive FAT32 so it can be shared between both an Xbox (which only reads a FAT formatted disk) and a computer

    You can go through this thread to first determine:
    1. is it being seen just fine (2 drivers installed OK) in device manager? then
    2. Is the drive displayed as a DISK in the lower display of Disk Management (important to know if it's recognized as disk or not)

    To answer your other question, if there's a hardware problem with your the drive casing or USB cable (but the internal drive itself is fine) then you should be able to replace the drive casing and find it all works.

    If the internal drive is what failed, then it won't work in a new drive case either. But to help find out you need localize the problem a bit further checking for above possible conditions, changing cables, trying all usb ports, etc,

    You can also look at the draft document i have posted here on other method to help localize and possibly recover that drive [post=701478] Click here [/post]
  18. starstorm2000

    starstorm2000 TS Rookie


    I happened to stumble upon this thread while searching for a solution to my external hard drive. After reading this thread in depth, it seems that my hard drive is experiencing the same issues and displaying the same symptoms as those described here.
    So, I would like to help resolve this issue and be of assistance, using my now non functioning hard drive as another 'guinea pig' to put this problem to rest.

    First of all, I have searched many many threads and sites for a solution. One thing I seen in common across most of the threads is that the hard drive is a Western Digital. The symptoms as well are very similar, being this, and as it is with my hard drive:
    1) The hard drive does not show up in My Computer.
    2) The hard drive does not show up in Disk Management.
    3) The hard drive is recognized by the computer as a USB device and a disk device in Device manager.
    4) When the hard drive is connected, the hard drive spins up, lights up, and the computer 'dings' as an indication that the hard drive has been plugged in. As well, the safely remove hardware option for the drive is listed in the system tray.

    I have tried many methods to get this thing working, including the following:
    1) Tried multiple USB ports.
    2) Tried connecting power supply to both a wall outlet and a power strip.
    3) Tried reassigning my CD drive which happened to take the place of the "E:" drive, hoping it would 'free' that spot up for my hard drive.
    4) Unplugging ALL USB devices, shutting down the PC, starting it back up, and plugging everything back in, Hard drive first.
    5) Cleaning the cables.
    6) Disabling the IEEE 1394 Bus host controller.
    7) Removing the hard drive from the casing to check screws- they are all tightened.
    8) Ran WD diagnostics- it gave me this error: Cable error! Check cables. Which is odd, because I also performed this action after knowing of that "cable error"
    9) Downloaded and ran a program called Testdisk. This program allows you to select a disk and run a check on it to see if partitions are properly working. It will also show you deleted partitions for recovery. As well, it will tell you what partitions are good and what ones are corrupted. I ran this test on my HDD... and the test passed. Which is odd, because if the cable was bad, this test shouldn't have been able to start at all. Much less my drive show up on the list of testable drives.

    I took apart my hard drive and found that it consists of 3 main parts. The first is the outer casing. The second is the hard drive itself. The third is a SATA to USB converter. (may be different depending on what HDD you have). Mine in particular is that- a SATA to USB converter, with an external power supply input. This is just a circuit card that has an attached jack that plugs into the hard drive, and has a USB and power supply jack built into it, and screws onto the hard drive, with a protective metal case that covers it.

    So, this brings me to a speculation, which is being confirmed by this piece of information I have found in other threads: other people have been able to mount their drive as a slave (secondary) drive to their computer, and can access it. So, this means the problem isnt the hard drive itself. However, I have a laptop and am unable to mount it directly to my computer as a slave drive.
    My speculation is that the problem lies in that SATA to USB circuit card. It has simply gotten damaged or just quit working properly.
    I can't confirm this just yet, but this is what I plan on doing first chance I get.

    There is a cable you can purchase. It is a SATA to USB cable. They make them as well with an external power supply that plugs into the SATA connecting end of the cable. There is also a SATA to firewire cable that can be purchased. (Firewire is a better choice for an external hard drive- faster information speeds)
    So, once I get my sata cable, remove the sata to usb circuit card thats on my HDD, and confirm that it works... or does not work... I will post my results here.

    Oh, and here are my HDD specs:
    1TB Western digital. Model number WD10000H1U-00.
    compe specs: Acer laptop, WinXp SP3.

    Didn't work. Purchased an external SATA/USB casing. (Functions the same as just a cable.)
    I also tried plugging it into another PC, running on vista... and the issue was the same on that PC.
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hi starstorm2000

    First of all, good post! :grinthumb Lots of good detail as to your own results with your USB hard drive. A couple of questions/comments:

    1) You said you “downloaded and ran TestDisk”.
    => Did you run TestDisk as an executable in your current Windows environment? Or
    => Did you download and boot into some environment where you ran it?
    Underlying point being when you said it was able to succesfully detect your hard drive and drive partition data was it running within your current software environment or did it side-step the current software and provide all of its own run-time environment??

    2. I’ve found some cases that seem to relate to XP SP3
    where people have noted the problem occurs immediately or soon after upgrading XP SP2 to SP3. (And their problem goes away when they uninstall XP SP3). I’ll add, if this is true, it’s certainly limited to some situations and is not true for all cases when upgrading from SP2 to SP3
    => Do you recall if your problem started sometime around your upgrade to XP SP3?

    3. Verify the Filter Drivers
    (as well as the driver) which applies to USB disk. Click here for a good explanation of Filter Drivers as well as a freeware tool to report them. (A faulty Filter Driver can affect the I/O data between you and the disk drive)
  20. starstorm2000

    starstorm2000 TS Rookie

    I ran testdisk with a normally booted up windows. However, testdisk isnt a regular program- rather, it runs in a command prompt.
    Also, take this into consideration. I booted up my PC and hit F12 upon startup to get to the multiboot menu. It showed me 4 locations to boot my PC from, one of them being my external hard drive! (Of course, choosing this option does nothing, as there is nothing on the drive to boot my PC off of.) So, my PC is able to see my HDD BEFORE loading into a windows environment. As far as being able to see what is on it, I don't know yet.

    Here is a 'timeline' of my problem. In mid december was the last time I used this HDD on my laptop. I went home to my hometown/parent's house for christmas/new year's. I did not use the HDD with my laptop at anytime during my 'vacation.'
    However, I did connect my HDD to my xbox to (successfully) play music off of.
    During the whole time there, my computer was connected to my parent's home network, which on the network, my parents have an external drive (Western digital, and of a letter designation of "E:") connected to the main network computer, and is accessible by all other computers connected to the network.
    Just before I left to return to my current location, my brothers wanted to attempt to transfer xbox saved game data they had accumulated on my xbox over to their xbox hard drive... so, we 'tried' to use my HDD to transfer the data. However, I noticed that the xbox didnt even recognize my HDD when this was attempted. I, however, didn't think too much of it, and thought it was just the xbox's way of telling me that the HDD can't be used to transfer the data (confirmed by googling it in an attempt to find out how to transfer data.) But, now that I come to think of it, that may be where my problem started, if not earlier, because my xbox was the second thing I tried when I got back from vacation after finding out the HDD doesn't show up in my computer.

    As for the drivers, I will look into that and report my findings.
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Some general additional info.... (I 've skimmed but not haven't "fully digested" the info in latest post from starstorm2000)

    An interesting observation: all 3 who’ve posted problems to this thread: delux269 (who originally started the thread), ackalaka and starstorm2000 you're all formatted FAT32.

    Notes on FAT vs NTFS formatting
    1) Xbox and MP3 players as well as other consumer devices (not computers) might require FAT32
    2) But if at all possible (e.g. you only connect to your hard drive to own and/or other computers) best to use NTFS not FAT32 formatted data
    => You can re-format the entire drive NTFS (which wipes any current data)
    => Or do a convert (which should preserve current data as it changes the formatting from FAT32->NTFS)
    => just fyi.. I’m not aware of a tool that converts formatting from NTFS back to FAT32. This would require a full drive reformat to FAT32 which wipes any current data from the drive.
    3) NTFS incurs a bit more system overhead but is more fault-resistant
    4) I don’t own/use Xbox so don’t know nor have I tried to check.. but does anyone else know if Xbox requires the entire drive is FAT32 or does it allow for one FAT32 partition to exist on the drive? Such that you’re able to format other drive partition(s) as NTFS?

    You can look [post=701478]at this post [/post] (updated). You might choose to build/test from a bootable CD to see if:
    => You can recover your data using the boot CD
    => The problem only occurs when loading/running the software you have stored on your hard drive. The problem might not occur if running strictly from software burned onto the CD. (e.g. if a virus or Windows bug is causing the problem)
    => The post mentioned above also tells how to check if system level errors are occuring when running running Linux off the CD (vs. Windows from your hard drive). If you find Linux system level errors probably indicates Windows system level occurs are ocurring as well

    And in any case, check Windows Event Logs http://support.microsoft.com/kb/308427 System and Application logs for any indication of errors related to your USB hard drive
  22. starstorm2000

    starstorm2000 TS Rookie

    Filter Driver Load Order

    Upper Class Filter: PartMgr
    Device Object: WDC WD10 EACS-00ZJB0 USB Device
    Lower Filter Drivers: No Lower Filter Drivers specified for this device

    Driver Name: partmgr.sys
    File Location: c:\windows\system32\drivers
    File Description: Partition Manager
    File Version: 5.1.2600.5512 (xpsp.080413-2108) [5.1.2600.5512]
    Product Name: Microsoft® Windows® Operating System
    Product Version: 5.1.2600.5512 [5.1.2600.5512]
    Company Name: Microsoft Corporation

    That is the report for the filter driver program.

    I have thought about just formatting the drive and 'hopefully' at least being able to use the drive again even if it means losing the data. But only as a last resort. However, I am unsure of how to go about doing it, since I can't see the drive anywhere.
    But, if I can manage to recover the data off the drive, then reformat it and get it in working condition, then so be it.
  23. starstorm2000

    starstorm2000 TS Rookie


    I downloaded the windows xp SP2 system tools, and ran DSKPROBE.EXE.
    The program was able to detect 2 drives, but labels them as PhysicalDrive0, and PhysicalDrive1.
    Im assuming 0 is my C: hard drive, and 1 is my external.
    I ran the program to read sectors 0 (Partition table) and 63 (Boot sector) of both drives. Drive 0 was readable. I couldn't understand what all the numbers meant, but it displayed something. Drive 1 however gave me a Cyclic redundancy check error on both sectors.
  24. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for the update!

    Have been meaning to add some info about post before last which is re-confirmed by prior post.

    When you had said
    I was going to point out:
    => There are multiple levels at which a device can "be seen"
    => That most of us (me included) mostly go looking for a volume letter or at least seeing the Disk represented in Disk Management
    => Or the device as DISK or USB device in Device manager

    but the REAL starting point for a device beneath all of those "levels" mentioned above is the raw physical connection (providing the I/O data stream) between your computer and the device referred to as the "raw device". Was going to suggest would need to find and start with a tool that can read from the "raw device" rather then only able to read from a higher device level as most tools do.

    I'd completely forgotten about DISKPROBE tool (thanks for reminding). And will guess it reads the raw device (but will also follow and take a look) and provide further comment.

    /*** EDIT ***/
    There are some other potentially useful tools but need go find them/download links again. But here's one if you're comfortable prowling around at the system level see everything organized by Drivers or Devices using tool DeviceTree. Note that it can take several minutes for DeviceTree to refresh and present a new view

    And also checkout DiskView

    /** EDIT **/
    btw... Nothing unusual about the filter drivers reported earlier.... PartMgr is a standard one
  25. majikstranger

    majikstranger TS Rookie

    I had the same issue and solved it by downloading and running partition table doctor. It said it was a MBR problem and it fixed it
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...