What to do if your external hard drive does not show in my computer

no option to change number???

hello, ive tried going into the disk management to change the letter as it was not showing up on my computer and the hard drive in the list did say not initialised ive now done that an now it says unallocated and it doesn't give me the option to change the number, only help, properties and new partition should i set up a primary or extended partition, please help
 
I am having the same problem.............I tried what ever has been told above..........bt my problem is when I try to name my HD there isn't any option of naming it in the device management!I m using windows xp!is there any way out!

i'm having the exact same problem did you find an answer please help
 

LookinAround

Posts: 6,429   +186
hello, ive tried going into the disk management to change the letter as it was not showing up on my computer and the hard drive in the list did say not initialised ive now done that an now it says unallocated and it doesn't give me the option to change the number, only help, properties and new partition should i set up a primary or extended partition, please help

You're talking about an external USB drive, right? If it now says "unallocated" then you next want to create a partition. You can right click select New Partition and create the partition. I'm guessing the drive will just be for your data? So make it any partition type should be OK.
 
Right click on my computer
Choose MANAGE
Then find DISK MANAGEMENT
You should see your ext hard drive under the list.
Right click on it, and choose "NEW SIMPLE Drive", click "Next".
CHANGE DRIVE LETTER,and format. It should show up in Your Computer.
Choose anything, but I recommend something higher than M:

You Must Click: "New Simple Drive" ...
... or you will not get to the option to change Drive Letters & Format :)

Hope This Helps, I just did it & worked like a charm !

Blessings All;
Chaz Tucker
 
I am Pleased to have been able to help out.
After reading the whole post about this problem, i started to investigate it.
I wondered why no one mentioned anything about the "New Simple Drive" option ?
So I gave it a try, and it was indeed the fix I was after !
After I succeeded, I joined TECHSPOT, and posted what I had discovered.


Rock On !
Chaz T.
 
Works with exFAT drive

I was hoping that I could use my Western Digital jump drive for external storage with my XBOX. It does not accept NTFS, so I reformatted it with exFAT. The XBOX did not like it, so I wanted to reformat it back to NTFS. When I plugged in the USB cable, the computer did not show up in Explorer. It did show up in Computer Management>>Disk Drives, and when I told it to update driver software, it said it was current.

My computer drive configuration is:
C: - primary
D: - recovery
E: - CD/ROM
F: - separate drive for misc files (music, video, photos)

I used your solution and reassigned the F: drive to L: (any letter will do here). When I plugged the USB drive back in, it did not show up in Explorer but was in Computer Management as an unallocated drive. Here I could reformat back to NTFS. Thanks a bunch!!!
 
testdisk question

testdisk works great but i have over 1tb of files on this ext hd and i don't know if i'll have the room for all of the files cuz my laptop's c drive only has 102gb (before copying the files) i just installed win 7.
 
I cannot seem to do anything. The choices are grey'd out.

Can someone please help me with this??

I have taken a screen shot but because this is my first post on this forum, I am not allowed to post links or images.

Please do the math:

[ I M G ] http : / / i42. tinypic. com / dnc3vb.jpg [ / IMG ]
 

LookinAround

Posts: 6,429   +186
I cannot seem to do anything. The choices are grey'd out.

Can someone please help me with this??

I have taken a screen shot but because this is my first post on this forum, I am not allowed to post links or images.

Please do the math:

[ I M G ] http : / / i42. tinypic. com / dnc3vb.jpg [ / IMG ]
Hi ktpierce and welcome to TechSpot :wave:

Based on the lower pane in your snapshot Disk 2 must the one your talking about. Note it shows 2 partitions
> The first is 200MB and indicates its the EFI System Partition
> The second is 297GB of unallocated space!

1. I googled EFI System Partition. It's used by some machines/devices but as it's only 200MB (quite small in size) I'd leave it as is (instead of trying to figure out if you really need it and/or what it does)
2. The rest of the disk needs to be allocated before it can be assigned a drive letter and used. Rt click on the Unallocated and check your choices. http://ask-leo.com/how_do_i_use_an_unallocated_space_partition_in_windows_7.html

/* edit */
p.s. and CLICK HERE for ktpierces's link if anyone else is looking
 
accidentally changed drive letter on c drive

Followed advice on this thread to change drive letter but changed "C" to "N." Now I really screwed up and can't even start computer since c drive isn't accessible. I can explain more if anyone can help. Thx.
 
Followed advice on this thread to change drive letter but changed "C" to "N." Now I really screwed up and can't even start computer since c drive isn't accessible. I can explain more if anyone can help. Thx.

was ur external hd drive letter really c that doesn't sound right.
 
no external hard drive was E but computer wasn't detecting it anymore. When I followed advice to go in and change drive letter, I didn't know I was changing C drive (it said "O") but all info related to C drive is wiped out, no desktop, can't even access "My Computer," so I know it was C drive I changed to "N."
 

LookinAround

Posts: 6,429   +186
You don't want to change the drive letter for the disk volume that has Windows installed (e.g. C)

Google Advanced Start Options for your version of Windows and try booting into Last Known Good Configuration.

Otherwise google System Restore for your version of Windows and restore to a time before the problem
 
Agree, now in retrospect, to not ever change drive letter on "C." It said "O" and I didn't realize what I was doing . . . but it crashed everything.

Tried Last Known Config but get same looping result as regular start up looping problem. Safe Mode wasn't even accessible (Windows logo just kept blinking on and off but was in an unending loop too). Thus, couldn't do System Restore either.

Next, tried Repair (R) option by booting with re-install disk. Voila!!! This was the fix. Yay!! After the whole repair process (about 30 min), it auto restarted as it should but kept saying "please wait" in the black windows opening screen. Waited about 30 min. Figured this wasn't going t/b solution so turned off. Then, rebooted quickly taking out re-install disk. It started normally and perfectly. All my files are there and accessible again as if this all never happened. SOOO glad I did "repair" with re-install disk first instead of what I was very tempted to and advised to do -- a re-install that would have wiped out all files, settings, drivers, etc.
 

LookinAround

Posts: 6,429   +186
<snip>Next, tried Repair (R) option by booting with re-install disk. Voila!!! This was the fix. Yay!!
Woo-Hoo! Great job! Glad you figured this one out and thanks for posting your result.

We all learn from experience (sometimes even bad experience) but glad this one turned out good in the end!

Happy Computing :)
 
My external harddisk is not initialized yet and a error comes up when i try to initialized it..can anyone help me with it?
 
none of the above

My problem seems to be different from the ones previous. I got an SSD and planned to use the HDD I was replacing as an external drive in an enclosure. When I connect the (now) external drive it is recognized in device management, but not in disk management. I've tried three different enclosures with no success each on three PCs. I can put it back in the laptop and still boot off the drive so I know its still good. While installed in the laptop, I booted on a gparted live cd and was able to format it as fat32 and ntfs. When I made it an external drive gparted could not see it. What could be wrong?
 
Seriously Stuck...

Guys please help.

i recently bought 1tb WD External HD. I have approx 750 GB stuff on it at the moment. I was using it the other day and it dropped while it was plugged in to my laptop. since then I cant find it in my computer. when I plugg-in, it makesa beep-noise, light comes on but NO SHOW in y computer.

I followed the steps given above -
My computer - Manage- Disk mngmnt - etc but when I click on Disk management --> it says INITIALIZE DISC - and I get two option to initialize the disc with
1)MBR
2)GPT
when I choose MBR and click OK - it says THE MEDIA IS WRITE PROTECTED. and I get back to the square one. It is so frustrating. i have got very important presentation and files on my HD. please help.




Thanks in advance.


is there any1 to help??? plz
 
I've tried the Computer Management before but never thought of changing drive letter.
Thanks MrNoname, it worked like a charm.
 
Easy to FIX

Right click on my computer
Choose MANAGE
Then find DISK MANAGEMENT
You should see your ext hard drive under the list.
Right click on it, and choose CHANGE DRIVE LETTER
Choose anything, but I recommand something higher than M:

I've seen this problem with alot of STORAGE DEVICE

It happen more often with Laptop because they usually have Card reader.
So it makes couple drives like e:, f:, g:.
Storage device tries to install themself with the drive letter next to CDROM
c: - HD1
d: - HD2 or CDROM
e: - Mass storage device (maybe for card readers)
So your external HD tries to have the E: drive (probably a bug)

See ya
my external hdd not displaying in disk management also. how to solve my problem? anybody can help me? [email address removed]
 
cheers I knew what it was just couldn't find it thanks, anytime I try to do anything to the drive like change drive letter, format it or even check the properties it says:
The operation failed to complete because the disk management console view is not up-to-date. Refresh the view by using the refresh task. If the problem persists close the disk management console, then restart disk management or restart the computer.
An Ive tried them all, not sure what to do now please help!
 
Hi, I have a Hitachi 2T external HDD with 5 partitions and initialized with GPT. It was working well for quite some time until suddenly my Vista notebook is unable to detect it. I tried to use disk management to check but the application hangs. I have over 1T of important data in it. please help.
 
Im having a similar problem the external hard drive wont show up in my computer but the light comes on and the pc makes a noise so the cable is working fine what shall I do