Sharing files from an external hard drive to multiple computers

JoeVM

Posts: 59   +1
I have a desktop computer and a laptop that I'm trying to share an external hard drive between them. Both computers are running Windows 10 and are both hard wired. The desktop has a Western Digital My Book attached to it through a usb connection. The laptop that I'm trying to share it with keeps saying it cannot access the drive. When I click on troubleshoot I get an error saying:

Your computer appears to be correctly configured, but the device or resource is not responding.

How do you connect the two so I can share files with one another? I tried all kinds of steps prior to posting here and nothing seems to be working. Hopefully someone here can help me.
 
Last edited:

JoeVM

Posts: 59   +1
My apologies. This has got me really frustrated.

Yes the drive is shared. I went to the drive I want to share then properties>sharing and clicked on advance sharing. I selected share this folder then permissions and selected allow all. Applied all the changes and clicked ok. I then went on the laptop I want to share the folder with and clicked on advance sharing. I turned on network discovery, turned on file and printer sharing under Private. I turned off network discovery and file sharing for guest or public. Under All Network clicked on use 128 bit encryption, and turn on password protected sharing. I made sure the same setting were checked on the Desktop as well.

I was messing with the desktop that has the external hard drive and laptop I'm trying to share with. I got the error message to go away but the Desktop I'm trying to share the drive from is not showing up under network on the laptop. On the Desktop I can see the desktop and laptop listed under network. On the laptop I just see the laptop network.
 

Gabriel Pike

Posts: 253   +69
I usually do this by PC name. Then just map the drive. If you know the name of your server PC it will make this easier. Are you trying to make a mapped network drive? If you have shared it correctly then you should be able to get to it in a file explorer by typing this \\server name\share name. If you are trying to make it easy first and add security second perhaps temporary disable password protected sharing. I do not recommend that you leave it this way but for testing it removes one layer of difficulty. Also can you ping the server name?
 
Last edited:

JoeVM

Posts: 59   +1
Yes. I'm trying to map an external hard drive to share over my network. I though share and map were sort of the same thing ? I'm not sure how to ping the server name. Also, I tried to type in the Computer name and share name and it says not found. in my case this is what it would be\\DESKTOP-LENOVO\WDMyBook. Sorry if I sound like a noob, all of this is new to me.
 
Last edited:

Gabriel Pike

Posts: 253   +69
So, lets start with ping. Open a cmd or powershell by clicking start and typing either one. Then in the window that pops up, type ping desktop-lenovo and then enter, and you should get a reply on the laptop.
 

JoeVM

Posts: 59   +1
Thank you. I tried it and got the following:

C:\Users\JMeye>ping desktop-lenovo

Pinging Desktop-Lenovo [fe80::787f:d492:50f3:479a%5] with 32 bytes of data:
Reply from fe80::787f:d492:50f3:479a%5: time<1ms
Reply from fe80::787f:d492:50f3:479a%5: time<1ms
Reply from fe80::787f:d492:50f3:479a%5: time<1ms
Reply from fe80::787f:d492:50f3:479a%5: time<1ms

Ping statistics for fe80::787f:d492:50f3:479a%5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
 

Gabriel Pike

Posts: 253   +69
This is good. So, the path may be incorrect. Did windows assign a drive letter to the MyBook?

(eg. \\DESKTOP-LENOVO\E)
 

JoeVM

Posts: 59   +1
Under sharing for The external hard drive it says

E:\
Shared

Network Path:
\\DESKTOP-LENOVO\WDMyBook
 

Gabriel Pike

Posts: 253   +69
Does your desktop have more than one user account?
If not you may need to add an additional user or disable password protected sharing.
 

Gabriel Pike

Posts: 253   +69
Something must be incorrect on the share side then. So to recap. When you put \\DESKTOP-LENOVO\E into a file explorer window it does not connect after setting the drive to shared with everyone and password protected sharing is disabled? Does it give you any error?
 

JoeVM

Posts: 59   +1
Yes, that is correct. It shows up under network on my desktop but not on my laptop. If I use file explorer on the other computer and search for \\DESKTOP-LENOVO\E it says it can not be found. I did not get an error.
 

Gabriel Pike

Posts: 253   +69
I am sorry but this is the end of where I can help. I'm goint to ping another member that provides good information.
@MattS Do you happen to have any ideas on why this is not working?
 

bazz2004

Posts: 1,762   +295
You have an external hard drive which connects by usb to both PCs. Isn't it easier to plug it into the computer you are using as and when rather than worrying about networking?
 

Kshipper

Posts: 593   +137
TechSpot Elite
If you are using the same username on each machine then add a password to both machines that is also the same. Then sharing will work, although I have never shared a USB drive before. You could also just try sharing something else (just as a test) to see if this sharing problem is isolated to the USB drive
 

Kshipper

Posts: 593   +137
TechSpot Elite
Oh and one other thing. Sometimes I have to add users to the the 'Security' tab on a shared resource. I often use 'Everyone' as a user so that the resource I want to share is shared with anyone who is authenticated (which is the fancy way of saying they are using an account with a password). You should also check off 'Full Control' otherwise it might be 'Read Mode' only.

I was wondering if the USB drive is NTFS formatted ...if it is FAT32 formatted then that might also explain the lack of the 'security' tab where you can't add users to the share.
 
Last edited: