Why are my write speeds so slow? (SSD on SATA3 card)

By Mugsy ยท 6 replies
Jan 20, 2012
Post New Reply
  1. My MoBo is only 2 years old (Gigabyte MA790GS-DS4H, PCIe 2.0, AHCI, Phenom II X4 cpu) but only has Sata-2 ports. I bought a Corsair Force GT 120gb SSD drive last November and wanted to take full advantage of its speed, so I bought a PCIe x1 Sata-3 card (ASMedia ASM1061), which arrived yesterday.

    I ran ATTO before and after so I'd be able to see if there was any difference.in performance:

    With the GT plugged into the MoBo's sata-2 port-0:

    Plugged into the sata-3 card with the MoBo AHCI mode DISABLED (the card has its own AHCI mode):

    With AHCI mode on the MoBo enabled:

    My reads speeds with the card are great (35% increase), but my write speeds fell through the floor (down as much as 80%). Any idea why?

    Help! Thx.
  2. techanswers1

    techanswers1 TS Rookie

    Have you checked the sata port you used is the motherboard's or the AMD chip that is?
  3. Mugsy

    Mugsy TS Guru Topic Starter Posts: 419   +24


    Thanks for the reply, but I'm not quite sure what you're asking.

    I plugged my SSD into the Sata port on my new x1 Sata-III card.

    I have tried turning the MoBo's AHCI mode both on & off (as noted above) and got better results with the MoBo's AHCI mode disabled (possibly conflicting with the built-in AHCI mode on the card.)

    I have tried moving the x1 card to an x16 slot, but it made no difference.

    I tried disabling all my onboard Sata ports on the MoBo, but that too made no difference.

    I tried using the driver on the provided CD. The results were even worse than the MS-supplied driver. (I'm using 64bit Win7 and the provided driver appears to be 32bit.)

    I tested the card/drive in XP (using "AS SSD") and got abysmal results. Not just worse than Win7, but worse than using Sata-II, even worse than my HDD's (scoring 159read/99write). Definitely a driver issue there.

    I have no clue why the card produces such poor write speeds while also producing decent read scores.
  4. Mugsy

    Mugsy TS Guru Topic Starter Posts: 419   +24


    After much searching, I found the solution.

    For others suffering from the same problem... miserable Write speeds with your SSD in Win7... simply go into the Device Manager and disable "Write caching" on the "Policies" tab for your SSD.

    More than TRIPLED my Write speed and even gave my Read speeds a tiny boost!

    "Write caching" is not needed with an SSD.

    My ATTO results with Write Caching disabled:

    (Can't get pictures to show here.)
  5. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    Nice, thanks! I know 2 people with this problem and knew there was a simple fix somewhere.
  6. Mugsy

    Mugsy TS Guru Topic Starter Posts: 419   +24

    I may need to amend this a bit.

    While turning off Write Caching gave me benchmark scores closer to what the manufacture claims the drive is capable of, a few real-world Read/Write tests are showing lousy results.

    Caching may get in the way of benchmarks and misreport your drive speed if you're trying to get accurate benchmark results, but in real-world use, I'm finding some caching still necessary.

    I don't think the built-in Win7 cache system is very smart/good. But do a few copy tests (several gigabytes of large & small files) with the Win7 cache both on & off, then try again using third-party caching software (I found "FancyCache" seems to work well) to see if it makes a difference.

    With caching off, a 4GB copy from one folder on my SSD to another folder on the same SSD took 3-1/2 minutes. With FancyCache, it took only 1 minute. (I don't remember my times using the Win7 built-in cache), so clearly SOME caching is still necessary.
  7. jobeard

    jobeard TS Ambassador Posts: 11,155   +985

    Good work and thanks for the follow-up for others that follow.

    This is a great example of 'there is no free lunch' or 100% benefit and 0% cost.
    Caching is always seen initially as a great idea, but frequently the cost (time to save and deduce a duplicate) quickly eats up the benefit.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...