Wi-Fi stops working

I have same problem.
Recently ISP have changed my ADSL router to vDSL modem/WiFirouter, I'm using assembled service of internet, IPTV and VoIP.

My LAN works perfectly, but WiFi is giving me some hard time:
everything works nice and I'm using internet on my laptop (Lenovo t410 Win8.1), phone (LG G2 andorid), tablet (iPad), but day after all devices are showing that they are connected to WIFI but there is no/or low internet response, for example: skype works but cant open some pages, other are opening but some images don't load (fb etc.). I can't log in into router to reboot it.
And this issue when internet isn't working normally but showing as connected persists on all devices I've mentioned above. But at the same time when internet isn't working, when I try it on my desktop PC (Win8.1) everything works normally.

Then I need to go to router turn it off then on and everything works perfectly, sometimes for a day, sometimes for a couple of days.

I've tried everything, changing IP lease time, changing freq form 20 to 40, changing channels, switching from b/g/n to N, almost everything I could think of...
My WiFi is secured with WPA/PWA2-PSK-TKIP/AES password, and name is a simple one with 3 char name.

My modem/router information's are:
Device Type ZXHN H367N
Device Serial No. ZTEEG03E7812096
Batch No. T2
HW Version V1.2.0
SW Version V1.0.0_L_BOSNIA
BOOT Version V1.0.4

do anyone have an idea what it can be the reason why this is happening?


Posts: 32   +9
NetWalker85. Since your desktop works when your wireless devices don't, it's not your Internet signal from your ISP. Your devices are showing the router's SSID which is being broadcast, but not the wireless internet signal from the router. I would reset the modem/router to it's default settings and change the necessary items (SSID and passwords,security settings, max number of IP addresses for the router to assign to devices,etc). if that was never done. If the problem is still there, I would request a new combo unit, or possibly see if there is a firmware update for that combo unit.
@TheHawk - thank you very much for you reply. I've figured that out, that ISP is OK since LAN is working normally but WiFi don't. The confusing part is that the WiFi connected devices are on the internet also, but with much of errors in traffic or something - since Skype works for some reason while I cant open any website - and at the same time on LAN everything works perfectly!
I was thinking on resetting the unit, but ISP have a lot of vDSL and IPTV settings on it, and I'm afraid they will charge me the re configuring it... I've tried isolating wifi signal etc with some options in the route - but that didn't help also.
Last resort is to ask ISP to change the whole unit since I'm experiencing the issues with WiFi..
I'm writing here only for one reason - since they locked all LAN ports except #1 port, I've brute force the unit password and turned on #2 LAN port since I need it for my NAS server which don't have WiFi option network access. And I believe that the issue started afterward... I believe - I'm not sure!

I have a couple of ideas myself:
WiFi channel overlapping - it is set on AUTO atm
DHCP settings issue
faulty unit
Im having the exact same issues with this Modem/Router.
If skype is working but everything else isnt, that is usually an issue with the DNS provider.
Skype never or rarely does and DNS Lookups and doesnt need working DNS to work properly, so my guess is that our Modem/Router somehow loses the ability to provide the devices with proper name lookups. You can change your adapter settings on your laptop and set your DNS as (the default google DNS) or your ISPs DNS server so you bypass the DNS Service of the router. I hope this helps