Win 7 Pro x64 BSOD, can't figure it out, dump files attached

By gexamb ยท 9 replies
Jul 8, 2010
  1. Hey guys,

    I hope someone can help me. I got some dump files from a client's computer i built a few months ago. Its a brand new build, modern hardware, windows 7 pro.

    Never had an issue with it when i was building it. now about every 2-3 weeks it gets a BSOD. Since it is a client machine, i dont know when it happens or how it happens or why. All i have with me is the mini dump files.

    can someone take a look at it for me? Thanks


    EVGA H55 Mobo
    Intel Core i3
    no video card - uses the new onboard chip rendering on the i3
    4 gb ram 1033
    430W PSU Antec

    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    F.Y.I. the mods will most likely move this to the BSOD forum.

    I read the first five minidumps of Zip1 and the first four are the same error code of 0x00000050: PAGE_FAULT_IN_NONPAGED_AREA
    Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

    All four specifically cited corrupted memory as the issue. You'll need to run Memtest for a minimum of 7 Passes (the more the better) unless you start receiving errors before hand. If so then run it per stick. Any errors and that memory stick needs to be replaced.

    *** If Memtest shows no errors then find the voltage specs of your RAM and compare it to the voltage setting in your BIOS. Do they match?
  3. gexamb

    gexamb TS Rookie Topic Starter Posts: 106

    Thanks boss, really helped me. I was thinking of ram the whole time but didnt test it before i deployed it.

    i also use LogMeIn on the my clients so that might be a problem as well? Although this would be the first one to cause any problems. Unlikely

    using symantec endpoint protection.

    i will run memtest next time I am up there. i will keep posted
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Yes, please keep us updated.
  5. gexamb

    gexamb TS Rookie Topic Starter Posts: 106

    Ok, the ram was a culprit, one of the sticks had a few errors. So I rma'd it and got a new set. It still does the BSOD's. Although i ran memtest on the new ram and it had absolutely no errors.

    What else could it be? Here is a message from the event viewer.

    The computer has rebooted from a bugcheck. The bugcheck was: 0x0000000a (0x0000000000000411, 0x0000000000000002, 0x0000000000000001, 0xfffff80002e7984c). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 081110-26442-01.

    I looked at the memory.dmp file and it is over 360 MB so i cant post it.

    But here are some more minidump files after I added the new ram.

    What can I do? Need help ASAP.

    Attached Files:

  6. gexamb

    gexamb TS Rookie Topic Starter Posts: 106

    Here is the readout of the memory.dmp check

    2: kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If a kernel debugger is available get the stack backtrace.
    Arg1: 0000000000000411, memory referenced
    Arg2: 0000000000000002, IRQL
    Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
    Arg4: fffff80002e7984c, address which referenced memory

    Debugging Details:

    Page 11c0b5 not present in the dump file. Type ".hh dbgerr004" for details

    WRITE_ADDRESS: 0000000000000411


    fffff800`02e7984c f00fba2e07 lock bts dword ptr [rsi],7



    PROCESS_NAME: audiodg.exe

    TRAP_FRAME: fffff8800618c250 -- (.trap 0xfffff8800618c250)
    NOTE: The trap frame does not contain all registers.
    Some register values may be zeroed or incorrect.
    rax=0000000000000cc2 rbx=0000000000000000 rcx=0000000000000002
    rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
    rip=fffff80002e7984c rsp=fffff8800618c3e0 rbp=0000000000000000
    r8=fffff78000000008 r9=0000000000000000 r10=0000000000000000
    r11=fffff88002f63180 r12=0000000000000000 r13=0000000000000000
    r14=0000000000000000 r15=0000000000000000
    iopl=0 nv up ei pl zr na po nc
    fffff800`02e7984c f00fba2e07 lock bts dword ptr [rsi],7 ds:00000000`00000000=????????
    Resetting default scope

    LAST_CONTROL_TRANSFER: from fffff80002e6fb69 to fffff80002e70600

    fffff880`0618c108 fffff800`02e6fb69 : 00000000`0000000a 00000000`00000411 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
    fffff880`0618c110 fffff800`02e6e7e0 : 00000001`06060000 00000000`00000000 fffff880`0618c258 fffff880`00000000 : nt!KiBugCheckDispatch+0x69
    fffff880`0618c250 fffff800`02e7984c : 00000000`00000000 00000000`00000000 fffffa80`0590f820 fffffa80`0590d930 : nt!KiPageFault+0x260
    fffff880`0618c3e0 fffff880`0518d6e8 : 00000000`00000000 fffff800`00000000 fffff880`00000000 fffffa80`0590dc00 : nt!KeWaitForSingleObject+0x13c
    fffff880`0618c480 fffff880`0514a06b : 00000000`00000002 00000000`c0000001 fffffa80`06423a70 00000000`00000001 : RTKVHD64+0x1826e8
    fffff880`0618c4d0 fffff880`052936da : 00000014`00008004 00000000`00000000 00000000`00000000 00000000`00000001 : RTKVHD64+0x13f06b
    fffff880`0618c5d0 fffff880`05291b42 : fffffa80`06445c40 fffffa80`067281d0 00000000`00000001 fffffa80`054b98b0 : portcls!CPortPinWaveRT::DistributeDeviceState+0x8a
    fffff880`0618c630 fffff880`04536815 : fffffa80`054b98b0 fffffa80`050b4b70 fffffa80`067281d0 00000000`00000000 : portcls!CPortPinWaveRT::powerNotify+0x772
    fffff880`0618c670 fffff880`0454253f : fffffa80`054b98b0 00000000`00000004 fffff880`0618c790 fffff8a0`03829fc0 : ks!KspPropertyHandler+0x735
    fffff880`0618c6e0 fffff880`0527c944 : fffff880`0618c790 fffff8a0`03829fc0 fffffa80`054b98b0 fffffa80`054b9ae8 : ks!KsPropertyHandler+0x1b
    fffff880`0618c730 fffff880`05291055 : 00000000`00d5e200 fffffa80`054b98b0 fffffa80`06445c40 fffff880`0525f0cb : portcls!PcHandlePropertyWithTable+0x64
    fffff880`0618c760 fffff880`0527bfa1 : fffffa80`054b98b0 fffffa80`050b4cc0 fffffa80`050b4cc0 fffff800`0316970c : portcls!CPortPinWaveRT::DeviceIoControl+0x1c1
    fffff880`0618c7c0 fffff880`0453601b : 00000000`c000000d fffffa80`050b4cc0 fffffa80`050b4b70 fffff800`03111166 : portcls!DispatchDeviceIoControl+0x79
    fffff880`0618c7f0 fffff880`0527b06c : 00000000`c0000001 fffffa80`01c0bc60 fffffa80`054b9ae8 00000000`c0000001 : ks!KsDispatchIrp+0xdb
    fffff880`0618c820 fffff880`0514fe26 : fffffa80`054b98b0 fffffa80`050b4cc0 fffff880`00000000 fffff880`0618c860 : portcls!PcDispatchIrp+0x5c
    fffff880`0618c850 fffff880`052c0674 : fffffa80`054b9ae8 fffffa80`0560d680 fffffa80`054b98b0 fffffa80`0560d680 : RTKVHD64+0x144e26
    fffff880`0618c880 fffff880`052bdc21 : 00000000`00000001 fffffa80`054b9b30 fffff880`0618cb00 fffffa80`05f93700 : ksthunk!CKernelFilterDevice::SynchronousForwardIrp+0x70
    fffff880`0618c8e0 fffff880`052bda87 : fffffa80`054b9802 fffffa80`054b98b0 00000000`00000000 fffff880`0618ca20 : ksthunk!CKSThunkDevice::CheckIrpForStackAdjustmentNative+0x171
    fffff880`0618c980 fffff880`052bd79b : 00000000`00000001 fffffa80`054b9b30 fffffa80`0560d680 fffffa80`054b98b0 : ksthunk!CKSThunkDevice::DispatchIoctl+0xcf
    fffff880`0618c9b0 fffff800`0318c6b7 : fffffa80`063e6720 fffff880`0618cca0 fffffa80`00000000 fffffa80`063e6720 : ksthunk!CKernelFilterDevice::DispatchIrp+0x93
    fffff880`0618ca10 fffff800`0318cf16 : 00000000`00d5e0a0 00000000`000003b9 00000000`00000000 00000000`00000000 : nt!IopXxxControlFile+0x607
    fffff880`0618cb40 fffff800`02e6f853 : fffffa80`064f7550 00000000`00d5e088 fffff880`0618cbc8 00000000`00000001 : nt!NtDeviceIoControlFile+0x56
    fffff880`0618cbb0 00000000`7714ff2a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
    00000000`00d5e058 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7714ff2a


    fffff880`0518d6e8 3b6b30 cmp ebp,dword ptr [rbx+30h]


    SYMBOL_NAME: RTKVHD64+1826e8

    FOLLOWUP_NAME: MachineOwner




    FAILURE_BUCKET_ID: X64_0xA_RTKVHD64+1826e8

    BUCKET_ID: X64_0xA_RTKVHD64+1826e8

    Followup: MachineOwner
  7. gexamb

    gexamb TS Rookie Topic Starter Posts: 106

    Also found this:

    wuaueng.dll (928) SUS20ClientDataStore: The database page read from the file "C:\Windows\SoftwareDistribution\DataStore\DataStore.edb" at offset 101646336 (0x00000000060f0000) (database page 3101 (0xC1D)) for 32768 (0x00008000) bytes failed verification due to a page checksum mismatch. The expected checksum was [6dad925236f406e2:79087908683d0c48:7bbb7bbbea530c08:5e8f5e8f7fd90c5c] and the actual checksum was [6dbd924252f462e2:1d081d08683d0c48:7bbb7bbbea530c08:5e8f5e8f7fd90c5c]. The read operation will fail with error -1018 (0xfffffc06). If this condition persists then please restore the database from a previous backup. This problem is likely due to faulty hardware. Please contact your hardware vendor for further assistance diagnosing the problem.
  8. gexamb

    gexamb TS Rookie Topic Starter Posts: 106

    Also I noticed that the external drive connected to the PC has died. I cant open the drive, says please insert removable disk even though it is connected and powered on. I looked at device manager and it says there is an unknown USB device. can this cause BSOD of this nature?

    Please help!!!
  9. gexamb

    gexamb TS Rookie Topic Starter Posts: 106

    Please someone take a look at this list of event logs. I still cannot figure out what the problem is. I dont have anymore dump files since the ones i posted earlier even though the computer is still getting BSOD's. However I did exchange the ram and now no errors on the ram. I get no more bugcheck errors in event viewers. but something is still causing these BSODs and hangs. Please help me.

    Attached Files:

  10. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Your issue appears to be with your onboard RealTec sound, perticurlay with the driver RTKVHD64.sys.

    Update the sound drivers from the manufacture.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...