Win 7 software fix followed by Excel files not recalcing

By Doug8765 ยท 8 replies
Dec 21, 2009
  1. On Saturday, two days ago, my HP computer told me I needed a bug fix (QFE 975741), which I told it to do.
    When it was finished, it gave me the message that the bugfix might not have installed correctly. Did not know if that was meaningless.
    Today when I was building Excel 2007 files (files that I have used hundreds of times over more than a year) I found that the files did not recalc unless I saved the files. Recalc did not happen.
    I undid the bug fix - using Control Panel | Programs | Programs and Features | Installed Updates | Uninstall an update - and the Excel files still do not recalc.

    Am I completely off the mark? What changed that now my files do not recalc?

  2. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Which office package do you have? 95, 97, 2000, XP, 2003, 2007, 2010B?

    I would backup the XLS and uninstall the Office then run Ccleaner to clean out the junk files and the registry on the next reboot. Then install a copy of Office. Don't forget to get the updates. Still what might have happen that one of your Macros you use for Excel go deleted in the bugfix. If you have IT support or someone else there you could copy over the macro over to your system.
  3. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi Tipstir - I use Office 2007. - Doug
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Do you have the latest service pack for 2007. Oh whatever you do don't install 2010beta as it might look great but it has way to many bugs in to keep on the system. Anyway sounds like the patch corrupted data or Office some how. You can repair Office under Programs in the control panel. There is also free software repair for Office check with Techspot downloads files or google it.
  5. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi Tipstir -
    I did the repair and it worked. Thank you.

    I liked Office 2003 more than I do Office 2007. Easier to use, fewer keystrokes.

  6. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    The Excel 2007 files I checked last night all recalc now. However, the most important file does not. I tried copying it to another Excel type (Excel 2003 .xls) and then back again. No dice. I uninstalled Office 2007 and then reinstalled it. Again, no dice.

    The file in question is 12 meg in size. Significant, but not huge.

    Does anyone have any idea of why this would occur to just one file?

    Any ideas of things to do?
  7. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    hmm; likely that file is corrupted OR contains <embedded> external files

    If you open that file fresh using dbl-click on the file-name, does it ask permission to 'consolidate'?
  8. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi Joe - No, it does not ask to consolidate. - Doug
  9. Doug8765

    Doug8765 TS Booster Topic Starter Posts: 208

    Hi -
    I found the solution. While I was experimenting with saving to other formats (on the hope that writing out the file in other formats would cause the bug to go away), I found the Excel Options button. It showed that my recalc option was set to Manual. I did *not* set it to that and nobody but me uses this computer, but now I know to look there.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...