Tech Stocking Stuffers: 18 awesome gifts under $50

Win XP reboot - include minidump

By hcloh ยท 7 replies
Feb 12, 2009
  1. Hi,

    It's been a week that i tried to solve this restart. I have follow the steps located at this forum, and created the minidump and transfer it into debuglog.txt as instruct. I had paste it as below :

    * *
    * Bugcheck Analysis *
    * *

    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If a kernel debugger is available get the stack backtrace.
    Arg1: 000000e8, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
    Arg4: 80701a16, address which referenced memory

    Debugging Details:

    Unable to load image avgtdix.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for avgtdix.sys
    *** ERROR: Module load completed but symbols could not be loaded for avgtdix.sys

    WRITE_ADDRESS: 000000e8


    80701a16 8711 xchg edx,dword ptr [ecx]




    PROCESS_NAME: System

    LAST_CONTROL_TRANSFER: from 804e5cef to 80701a16

    f78da924 804e5cef 891954c8 89127e28 891954f0 hal!KeAcquireInStackQueuedSpinLock+0x26
    f78da944 b092df95 891954f0 89127e28 00000000 nt!KeInsertQueueApc+0x20
    f78da974 804e18ff 8a3b1980 8a48ac40 890e5e80 afd!AfdRestartConnect+0x172
    f78da9a4 ad7fccb1 892821ab 89282138 00005e7c nt!IopfCompleteRequest+0xa2
    WARNING: Stack unwind information not available. Following frames may be wrong.
    f78daa20 804e18ff 00000000 89282138 89127e28 avgtdix+0x1cb1
    f78daa50 b09ba942 88ccc3c8 88cce9e8 00000002 nt!IopfCompleteRequest+0xa2
    f78daa68 b09c0471 89282138 00000000 00000000 tcpip!TCPDataRequestComplete+0xa6
    f78daa7c b09c0f10 89282138 00000000 00000000 tcpip!TCPRequestComplete+0x12
    f78daa9c b09c4d77 88cce9e8 f78dac5c 00000000 tcpip!CompleteConnReq+0x87
    f78dab20 b09b7ef5 8a29a118 0100007f 0100007f tcpip!TCPRcv+0xe35
    f78dab80 b09b7b19 00000020 8a29a118 b09ba0b6 tcpip!DeliverToUser+0x18e
    f78dabfc b09b7836 b09f78f0 8a29a118 f78dad18 tcpip!DeliverToUserEx+0x95e
    f78dacb4 b09c3ce6 8a29a118 f78dad2c 0000001c tcpip!IPRcvPacket+0x6cb
    f78dad60 f77e73e4 b09f7680 8a29a118 b09f7690 tcpip!LoopXmitRtn+0x195
    f78dad7c 804e23b5 8a29a118 00000000 8a57f640 TDI!CTEpEventHandler+0x32
    f78dadac 80575723 b09f7680 00000000 00000000 nt!ExpWorkerThread+0xef
    f78daddc 804ec6d9 804e22f1 00000001 00000000 nt!PspSystemThreadStartup+0x34
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


    ad7fccb1 ?? ???


    SYMBOL_NAME: avgtdix+1cb1

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: avgtdix

    IMAGE_NAME: avgtdix.sys


    FAILURE_BUCKET_ID: 0xA_avgtdix+1cb1

    BUCKET_ID: 0xA_avgtdix+1cb1

    Thank you and hope it can be solved.

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Your error code 0xA are strong indications of hardware issues, But they are also caused by drivers attempting to access an IRQ Level they have no right doing so.

    The driver cited is avgtdix.sys and this belongs to AVG. What version are you running? A lot of people are experiencing problems with version8.

    You may want to uninstall and reinstall AVG to see if that helps.
  3. hcloh

    hcloh TS Rookie Topic Starter


    Thank you for your reply. Hardware issues .. do you know which one ? Regarding AVG, yes, i am using version 8. I did uninstall and install and still have issues. Then i tried by closed the AVG while using the computer and it's blue screen with the IRQ error.

    Help please. Thank you.
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    For clarification, 0xA errors can be strong indications of hardware issues but they also point to drivers attempting an IRQ Level they have no right doing so.

    In your case it is the driver avgtdix.sys (no hardware was cited) and this belongs to AVG. Version 8 has given many people issues. Try running your PC without it and see if you gain stability.

    If you get a BSOD while AVG is shut-down then attach your minidumps. See the attachment button at the bottom when you post. You can Zip up to five together. Please don't Zip each and every one individually.
  5. hcloh

    hcloh TS Rookie Topic Starter

    Route44 and all,

    I had ran it without AVG and collect the minidump as zip it. Please help. Thank you.
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    All are same 0xA errors and all cite the same AVG driver avgtdix.sys. Instead of shutting it down, try uninstalling and see if that works. Even when disabled you still will have drivers, etc. working or attempting to connect.
  7. hcloh

    hcloh TS Rookie Topic Starter


    Currently i had AVG removed and running it few days without getting errors. Thank you for your help.

    By the way, i would like to ask, if there's a hardware issues, how do we know are there any and which hardware it is base from the minidump ?

    Thank you.
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Hey, glad its working out for you. This is good to hear. I hope you have found an antivirus that will work for you. AVG used to a great product but version 8, as I said previously, has caused headaches for many. Try Avast, Avira Antivir, or Kaspersky. Many like BitDefender as well.

    However, if you have a subscription to AVG you might want to install it again and see if this time it works without conflicts. If conflicts retrurn then uninstall but make sure there are no remnanats of the software behind, otherwise you get crashes.

    As for your question about minidumps and hardware issues, sometimes a minidump will either say hardware or specifically cite something like memory corruption. Sometimes it is just the error code itself like 0xA, 0x8E, 0x24 (which points to possible harddrive problems -- or something else), etc., and the experiences that accompany from working with them.

    However, this is far from cut and dried. You'd be amazed how all evidence points one way only to have the answer coming out of left field. Let's say your minidumps cite memory corruption and you run the tests and they come back with no errors. Some answers have been the memory wasn't seated right or the motherboard didn't set the voltage right and so on.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...