Win7: Can ping DNS but no DHCP or internet browsing

chamrob

TS Rookie
I'm having a terrible time with one win 7 32 bit computer on my home network. All other devices (about 12) work fine, other windows 7 pc works fine, ADSL router and Cisco switch work fine. This one Dell Vostro 430 with a cable into the network worked fine for 2 years. Overnight it can't connect to local network with its DHCP settings and if I change to static ip it still can't browse the internet. However I can ping external addresses by IP address only. If I ping google.com eg it cannot find the host. What is really confusing is the "Ping Statistics for " response contains neither the name or the address but instead random characters... ie ãäý¶è$5ÿÿÏ this changes every time. all other devices on the same network resolve IP adresses to their fully qualified domain name.



I have been through loads of sites and support, flushing dns, flushing IP, restoring the pc to a previous working point, changing the network cable and port, installing a USB wireless key (which works on this pc), manually configuring IP addresses, reseting the IP and WINSOCKs with Netsh commands, I ran anti malware, Combofix,virus checkers (zone alarm) all found nothing, I booted into a linux instance but still couldn't browse the net, I cabled two pcs back to back and could ping each other from each other then restored the cable to the bad Dell I still didn't get a DHCP address but with manual IP, gateway and DNS I could ping 8.8.8.8 but not browse.

I have run out of ideas....anyone help

Oh it's win 7 professional and there may be a few more things I've done but forgotten in the post above

Obviously changed drivers on NIC, and installed drivers for the wireless USB NIC,
 

gbhall

TechSpot Chancellor
Booting from a Linux rather than an apparently faulty Windows OS is my favourite way of deciding I have an actual hardware fault.
 

jobeard

TS Ambassador
Here's a sequence of tcp tests:
  1. ping 8.8.8.8
  2. nslookup google.com
  3. ping google.com
Results:
(1) if this returns timing values, then you have connectivity from
pc->router->isp- - - the google public dns (that's what 8.8.8.8 corresponds to)
Otherwise there's an issue on the pc or the router(but you've already proven that to be false).

(2) should return the ip address of the google.com web server and success says your pc has a valid DNS setting. It this fails, then the DNS value is incorrect or totally missing.

(3) should perform like (1) *IF* the DNS is good, or like (2) if not.

get a command prompt and enter IPCONFIG /ALL >myTCP.txt
now copy the contents of myTCP.txt and paste in your followup
 

jobeard

TS Ambassador
DHCP may be disabled on the NIC, so runas /user:administrator cmd,
enter the password and in the command prompt window enter
netsh interface ip set address "Local Area Connection" dhcp
 

Rage_3K_Moiz

Sith Lord
Looks like Winsock corruption; DNS resolution is effected by the Winsock/LSP subsystem. From experience, it's likely malware that is still somehow in effect on the computer.

Try the steps in the following MS KB article if you haven't already:
http://support.microsoft.com/?id=811259

I'd also recommend you take a look at your HOSTS file to see if there's any bogus redirection entries that shouldn't be there.
 

chamrob

TS Rookie
Ok thanks everyone will try the above.... sorry for the delay not been able to get time to concentrate on this since my first post...
 

chamrob

TS Rookie
Ok heres the results from pinging and nslookup


==Command was: "Ping 8.8.8.8"

==results:

Pinging with 32 bytes of data:
Reply from 8.8.8.8: bytes=32 time=37ms TTL=47
Reply from 8.8.8.8: bytes=32 time=49ms TTL=47
Reply from 8.8.8.8: bytes=32 time=36ms TTL=47
Reply from 8.8.8.8: bytes=32 time=36ms TTL=47

Ping statistics for :.cv瘘˜ø•:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 36ms, Maximum = 49ms, Average = 39ms

==Command was: "nslookup google.com"

results:

***Unknow can't find google.com: No response from server

==Command was: "Ping google.com

results:

Server: UnKnown
Address: 8.8.8.8

I've viewed the details of msconfig32 and in the Components>>Network>>Protocol section ... it's totally blank..nothing, nada...

In the winsock there are two sections.... winsock.dll and wsock32.dll

I then downloaded the microsoft fixit .msi detailed on the webpage and ran it ..then msconfig32 again .. and still the same nothing in the protocol section but I can still ping 8.8.8.8 but get the same results

I ran the netsh interface ip set address "Local Area Connection" dhcp and set the adaptor to dhcp but then I can;t ping anything the response is

PING: transmit failed. General failure


As I mentioned before I can only ping any address internal or external if I manually put in the IP address... DHCP fails to obtain an address.... but the rest of the network is working fine...
 

Rage_3K_Moiz

Sith Lord
Could be a hardware fault then, as gbhall suggested. Especially if you've tried everything, including an OS reinstallation. The fact that a wireless NIC works also hints towards this, I believe.
 

chamrob

TS Rookie
Finally the hosts file

[SIZE=13px][FONT=monospace]%SystemRoot%[/FONT][/SIZE][SIZE=13px][FONT=monospace]\system32\drivers\etc\host contains [/FONT][/SIZE]

[SIZE=13px][FONT=monospace]127.0.0.1 localhost[/FONT][/SIZE]


[SIZE=13px][FONT=monospace]thats it[/FONT][/SIZE]

actually I haven't tried the OS yet... thats what I was trying to avoid.. but looks like it's the only solution...
 

tipstir

TS Ambassador
I have to agree with Rage above. To me sounds like the NIC in there has gone duff (bad) They can fail at anytime. Replace it and see if you still have these issues which you shouldn't.
 

jobeard

TS Ambassador
You can access the ISP dns directly by stopping the local DNS CLIENT.

using admin, run->cmd
enter
ipconfig /flushdns
net stop "dns client"
now attempt NSLOOKUP 8.8.8.8

This avoids your hosts & accesses the DNS directly
 

jobeard

TS Ambassador
Ok heres the results from pinging and nslookup ...

I ran the netsh interface ip set address "Local Area Connection" dhcp and set the adaptor to dhcp but then I can;t ping anything the response is

PING: transmit failed. General failure

As I mentioned before I can only ping any address internal or external if I manually put in the IP address... DHCP fails to obtain an address.... but the rest of the network is working fine...
need to reboot OR disconnect from the router, wait 30 seconds and then reconnect - -
validation of the DHCP results are see using ipconfig /all

ALSO NOTE:
Reply from 8.8.8.8: bytes=32 time=36ms TTL=47
Ping statistics for :.cv瘘˜ø•:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 36ms, Maximum = 49ms, Average = 39ms
instead of Ping statistics for :.cv瘘˜ø•: that line
should have read Ping statistics for 8.8.8.8:

This looks like a virtual address or a hidden proxy is active.
 

chamrob

TS Rookie
Ok updated.... I wiped the Dell... re-installed the OS and it's up and working no problem..... pings are clean and returning the fully qualified domain name....... it's running better of course but will annoyingly have to go through the massive round of updates.. however will disk image it once everything is back installed. (could have sworn I did it last time but couldn't find it. ;-)

thanks everyone for your help really appreciated the effort....

rob
 

jobeard

TS Ambassador
GREAT! I hate to recommend purchasing replacement parts when it's so very frequently software configuration issues :)
 

Latest posts