Windows 7 only boots after pressing F12 to select boot device

By BorisandBailey ยท 4 replies
May 13, 2014
Post New Reply
  1. Here's a brief synopsis of the problem:
    1. Black screen at startup: NTLDR is missing.
    2. Windows 7 64-bit Disk will not launch Repair, saying the system is the wrong version.
    3. NTLDR no longer displayed at startup, now it's Boot Device not found.
    4. Try different boot order options in BIOS. Nothing works, including my favorite: DVD, Hard Disk, Boot Manager.
    5. Press F12 key immediately after starting up, select Windows Boot Manager, Windows 7 (64-bit) opens.
    6. Turn computer off, restart, now try F8, Windows Recovery and Repair Tools opens.
    7. Select repair boot files. No problems found.
    8. Try command line. Can't use fixmbr.
    Okay, I've exhausted my options just short of reinstalling Windows 7. Any ideas on how to make my computer to see Windows 7 at startup and then boot into it?
  2. oliverpowell

    oliverpowell TS Enthusiast Posts: 26

    Get your Windows installation CD and run 'Startup Repair' at least 3 to 4 times, just to make sure that there were no problems with your system or all the problems has been repaired successfully.

    If you're still facing difficulties, navigate to BIOS Settings and set your hard disk drive as your primary boot device. Try these options and see what happens.

    Good Luck!!
  3. BorisandBailey

    BorisandBailey TS Enthusiast Topic Starter Posts: 154

    Hi, Oliver, and thank you for posting. Those are very good ideas for most booting scenarios.

    My installation disc will not open the Startup Repair, saying it is the wrong version. This is the licensed disc I used for installing the OS in the first place. I tried my wife's laptop's system repair tools as well with the identical system. Same message. However, I can access Startup Repair by pressing F8 just before the Windows Logo appears. I ran through it problems found (despite having a problem, nonetheless). I also tried a system restore.

    Okay...BIOS. I tried a few combinations, including the hard disk as the primary boot device. No luck.

    So far, the only way to enter it now is to press F12 which gives a list of startup options. I choose the Windows Boot Manager which opens it.

    Any ideas?
  4. oliverpowell

    oliverpowell TS Enthusiast Posts: 26

    What I strongly suspect is, there might be some problem in mobo or the internal hard disk health. Once you're at the desktop, consider updating all your motherboard and video graphics driver to it latest. You can find all these updates from the manufacturer website.

    I'm afraid that you may have to format your system and install a fresh copy of Windows if that doesn't addresses your issue. Please start taking backup immediately before its too late.

    Good Luck!!
  5. BorisandBailey

    BorisandBailey TS Enthusiast Topic Starter Posts: 154

    Except for the power supply, the components are about six months old, however, SATA port 01 failed and I switched the hard disk connection to SATA port 02. I have wondered what else might eventually fail on that Gigabyte main board, which, normally, are pretty good. The hard disk works well and I have backed up everything in a few different places, including a computer with a Ubuntu OS, so I can avoid a "too late" situation. I have anticipated a complete re-installation. Anyway, very good observations, Oliver, thank you. That sounds closer to what it might be.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...