Windows can't format hard drive

By Kamikaze78 ยท 8 replies
Jul 14, 2008
  1. I got hit with a power surge, my system turned back on after and I got hit again. After that my harddrive became more and more unstable upto the point it would no longer detect. I have an RMA on the drive already... but my problem is... I went to best buy to buy the same hd. Windows 2000 would only format 127 GB of it, and windows 2000 told me twice... it cannot format the harddrive. Any ideas what the problem could be. BTW, its a 500 GB Seagate Barracuda SATA Harddrive. The only difference between the 2 drives is the firmware.
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

  3. zelgadis85

    zelgadis85 TS Rookie Posts: 21

  4. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    Use the CD that came with the drive to format it. Never let Windows 2000 or XP do it. Check your BIOS to see if they're any hardware updates for it? The software from the HDD maker might partition the drive into two 250MB. It might not do that give you the full 500GB instead.
  5. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Windows 2000 isn't going to easily go higher than 132 GB unformatted... and will usually give you trouble even if you setup the hard drive with the manufacturer's setup disk. You will likely need to extend the partition after you install W2K.
    Why not spend the money for WXPP SP2 or SP3 and do it right. You will suffer from now on using W2K because it is no longer supported. You are going to have trouble with drivers forever.
  6. Kamikaze78

    Kamikaze78 TS Rookie Topic Starter

    I just like win2k over xp. After resizing my partition for win2k... I got a blue screen of death. So I tried 4 different versions of XP Pro. Which tell me they cant format the harddrive. And the disk I got with the drive is not bootable.. so how I format a locked patition. Also... latly.... maybe cause the linux partitions... but no windows installer will boot. It loads and then my harddrive light stays on longer then I am willing to wait.
  7. raybay

    raybay TS Evangelist Posts: 7,241   +10

    So you are basically doing it to yourself.
    Nothing wrong with W2K. Three of my machines, all IBM's have it. It is basically just WXP with no service packs.
    But your problems are perhaps a result of your choices.
  8. cadsystems

    cadsystems TS Rookie

    I think I get hit by the same problem. We had a thunderstorm last week. Booted up the machine one day after the storm. Computer was taking forever to boot up usually takes about 30-45 seconds, it took about 2 minutes. The next day the wife said that it was acting funny? She rebooted and it wouldn't boot. I suspected bad hard drive. So I went out and bought a new 250gb hard drive. Put the hard drive in, put in my XP disk, and the install showed that there was 138gb hard drive, i thought it was a bad hard drive. I hit format since there was nothing on there and Windows wouldn't format the disk. Said it might be corrupt. So i got a good known working hard drive, put it in, same thing only showed around 138gb. Tried to format said disk was corrupt. This leads me to believe the surge may have taken out something else like the motherboard. Not sure at this point because I'm still in diagnostic mode. I really wish this motherboard had a diagnostics disk.
  9. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Does the version of Windows XP you used to run the format have no Service Pack, Service Pack 1, Service Pack 2, or Service Pack 3?
    Unless you have at least Service Pack 2, it will not format a drive larger than 132 GB.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...