1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Windows will not boot and main drive inacessible

By cheaterguy ยท 25 replies
Jun 23, 2008
  1. Good evening.
    First of all, I am Cheaterguy, a newcomer here at TechSpot. I'm decently skilled with computers but I have recently received a quite serious error which I cannot solve without placing my entire system at risk. Hence, I created this account and I'm hoping for help. I will be very thankful for any clues or hints.
    Now with that over...

    Earlier today I was doing a non-destructive partitioning with Partion Magic because I wanted to dual-boot Linux to try it out. PM reboots my computer and resizes my C drive (the first of four steps). However, after this, it gives me an error message (which I unfortunately cannot recall) and tells me I have to reboot. Now, It reboots as usual up to the point where the Windows (Windows XP Professional SP2) boot screen comes up. It runs for a few seconds, then freezes, a BSoD flickers on and off for a split second and my computer reboots. So I'm trapped in a reboot loop, so to speak.

    After a bit of internet browsing (on other computers, as well as the bootable Linux CD) I found some info to possibly find the source of the issue. After following one lead I was able to read the BSoD and it identified the error as:
    *** STOP: 0x00000024 (0x00190203, 0x86df32b8, 0xc0000102, 0x00000000)
    Further browsing revealed this as a NTSF file system error.

    Also, while using the trial version of the Linux OS, bootable from the CD, it told me that my hard drive was completely inaccessible. "Could not be mounted" to be specific. It can however tell me the size of the drive, as can BIOS and the various windows utilities that can be booted from the installation disk.

    Now I wonder what to do. I would, by all means necessary, prevent having to reformat the drive, since I have irreplaceable data on it.
    I have also heard that Chkdsk is really bad for the computer, so I have not attempted that yet. All I have done is rebuilt the partition table and the MBS to no avail.
    So before taking any further action I deemed it best to consult someone who actually knows.

    I appreciate any response, so thanks, beforehand.
  2. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Fix your MBR
    1. Restart your computer with the Windows XP Setup disk in the CDROM drive.
    2. If you are prompted to press a key to start the computer from CDROM, do so quickly. Otherwise it may try to boot from the hard drive. (may have to enter bios and change boot order)
    3. After a few minutes, you'll see a prompt to press the R key to start the Recovery Console.
    4. When Recovery Console starts, it will prompt you to enter a number corresponding to the Windows XP installation that you need to repair. In most cases, you'll enter "1" (which will be the only choice). If you press ENTER without typing a number, Recovery Console will quit and restart your computer.
    5. Enter your Administrator password. If you don't enter the correct password, you cannot continue.
    6. At the Recovery Console command prompt, type fixmbr and then verify that you want to proceed.

    Your damaged MBR will be replaced with a new one, and you should then be able to boot your system normally. In some cases, you may need to repair the boot sector in addition to the MBR. If your system still doesn't boot properly, repeat the steps above, but issue the fixboot command instead.
  3. cheaterguy

    cheaterguy TS Rookie Topic Starter

    First of all, thanks for the rapid response.
    Second, there are some issues in the process you described.
    First problem: I get no prompt asking me to select windows installation or to input any password.
    Second problem: I ran both the fixmbr and fixboot commands before writing the post. Fixboot told me that my filesystem and bootsector were corrupted and wrote a new bootsector. Fixmbr just told me that a new MBR had been written successfully, but none of these solved the problem.
    I'm still receiving the same stop error.

    Like mentioned, I will do most anything to save my data... So, any other ideas?
  4. cheaterguy

    cheaterguy TS Rookie Topic Starter

    Now, I hate to be impatient...
    But without much to do during the day one cannot do much but wait... It gets boring fast xD

    To the point:
    After many more hours of web browsing I do believe I have narrowed the problem down to a File System corruption which can supposedly easily be fixed by running CHKDSK.

    But now, suppose I am wrong and it is not a File System error, though I do not know what else it could be, what sort of damage would CHKDSK cause? Because from the information I have found, CHKDSK is a repair process that is best avoided, since it often fragments and destroys data more than it actually fixes the system.

    So what would be someone elses opinion on this... Is it safe for me to run CHKDSK or should I try something else first?

    Once again, the data on the disk is crucial, so damage must be avoided by any means possible.

    Thanks beforehand
  5. Richardw9

    Richardw9 TS Rookie Posts: 127

    sorry for the inconvienience

    i can see your online and i don't want to start my own thread.
    But can you tell me what is BIOS and how do i access it?
  6. cheaterguy

    cheaterguy TS Rookie Topic Starter

    I can only tell you what I know, but here goes.
    BIOS (Basic Input/Output System)
    The most basic system of any computer, it takes inputs and makes outputs, and it searches for something to boot.
    It is normally acessed by rebooting your computer and then hitting some button (normally F8, on my computer it's Delete)
    Be careful while making changes there though... As the most basic system it's also the most crucial, you don't want it to fail.
    Hope that helps.
  7. Richardw9

    Richardw9 TS Rookie Posts: 127

    Thanks i wanted to know because most threads involve it in some way. Best of luck in fixing your system
  8. cheaterguy

    cheaterguy TS Rookie Topic Starter

    You're welcome, and thanks ^^
    I hope it works out too xD
  9. Richardw9

    Richardw9 TS Rookie Posts: 127

    i found this information on Wikipedia :

    The version of CHKDSK (and Undelete) supplied with MS-DOS 5.0 has a bug which can corrupt data. This applies to CHKDSK.EXE and UNDELETE.EXE with a date of 04/09/91. If the file allocation table of a disk uses 256 sectors, running CHKDSK /F can cause data loss and running UNDELETE can cause unpredictable results. This normally affects disks with a capacity of approximately a multiple of 128 MB. This bug was fixed in MS-DOS 5.0a. A Microsoft Knowledge Base article[2] gives more details on this.

    By the sounds of it, for what you want to use it for CHKDSK is not the best option
  10. cheaterguy

    cheaterguy TS Rookie Topic Starter

    True that, but it also says the bug was fixed... So I really could use a personal, professional view on it from someone around here...
    To CHKDSK, or to not CHKDSK? That is the question xD
  11. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    I am going to put a message in to somebody who is better at this side of things than myself, I normally work on removing malware. I am good at fixing these types of problems too, but not at giving advice for what you are trying to do.
  12. cheaterguy

    cheaterguy TS Rookie Topic Starter

    Thanks mate ^^
    Could have used your skills a few weeks ago (I had a bad case of Vundo and Neptunia) but I eventually managed to solve that... Malwarebyte's Anti-Malware is the shizz xD
    But... Back to topic xD
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    The most important part is your data
    So I would strongly suggest to remove the internal HardDrive and mount it in another PC (as a Slave)

    Once your drive has been mounted in another computer
    Boot up the computer normally

    Now another point of concern here, is the computer that will be booting up, may state the slave requires a Check Disk to be performed.
    Just press any key to cancel the operation at this time

    Once windows has fully started and the new slave HardDrive is found
    Please open (usually My Computer) the Slave HardDrive and check if any files are accessible.

    Now, I realize that the Linux Boot CD could not access the drive
    But the proceedure above is the best (world agreed) way of confirming if you can access your data.

    If you still cannot access any data on the Slave drive
    Your next option would be to run CheckDisk
    Checkdisk (unlike Scandisk) will repair a corrupted file system, as long as that filesystem has not been encrypted or compressed. It can also be unsafe to use if your HardDrive is showing signs of faulting (Hardware wise)
    But generally is Safe to use
    (The above still needed to be confirmed anyway)

    Therefore please run CheckDisk on the slave HardDrive
    Open My Computer
    Right Click on your slave HardDive
    Select Properties
    Select Tools tab
    Select Check Now button
    Tick "Automatically fix file system errors"

    Reply back

    The above is exactly what I would do
  14. cheaterguy

    cheaterguy TS Rookie Topic Starter

    First, thank you for the detailed response. It is exactly what I was hoping for.
    Secondly, I'll get back to you with any progress once I track down another computer with S-ATA/300 connectors (all other computers in the house are too old for that).
    So until then, thanks, and cross your fingers. xD

    Clever, as I am, I completely overlooked the possibility to boot from a normal IDE drive in my own computer, still placing my own drive as Slave. Or was there some restriction in Windows to prevent this? I heard something about windows coding itself to exactly the computer it's installed on, to prevent the drive being moved...
    Another option is for me to get a completely fresh drive and install windows on that... But that seems sort of unnecessary so I'll try to resolve it using the advice I have gotten.
  15. kimanyo

    kimanyo TS Rookie

    I have a Dell Inspiron 9400 with Windows XP installed. I have the laptop since April 2007.Yesterday I left the laptop in stand-by for about 1 hour, when I got back the screen was black and could not be revived in any mode.
    I have switched off the PC by pressing the power button until power went off.

    When I try to start the laptop the Dell logo would come on with a weird pattern of green dots in the back ground, then the usual XP logo would come on, still green dot pattern all over the screen and then the screen would go blank.

    I have ran all the available system diagnostics for Memory, Hard disk and system components at start-up and they all passed. In addition the laptops power sources are working well.

    Then I have run the genuine Dell-XP CD Rom and run the 'Repair Installation' option.
    This would run normally and even the screen was normal until after the first Boot request. Then reboot the PC and configuration would go on for about 10 minutes ... then the screen just blanks out again.

    Please help ... I need some fresh ideas on what else I could do.
  16. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Hi kimanyo, welcome to TechSpot
    You have replied to a thread that has nothing to do with your issue (or theirs)
    You need to create your own thread just for you, explaning your fault condition again, and ideally what Hardware you are using (ie addon Video card)
    Here is the direct link to creating a new thread: https://www.techspot.com/vb/newthread.php?do=newthread&f=8
    Please click on that thread, and do not reply here.

    Good idea, I didn't even think of that
    There are a couple of issues though
    The IDE master HardDrive may actually boot as slave (Sata having precedence)
    Yes but the Sata has already been activated
    If you boot up and your IDE HardDrive asks for activation, do not activate it (usually you will be given 3 days)
    Once the Sata is remounted as the main drive, the activation (already completed) will be as it was before (fully activated and not asking to be re-registered)
  17. cheaterguy

    cheaterguy TS Rookie Topic Starter

    So, after almost an hour of swinging an electric screwdriver around, trying to maneuver fragile hardware in my cluttered room, I finally managed to get my sisters harddrive installed in my computer.
    A bit of further editing in BIOS made sure that drive had boot priority.
    Yet, something still isn't working.

    Same symptom as before. Windows is booting but a few seconds into the process a BSoD flashes on for a split second and the system reboots. Trying again, I read the BSoD:
    *** STOP: 0x0000007E (0xC0000005, 0x00000000, 0xF78AB0C0, 0xF78AADBC)
    According to the stop-error guide here on TS, It's a "SYSTEM_THREAD_EXCEPTION_NOT_HANDLED"
    Hardware incompatibility, most likely.
    The data on the IDE disk is, however, accessible from the bootable Linux CD

    Awesome -.-
    I'm going to reassemble both computers and then take a run down to town to see if I can't find myself another S-ATA HDD.
    I ran a utility that was recommended to my by a friend and that was, at any rate, able to show that I still had all my files and folders on the disk. Didn't fix or diagnose anything, but it was able to tell me that everything was where it was supposed to be. (Active@ Partition Recovery on Ultimate Boot CD)
  18. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

  19. cheaterguy

    cheaterguy TS Rookie Topic Starter

    Thanks. My plan for right now is to attempt the first procedure by installing Windows fresh on my new HDD (250GB Samsung S-ATA) and attempt to access the data. If this, by some miracle, works I will rescue the data I need and then proceed to reformat the old drive.
    If it does not I will run some file-rescue software from the Ultimate Boot CD before attempting the CHKDSK.
    After CHKDSK I will attempt to boot and if possible, asess the damage (if any).
    Wish me luck ^^
  20. cheaterguy

    cheaterguy TS Rookie Topic Starter

    Okay. After the long process of installing Windows... again, I finally got into my computer to be able to try the theory.
    Not all too surprisingly, it failed.

    When I attemt to access my old drive (placed as slave, now called E) it gives me the error:
    "E:\ could not be accessed. The file or directory is corrupted and unreadable."

    So up next I will try to save the data by one of the utilities I have/Kimsland linked. Still being a bit hesitant about CHKDSK I won't run it until I get a response.
  21. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    I'd say that you can safely run Check Disk now
  22. cheaterguy

    cheaterguy TS Rookie Topic Starter

    I'm gonna take your word for it... Besides, the most vital data has already been saved using ZAR, for which I thank you greatly.
    I will get back to you after I have run CHKDSK, at which point I hope I will be typing the response from my own computer again ^^
  23. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    If you reply back in the next 5-10 mins, I'll see it.
    Otherwise I'll check back about ~8Hrs from now
  24. cheaterguy

    cheaterguy TS Rookie Topic Starter

    I suppose I was too slow then xD
    Any which way, CHKDSK worked. I now have access to the drive again and it will boot if I tell it to. Only issue is that when it boots, so does Partition Magic as if nothing ever happened. It tells me to hit any key to abort, but since my keyboard doesn't have an "any" key, I'm screwed. It doesn't respond, no matter how hard I hit the keyboard.

    Regardless, I can enter the drive through Explorer, grab what I need and then put it on reformating overnight. So, I thank you (Kimsland) and you (Blind Dragon) greatly for all your help in this process. I sincerely wish you both the best of luck in your continued life.

    So that is all for now...
    Peace out ^^

  25. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    Thanks for letting us know all is now ok
    Glad it's resolved

    Just a point of interest regarding all this.
    Please backup your data, to external media always. lol :)
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...