Windows XP re-install problem

By jpettitt ยท 15 replies
May 15, 2009
  1. I have a Dell desktop running XP SP3. I ran into some virus/malware problems. I attempted to get rid of the virus and malware not very successfully so I decided it was time to reinstall windows and reformat.

    I ran into problems trying to run Windows setup in normal mode as the virus was affecting eveything so I went into msconfig and selected the /Safeboot option to start the computer in safe mode. I attempted running Windows setup in safe mode and quickly learned that setup will not run in safe mode. I was prompted a 'Setup cannot run in safe mode, setup will restart'. This reboots my computer and as I made the change in msconfig to reboot in safe mode you can understand that a viscous circle has been created. Computer reboots in safe mode, windows setup restarts, error message, reboot again, etc.

    my question is, how can I bypass safe mode and restart my computer in normal mode again? Or alternatively, how I can stop windows setup from running?

    I have tried pressing F12 and a couple different keys that Dell has recomended when the comp reboots but that has not been successful. None of those keys seem to work, that is why I changed msconfig to get into safe mode cause F8 didnt work

    Thank you
  2. fastco

    fastco TS Booster Posts: 1,123

    First, what kind of keyboard do you have (usb or ps/2?) If you are using a USB keyboard it may not be recognized until after Windows begins to load. That's why nothing happens when you reboot and press del or F8, F12. Get a usb to ps/2 adapter or use an old ps/2 keyboard.
    Second, how are you running setup? Are you booting off of the Windows CD. Also how old is your Dell? Does it have a restore partition or do you use restore cd's?
  3. jpettitt

    jpettitt TS Rookie Topic Starter

    I am running a USB keyboard. I dont think I have an old ps/2 keyboard but I can try to find one or I will buy an adapter and try that.
    I believe I originally booted off of the Windows CD in Safe Mode, or I may have started setup through windows explorer I cant remember I tried a couple different things. Setup just continues to run now, no CD
    My Dell has a restore partition, I dont believe any restore CD's came with it

    thanks for your help
  4. AndrestheBean

    AndrestheBean TS Rookie Posts: 207

    you can buy a adapter, they are like 5 dollars at your local best buy or circuit city
  5. fastco

    fastco TS Booster Posts: 1,123

    OK then get the adapter for your keyboard, start the computer and press F12 to restore the computer!
  6. jpettitt

    jpettitt TS Rookie Topic Starter

    sounds good to me.....thanks everyone for the help.
    Im new to this forum and so far it has been very helpful. I posted the exact same post on the Dell forums a week ago. nobody answered my question and kept telling me the 'right way' to reformat. however helpful that may be to some, it doesn't help me get out of the vicious circle my computer is putting me through.
    thanks again
  7. fastco

    fastco TS Booster Posts: 1,123

    Let us know how it turns out!
  8. gguerra

    gguerra TS Guru Posts: 319

    USB Legacy support should be enabled by default on Dell machines that came with USB keyboard. In any case you will only be able to install a 2nd instance of Windows if you don't have the CD. (in a directory other than c:\windows) More than likely if your dell is not too old you will be able to restore it back to factory state by using dell restore. Not sure the key combination but it is something like Ctrl-F11 or Ctrl-F12. Google the model number of the Dell to find out exactly. Oh and BTW check out and type in your service tag to get more detailed instructions. If your USB keyboard is not responding at boot time then USB legacy is disabled for some reason and you will not be able to enable it without a functioning keyboard. I have not had luck with USB to PS2 keyboard adapters. (mouse USB to PS2 adapters do work). You may be better off borrowing or buying a cheap PS2 keyboard (under $10). However after all is said why dont you try to remove the malware first. Re-formatting is usually a last resort.
  9. jpettitt

    jpettitt TS Rookie Topic Starter

    yeah the dell has a restore partition but I need to hit F12 at startup to get into the restore app.
    I have tried removing the malware and various trojans that my comp is infected with. I have had the comp for 2 years now and I havnt reformatted once so the combination of the pain in the *** it was to go after each individual trojan and me realizing it is probably time for a reformat lead me to this point.

    So, I bought a usb to ps/2 adapter and I guess I got the wrong one. This is converting a ps/3 connection to a usb (wouldnt that be 'ps/3 to usb'???) point is, it is useless to me so I havnt progressed anywhere. next step - find a old ps/2 keyboard.

    ive been all over (should have bought the extended warranty lol) for over a week now and didnt get anywhere. I made alot more progress with one quick post on this forum in one day then I did on the dell forum in a week.

    i want my computer back..........
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That's right. Your USB keyboard should work
    As you have not posted your exact model type, I cannot look up how to get to Bios Setup
    You need to get to Bios Setup (sometimes called System Setup or CMOS Settings)
    This is usually accessed by pressing DEL or F2 key, as soon as your computer starts up
    Once in System Setup screen, locate USB Legacy support for your keyboard, and then enable it
    Save and exit (F10 key) System Setup
    Try F12 again

    Dell info and support for your unknown model can be found here:

    Good luck :grinthumb
  11. jpettitt

    jpettitt TS Rookie Topic Starter

    Dimension E521

    setup is F2 on my machine. none of these shortcut keys work

    ive spent plenty of time on the dell support forums/blogs/wikis.....etc, etc. I made zero progress and came to the realization that unless i have the extended warranty (which i dont) getting any help from Dell is impossible
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Dell Forum support is free
    They also provide many onlline documents, and their driver and download area is generally above all other manufactures

    Have a look here:

    Looking at jumper No.12. We will reset the Bios from the Main Board

    Remove all Power
    Hold the ON button in for 20secs, to disperse other residual power
    Remove the side cover
    Remove the CMOS battery (No. 14 in pic)
    Remove the jumper (No. 12)

    Refit the Jumper (No. 12 in pic)
    Refit the CMOS battery (No. 14 in pic)
    Re-insert the power cord
    Turn on

    Does your USB keyboard now work?
    If no, try going back to Bios Setup (F2) and re-enable USB legacy device
    Save and Exit
    Test again
  13. jpettitt

    jpettitt TS Rookie Topic Starter

    ok, a couple interesting things here.

    1. opened er up and there was no jumper on #12. clearly a 2 pronged spot where the #12 jumper would go but nothing on it. there was one on #21
    2. I dont even have a ps/2 input on my tower at all so hooking up an old keyboard isnt an option

    result of that test keyboard action
    I boot up. Dell page comes up then I see

    Diskette drive 0 seek failure
    keyboard failure
    invalid configuration information - please run SETUP program​

    then at the bottom F1 to continue, F2 to enter setup but no keyboard working makes that difficult.

    man just when I thought we had something..........any other suggestions?
  14. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    The "No jumper on 12" meant I had it around the wrong way

    Remove all Power
    Hold the ON button in for 20secs, to disperse other residual power
    Remove the side cover
    Remove the CMOS battery (No. 14 in pic)
    Insert the jumper (No. 12)

    Now inserting the jumper...

    It is possible that there is a jumper there, but it is only on 1 pin (effectively doing nothing)
    If so, just pull the jumper off (note we are specifically talking about Jumper 12 only, it may even be Red in color)
    And then put it back on, both pins
    Then remove it (it only needs to be on for a second)

    Re-insert Battery, then Power cord, then turn back on

    IF there is just no jumper there
    You can just short the pins (just jumper 12 pins) with a flat screwdriver (you just touch them for a second)

    It is totally safe, as all power is out. But do not scratch anything if using a flat screwdriver


    After turning back on, you should get that F2 prompt again
    If your USB keyboard does not work
    And your PS/2 Keyboard does not work (make sure no pins are bent in the plug, and it is securely in the keyboard connector, maybe push just a little bit harder, to seat it in. Power must be off, to plug in PS/2)

    IF it still does not work...

    Either faulty PS/2 Keyboard, or faulty Motherboard!

    How did you go?
  15. fastco

    fastco TS Booster Posts: 1,123

    I think we are getting too deep here. My son has an "F" lock button on his keyboard and it has to be pressed every time the computer is restarted or NONE of the F keys work. Does your keyboard have an "F" lock button on the left side of the F keys?
    I have seen, many times, usb keyboards don't work until Windows loads with or without legacy support.
  16. jpettitt

    jpettitt TS Rookie Topic Starter

    ok it looks like I have everything resolved.

    i rebooted a couple times and kept trying the keyboard and it finally started working so i was able to access setup and also initiate the Dell (symantec) restore application. confirmed in setup that the usb was enabled and the keyboard continued to work after I rebooted again. the dell restore app was very fast and easy to use. seems like my computer is back to normal, now today I spend most of the day installing apps back onto my machine.

    thanks again for everyone's help - kimsland very helpful information and tips, help i thought I would have to pay someone for
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...