1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Wireless connectivity lost after Windows Update

By macjohnson ยท 6 replies
Dec 27, 2008
  1. I have a Dell Dimension 9200, which was connecting to the Internet via Netgear WG111v2 wireless USB adapter. I also have a Dell Insprion 1501 using an Internal network card no problems. Both running Windows XP. Router is BT Voyager 2091.

    After doing a Windows Update, I had problems with internet connectivity (limited or no connectivity). Reinstalled the Netgear drivers (via laptop connection), no joy. Tried manually setting up IP address, and it could see the router, but would not bring up the Internet.

    Did a system restore to just before the Windows Update, and Internet came back, but then had problems with itunes/quicktime. A knowledgeable friend thought it best then to do the Windows Update, and the Internet connection again disappeared, but now I cannot do a system restore. Am able to connect to router with an Ethernet cable.

    Thought maybe the Netgear was faulty, so I've now installed a Belkin Wireless G+ desktop card. Initially this found the router, but with limited or no connectivity. After a reboot, the Belkin cannot even see the router (cmd line says Media disconnected, but after complete reinstall of Belkin using latest software from Belkin website, no joy). In desperation I've restarted the Netgear, which comes up with 'Limited or no connectivity still'.

    ipconfig /all shown below:

    Host name: Arthur
    Primary DNS Suffix -
    Node Type - Unknown
    IP Routing Enabled - No
    WINS Proxy Enabled - No

    Ethernet adapter Wireless Network Connection 3:
    Media state - Media Disconnected
    Description - Belkin 802.11g Network Adapter
    Physical address - 00-17-3F-86-7F-45

    Ethernet adapter Wireless Network Connection 2:
    Connection specific DNS suffix -
    Description - Netgear WG111v2 54Mbps Wireless USB 2.0 Adapter #2
    Physical adreess - 00-0F-B5-CD-16-02
    Dhcp enabled - Yes
    Autoconfiguration Enabled - Yes
    Autoconfiguration IP Address -
    Subnet mask -
    Default gateway -

    If I try to ping the router on the request times out.

    Laptop ipconfig /all below:

    Host name - Larry
    Primary DNS suffix -
    Node type - unknown
    IP routing enabled - No
    WINS Proxy enabled - No
    DNS suffix search list - home

    Ethernet adapter Network Bridge (network bridge) 3:
    Connection specific DNS suffix -
    Description - MAC Bridge Miniport
    Physical adreess - 02-19-7D-2E-89-D6
    Dhcp enabled - Yes
    Autoconfiguration Enabled - Yes
    Autoconfiguration IP Address -
    Subnet mask -
    Default gateway -
    DHCP Server -
    DNS Servers -
    Lease obtained - 27 Dec 08
    Lease Expires - 28 Dec 08

    I set up a network bridge on the laptop to enable me to connect our XBox to the internet via a bridge - don't know if that's significant.

    This morning I connected the Wii to the router wirelessly - no problem.

    Any suggestions greatly appreciated. Sorry for the lengthy post.
  2. CCT

    CCT TS Evangelist Posts: 2,610   +6

  3. macjohnson

    macjohnson TS Rookie Topic Starter

    Ok, tried that. Winsock did not seem to be corrupt - the 10 registries were there as described, though there were a few extra entries also, so did the repair as stated. Also did the sockxpfix and rebooted. ipconfig entries exactly as before.

    Incidentally, if I manually configure the IP address on my Netgear adapter, the status comes up as connected, and I can ping the router on

    Just looking at the router online, I can see the laptop and wii connections fine.

    Anything else I can try?
  4. CCT

    CCT TS Evangelist Posts: 2,610   +6

    Usually, when I have problems, I just uninstall the drivers for the LAN and reboot and start fresh.

    In severe cases, I even pull the network card (if pullable) or disable in Bios.

    Then start anew.

    Worth a try. Jobeard is the resident expert here - watch for him or find his name and PM him.
  5. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    Go into the device manager and uninstall all USB drivers, uninstall that USB NiC driver you have also. Then remove it from the PC. Reboot the system and all USB driveres will be re-installed. Now Install the drivers for your USB NIC wait for the software to tell you when to install the USB NIC device. Once that is done installed. Wait to re-join the network using your passcode. If that doesn't work then you have some sort of conflict with your USB Nic and any other devices so check the device manager again. Make sure all onboard wireless is disabled in Windows or through your BIOS. Disabled the wired connection also. If it still doesn't work you can try to repair the connection but that might work or not in your case. You can always buy another USB NIC to try out though..
  6. macjohnson

    macjohnson TS Rookie Topic Starter

    OK, the plot thickens. I've gone into Device Manager and tried to unistall all my USB controllers, but the computer just freezes until I cancel the action, at which point I'm told the program (Device Manager) is not responding. If I choose to end the task, I get a Microsoft Management Console non responsive program alert.

    Not sure how to do this via the BIOS (if I even can), but will try to look this up now.

    Would it be relevant to know I'm running Windows XP Media Centre Version 2005 with Update Rollup 2?

    BTW - I have a huge list of USB controllers - 1 generic usb hub, 5 Intel ICH8 Family USB Universal Host Controllers (each with a different number at the end from 2830 to 2835), 2 Intel ICH8 Family USB2 Enhanced Host Controllers, 1 USB Mass Storage Device and 7 USB Root Hubs. That can't be right, can it?

    Further update - I've gone into Device Manager to try and unistall the Netgear wireless adapter, and the Belkin Network Card, but am now told that the device cannot be uninstalled because 'it may be required to boot up the computer'. I'm now going to try and reinstall the drivers to get the devices working properly again...
  7. macjohnson

    macjohnson TS Rookie Topic Starter

    Update: Using an ethernet connection, I have updated Windows once again (as prompted to do so), and miraculously my Belkin wireless card reappeared, finding several wireless networks in the vicinity. I can see my router, but with Limited or No Connectivity. My computer has been assigned an IP address of, subnet mask It is broadcasting on channel 11 and none of the other wireless networks are using this channel. Signal strength is excellent. When I edit the connection, to check the WEP key, I enter a 128 bit passphrase which I know is correct (the laptop and Wii use the same fine), but when I exit the screen and return to it, the encryption info has changed to a hex key which I do not recognise. This has happened repeatedly.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...