XP dying mysterious death, NTLDR is missing when trying to restore from backup

By werewolf ยท 12 replies
Nov 10, 2010
Post New Reply
  1. My laptop (Lenovo T500) will run absolutely fine for a few hours, then start breaking down: Word docs will lose half their text (screen won't draw properly; the docs themselves are unchanged), desktop icons lose their text, Chrome gives you the "Oh Snap" error and stops working. Bringing up task manager at that point gives you the a "taskmgr.exe failed to initialize" error. Soon afterwards, I'll get "explorer.exe failed to initialize" and I'll have to do a hard reboot. Cycle repeats. Runs absolutely fine for a few hours, but then fails. This is true even if I am only running one app (Chrome) during that time.

    Machine is about 1.5 years old, ran fine until it started doing this last week. Plenty of memory (3GB) and free hard drive space.

    I've tried everything -- run a dozen different antivirus, spyware, trojan scans (and I always have antivirus and firewall running anyway). Ran memtest86+, ran chkdsk, Office diagnostics. If anyone has more ideas, I'm all ears.

    So now I have gotten to the point where I'd like to do a system recovery. I used Lenevo's Rescue & Recovery 4 to make the backups. However, when I try to restore from this, it gives me the "NTLDR is missing" error and won't do the restore. I press Ctrl-Alt-Del and simply reboot and am back where I started. I've read a bunch of NTLDR is missing threads but none of them seem to apply to getting this message when trying to do the restore.

    Any ideas? I did partition my primary harddrive (to keep My Documents folder -- ie, most of my data, on a separate J: partition). Not sure if that is related. The Rescue & Recovery backs up the C: partition where my OS/apps are, but the backup files are on J:
  2. pjamme

    pjamme TS Enthusiast Posts: 208

    Have you tried sfc /scannow, or an Office repair?
  3. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    NTLDR missing just means that the boot process does not point to the correct place (partition) anymore. Often happens when you restore a partition, but the MBR (Master Boot Record) is either not restored, is corrupt, or points to another partition to the one you just restored into.. You cure this very easily if you have an install Windows CD. As here http://www.computerhope.com/issues/ch000648.htm

    I am not entirely clear if you have a working PC at all at the moment. Either way, you need to boot off the restore media, not your HDD. You cannot write to a partition you are running from.
  4. akannitaoheed

    akannitaoheed TS Rookie Posts: 79

    If you used the lenovo rescue and recovery utility to create backups, the you don't have the O/S yet, that must be why you're getting the "NTLDR MISSING" errors if you try to boot from the disk. The backup are just for your files. Go back there and create a set of "RECOVERY DISKS", that's what you need for recovery back to the factory condition. You would need 2 or 3 dvds in most cases for this task.

    Please do this first then let's know what's next.
  5. werewolf

    werewolf TS Rookie Topic Starter

    Thanks all - to answer your questions:

    @pjamme - thanks, yes, I have tried sfc /scannow -- this was the first thing I tried after some antivirus scans - I believe it repaired one file - then I reran it again with no problems (but didn't fix the issue). I also ran Office's own diagnostics which included memory and disk check plus file checks. It also repaired a file. Reran it again with no issues...

    @akkanitaoheed - my understanding is that lenovo R&R backs up the OS and my apps and my data. ie, it does a disk image, not just data files. When I run R&R, I select "Restore your system from a backup" then select "Restore only the Windows operating system and applications" (as opposed to "Restore my entire hard drive, including all personal data"). The system then shuts down as it is supposed to, but then instead of restoring, it gives me the "NTDLR is missing, press Ctrl-Alt-Del to reboot" error. My only option then is to press Ctrl-Alt-Del which reboots the system just fine, but again after 2-5 hours, my machine dies again.

    @gbhall - I do have a working computer. It works boots fine and works for 2-5 hours without any problem, until it starts failing. So I haven't been trying to boot from recovery disks (which I do have). My hope was to use Lenovo's R&R to restore only my OS and apps to a previous point where things worked. My thinking was that I have an infected or corrupted file there. I was hoping to avoid a complete clean install / going back to factory condition.

    I had seen links like the one you posted, but was afraid that was only relevant for people getting the NTDLR error when booting up normally (as opposed to only getting the error when trying to do a restore). I will give it a try, though.

  6. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    werewolf, if your problems begin only after some hours of use, I would suggest the problem is pretty sure to be hardware. Suspect overheating CPU, ram faults, HDD going bad, video card overheat, power supply dropping low, burst capacitors on the motherboard. Some or most of these can be tested individually after some hours of use.
  7. werewolf

    werewolf TS Rookie Topic Starter

    Thanks, gbhall. Would love some guidance on how to test the hardware.

    Here's what I'm thinking:

    Doesn't seem to be overheating CPU - laptop never feels even close to hot, and not much is running.

    I did several passes on RAM with Memtest86+. No problems. I will run overnight this time and see if it makes any difference. Is there something better to test with? To me, the symptoms appear most like a memory issue.

    I ran chkdsk to test the HDD, again with no problems, but not sure if there is a better way to test. I don't think it's this, because the failure shows the exact same symptoms each time -- first, screen stops drawing correctly -- and even files sent to the printer lose pockets of text (but not all text -- something like 1 in 20-30 words remains correctly printed), then Chrome stops working (can't access any sites -- just keeps giving you the "Snap, something's not working" error), then you can't bring up task manager ("failed to initialize" error), then you basically can't do anything. But upon reboot, everything works and all files are completely in tact. **Note: when things start failing, if I quickly close a bunch of running apps, I can usually get myself a very brief window in which I can successfully launch task manager (or another app). So my guess is I'm able to free up enough "good memory" to run something. But this lasts a very short time. Overall, the deterioration happens very quickly once it starts happening (but the laptop can go for a few hours without any problem at all. It completed multiple complete/deep antivirus scans with no problem, for example).

    Power supply seems OK (it's the original one I ordered with the laptop, direct from Lenovo), power meter seems accurate, but I don't know what signs to look for here...
    No idea what burst capacitors on the motherboard would do... but in this case, would things start working again after reboot?

    Any thoughts would be awesome.

    By the way, I did finally figure out the NTLDR error. It appeared to be a bug in Lenovo R&R version 4.1. After upgrading to the most recent version (4.23, I believe), I was able to successfully restore my OS/apps from a back up. I restored from a backup from several months ago (these problems began about 2 weeks ago). However, this did not fix the problem.

    Doing a clean factory install is still an option, but I'm still hoping to avoid since I have a more or less working computer, except that I have to reboot every few hours....
  8. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    There are utilities to watch the CPU temp. Manufacturers site to get full HDD tests, which read and write from every sector, taking ages, but stress the laptop enough to cause any weakness to show. Lenovo forums - I'm sure you have seen these - lots of problems with all areas of the machine. Sadly seems to have a fair few design faults.

    Blow out (clean) the fan. If the fan stalls or stops, the CPU will overheat well before the body of the machine gets hot.

    Reseat the ram (carefully!). If heat gradually accumulates on the connections, they can quite suddenly cause the Ram to stop working properly.

    There appears to be software to change the behaviour of many sections, such as active protection, switchable video behaviour, fan control and so on. Try experimentation there.

    Cant see any point in clean installing for what is probably a hardware fault.

    One important thing, have you checked the error log?
  9. werewolf

    werewolf TS Rookie Topic Starter

    Thanks again -

    Sorry for the dumb question but what is the error log and how do I check it???

    I've been running core temp since yesterday and temp never goes above 43 degrees (even when failing). I also hear the fan running, so I'm pretty sure that's OK.

    Also ran memtest overnight (made it through 10 passes, not sure if that is a lot or not), no errors.

    My reasoning for doing the clean install is that if that doesn't resolve the problem, then I can surely say it is hardware and ship it back to them for repair. I'm still within the 3-year warranty (I have the upgraded one that includes accidental coverage). When I bought it, I upgraded the HDD to 320 GB from the 80GB it shipped with. So I'm thinking I do a clean install on the 80 GB drive and see if it works -- that way I don't unnecessarily wipe my working hard drive. Does that seem sensible?
  10. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    To open Event Viewer, click Start, point to Settings, and then click Control Panel. Double-click Administrative Tools, and then double-click Event Viewer.
    For information about using Event Viewer, in Event Viewer, on the Action menu, click Help.

    You should look at System first, then application errors. It's hard to miss a recorded error, there is a big red splash against it.

    Try to find errors just before a known time when your PC went bananas. Application errors may contain useful info too - possibly video driver errors and so on.

    Doing a clean install on the original 80Gb drive is a good idea. Make sure you have the re-install media if appropriate. Often it is a hidden partition on the HDD, and this might well be still on that 80Gb drive. If not, be sure you understand how restore operates. Read the manual in other words :)

    Based on what you say you have checked already, ram is ok, HDD is ok, temps are ok, so you are now looking at video or motherboard problems, for which motherboard replacement is the only option. Looks like you are going to have to RTM, but the check you are proposing would be an absolute clincher if it still plays up. Good luck.

    Please let us know the ultimate outcome, whatever it may be.
  11. werewolf

    werewolf TS Rookie Topic Starter

    Thanks - I checked out the Event Viewer and didn't see anything that caught my eye. Unfortunately I don't have the logs of the time just before the machine went bananas because I had already restored my primary disk to a previous state (from 3 months ago) when things weren't bonkers, in hopes that it was a virus that would be fixed by restoring to a previous good state. (This was before I remembered I had that other 80GB drive I could have tried using.)

    So will go ahead and try the clean install on the 80 GB drive. Argh! Can't believe how many hours I've sunk on this already....

    Appreciate the help, and will report back on the outcome...
  12. mayokittens

    mayokittens TS Rookie

    werewolf, if you do RMA the laptop be sure to copy any important files from your 320 drive.
    when they do a replacement you might wind up with different hardware sent back, and that can cause some wicked driver conflicts if you plug your 320 into it
  13. werewolf

    werewolf TS Rookie Topic Starter

    Thanks for the heads up, mayokittens!

    I've just finished factory-installing the 80 GB drive, so now we'll run it for a while and see if it exhibits the same problem...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...