XP locks up when loading AGPCPQ.SYS

Not open for further replies.
I have reinstalled xp pro at least 5 times and my IBM 8315-kau lock every time it start to boot, I can't boot to safe mode. It loads drivers until AGPCPQ.SYS and go to black screen and starts to reboot again. I only have a recovery disk from Ibm. I have read that it is the sp2 pac. But I don't know how to get past it.
Some things say to install a new video card, but will that fix the problem. I believe this is a driver problem. but not sure. Thanks


Posts: 6   +0
I've seen it on multiple IBM S50 desktops - when booting into safe mode the process halts while trying to load this file - apgcpq.sys. This file is the cpu to agp controller driver. I have not found a solution yet but am still digging. Has anyone else out there seen this?

I am running Windows XP SP1.
We're experiencing the same problem with images created for the Dell Latitude 610 & 400. We have tried both SP1 and SP2 with the same results. I'll report back here if I find anything that leads to an answer.


Posts: 6   +0
An upgrade to the latest BIOS seemed to do justice for the S50 desktop I have here. However, one of my customer's wanted XP Pro on a Dell PowerEdge 400SC server, and the problem remains, latest BIOS and all.
I just recieved my xp SP2 and I can't install it. I can't get to safe mode, command promt, All it will do is just boot to the agpcpq.sys and black screen and start over. This is one of the hardest problems I had. Reinstalling xp does nothing to help.
I got in touch with IBM and they told me to update the bios. and gave me the update for my IBM 8315-kau. After the bios update it works great. So If you are having the same agpcpq.sys problem update your bios.
I've had the same problem on several Dell GX270's. I updated the bios. No change. Ran a HDD recovery tool and the HD had tons of bad sectors. This machine had just been updated with SP2. I still don't have a fix, but I was curious if anyone else had checked HD integrity and what the results were.
me thinks it's more hard drive related

Have IBM Netvista 8307-47U. Worked fine until a power failure happened during a reboot. PC is connected to UPS. Infinite reboot cycle since then. Updated to current BIOS - no change. If HDD is installed as slave, I can see and access the data. Ghost will not boot to diskette - pc locks. I believe it is related to the Master Boot Record, Partition Table. :confused:

gateway 614ge - same problem... anyone ever figure out a workaround? i tried a pci vidcard... i WAS however, able to install a working xp in a new folder titled windows2 on c:

can't access the old documents folder though :( access denied...


Posts: 9   +0
Just joined this forum after finding some useful items about the xp boot problem appearing to stop at the agpcpq.sys file load.

I have been looking at a friends advent 3312 that developed the fault of locking up on the windows screen but it would still load up into safe mode.
When I ran the logged OPTION / DEBUG I found that it appeares that the agpcpq.sys is the last driver to load before the freeze . However I noticed that the next driver in the list was the acpi control file.

I looked onto the microsoft site acpi faults and found that this power management makes an assumption on the state of the systems bios.
As I can not find a bios update for my advent 3312 ( not supported by MSI )
I decided to change the settings in the Txtsetup.sif to either force acpi on or force it off.
I found that by forcing it off ,( change properties of file to not read only and edit value in notepad , save file and set back to read only ) setting the value of the "ACPIEnable" string to 0 just under [ACPIOptions] the pc has booted up for the first time in 3 days and all looks ok .

All I can assume is that the bios has been corrupted following a power supply fail that first started the problem .

I've looked to see if this will have any detrement to the system but not found anything so far

Hope this helps any others out there , might be especially good with notebooks
agpcpq.sys lockup

I have a Dell 8400 with XP.
I have had this fault occur two or three times in the last year - either after removal of software or a crash (rare).
I could find no solution on the net, and too found that in safe mode the boot up stopped at agpcpq.sys.
But actually, the boot does not stop on my computer.
If you have this fault. Try booting up in normal mode.
It will take you past the windows boot up screen and take you to a black screen.
Nothing happens, no disk activity. It appears locked.
I have found - always that after about five minutes, yes, five minutes, the boot up proceeds and completes perfectly.
This will happen one, two or three times on successive occasions.
But usually - it seems to be the following day, the computer boots up normally and quickly and the fault does not re-occur - until another crash maybe.
Of course I do not understand what is happening. It is as if the boot up process fails to find something (e.g. like the monitor) and then does, and then remembers where it is. I am sure this is simplistic
HTH Don Lodge
VMware server can cause the same problem

I'm playing with the VMware server (a virtual machine) and decided to drop an XP Pro image on it. So far I've not been able to get the image to work and the symptoms seem to be identical to what everyone here is reporting. During a safe boot the last line that shows before the crash is Multi(0)disk(0)rdisk(0)partition(1)\WINDOWS\System32\DRIVERS\agpCPQ.sys.

For a very breif moment before the reboot it will show the following info:

A problem has been detected and Windows has been shut down to prevent damage to your computer.

If this is the first time you’ve seen this stop error screen, restart your computer. If this screen appears again, follow these steps:

Check for viruses on your computer. Remove any newly installed hard drives or hard drive controllers. Check your hard drive to make sure it is properly configured and terminated. Run CHKDSK /F to check for hard drive corruption, and then restart your computer.

Technical information:

*** STOP: 0x0000007B (0Xf896C528,0Xc0000034,0x00000000,0x00000000)

This info so far is worthless to me. It's a virtual machine and I downloaded the latest version of VMware server just this weekend. The BIOS, hard drives, video card, etc... are all virtual and not real hardware.

I'm inclined to say that it is a video issue of some type. The XP Pro Image I'm using has been syspreped and once I drop this image on a real physical PC I can not change the video mode the first time it boots up and the video will be at a lower res (probably 640x480). If I try to go straight in on the first boot and change the video mode the system will instantly crash/reboot. But if I allow it to boot up all the way, and then restart the PC, then on the second or later boot ups the video mode will be at a little larger res (I believe 800x600) and I can change the video mode without problems. I think XP on this image is improperly identifying the video on the first boot but does properly identify the video on the second boot. This is just fine as long as the computer makes one full successful boot. In the VMware case the failure to properly identify the video card may be causing the crash and preventing a full successful boot up. The system starts over and tries the same thing over and over again.

Just theory and for the most part I’m clueless the cause. If I get a real solution I’ll post it.
VMware server with SCSI

FYI: Just tried the same image in VMWare server with SCSI instead of IDE and the image still crashes at the agpCPQ.sys line.
i know the feeling its driving me crazy!!!!!!!!!!!!!!!!!

OK folks i have tried all the great stuff to get this to go away. and its not working. updated bios, format mbr, wiped hard drive, installed new os xp pro sp1 and sp2 oem cd's and burnt copy, tried ghost image. tried reloading fresh drive out of the sp2.cab file. loaded up with bart pe and look at the file but its not in system32/drivers anymore its in two diffrent spots windows/drivercache/i386/sp2.cab and windows/i386/sp2.cab but you are not able to extract it to the correct destination because it want to put out the entire cab file i did that. dont do that not fun to fix. also run memtest x86

here is a list of other files that the file is assoceated with as well,
machine in 6 instances windows/inf,

if you dont have a live file system on dvd or cd i would suggest two of them. Knoppix it a live linux file system, and bart pe wich is a windows based live file system. it helps when trying to reload the file in question. if anyone has something else to try
agpCPQ.sys: stop... fixed!

I have had my first experience of an infinite re-boot which seems associated to this agpCPQ.sys related (or relevant) problem. A customer's Acer Aspire WLMi is now back to a clean booting state after some considerable and I have to say experimental efforts. I firstly tried the Bios upgrade recommendations and followed various routes to do with other agp***.sys forums to no avail. I believe this laptop's problem stems from a crash during heavy 'game-play' in a graphic intensive app so I thoroughly inspected the ../../sys~32/drivers file using knoppix 4 on CD I could find no signs of obvious error or corruption, I copied a few files over from a healthy XPhome system in Dos mode (agpCPQ.. hal.dll) no change resulted. Next I tried a thorough work-through with Partition Magic again in Dos.. which failed to read the C drive spouting a non-specific read-error then a little 'simple thinking' struck me. No scandisk.exe was present in the C drive so I copied one in again in dos; a run revealed a fat error which it promptly fixed as well as several file errors in i386... this resulted in a normal(ish) boot up then some careful scanning and probing revealed some still resident errors which were fixed on the next re-boot. I now have some residual minor errors which are not greatly affecting system stability and performance, but there is a possible clue as to the origin of this particular problem... the ACPI mangement seems to be disabled or corrupted.. I will keep you all posted as to my findings, and the best of luck.. I hope this helps.
agpcpq.sys: stop... update!

.... The residual problem in XP after the fix I posted was 'Power management' being somewhat cobbled... several missing tabs in control panel/power options; leaving the laptop with no proper battery notification and power management features being mostly invisible and therefore near impossible to change. I believe this was caused by replacing the HAL.DLL in my 'fix' post above which was possibly part of the origin of the problem.
The answer was simple... In device manager- update driver of computer/ACPI-uniprocessor, select ".. from a list..." and from the list of available hardware choose another version of ACPI computer; I chose 'Advanced configuration and Power Interface (ACPI) PC'... this simply replaces the ACPI files and asks for a reboot. On start-up the power management features were found to be completely restored and all in working order. This absolutely non-booting, no recovery disc Acer laptop is now returning to it's owner fully fixed. I still have only patchy evidence of what causes this problem in the first place... some clues have shown up in the now working system ... Windows Update may be to blame!
I will keep delving and post my findings soon. Hope this all helps.
We Found A Definate Fix

One Mr. nacho leebray ( not his real name) in our tech department has FOUND A PERMINT FIX FOR THIS ISSUE






Good Stuff!

Hi Techman,
I think you are right. It didn't occur to me at the time when I spent hours fixing this on the client's laptop; but yes, it was formatted Fat32. I did go on to run the convert afterwards and all has remained well; so I hope it helps as many as possible to get out of watching the fastest blue screen in the west!!

To all who land here in desperation... take your time, be patient... and the answer will always come.
Intel SpeedStep could be the cause.

it worked for me (with a gateway 7322):

Plan A

1. remove the battery
2. unplug your pc
3. connect the power
4. turn on your pc
5. on the gateway boot screen, press F2 or whatever it is to enter bios setup
6. get to the following screen and disable "Intel SpeedStep"
7. Exit WITH changes.
8. Are you sure you saved the changed (Intel SpeedStep disabled)?
9. As soon as you save the config, your computer will start again, you shoudl see the windows screen, and if it doesnt start normally, give it 5 minutes. if nothing proceed to plan B

Plan B

1. remove the battery
2. unplug your pc
3. connect the power
4. turn on your pc
5. on the gateway boot screen, press F2 or whatever it is to enter bios setup
6. get to the following screen and disable EVERYTHING on the Advanced Tab. (check out the img below)
7. Exit WITH changes.
8. Are you sure you saved the changes (the advanced tab just like the img below)
9. As soon as you save the config, your computer will start again, you shoudl see the windows screen, and if it doesnt start normally, give it 5 minutes. if nothing proceed to plan C.


1. start the computer.
2. on the second screen, after the gateway logo, press F11, or whatever key it is to enter gateway recovery partition.
3. choose DESTRUCTIVE option (if you want to try backup mode, its up to you, but dont blame me if it doesnt work, try it anyway, doesnt do any harm)
4. follow all the instructions for recovery.
5. after like 1 reboot, the windows setup will detect all the hardware. you will notice the blue progress bar freezes at about half way. if it does, its ok, just disconnect the power.
6. start the computer and enter bios setup.
7. disable EVERYTHING in advanced, just like you did onplan B.

8. save and exit with changes.
9. let the computer run. now it should go throughj the hardware detection screen. if it doesnt, run again gateway recovery. just make sure you got everythong disabled in advanced before you recover again, this time, it shouldn't freeze.

That's it!!!

now after you setup windows and get it running smooth, you may re-enable EVERYTHING you disabled in the advanced tab in the bios setup. there is an option to restore all the defaults for the bios, i recommend that. if the problem rises again, try to disable everything again ad work your way up until you find whats causing it.

if it doesn't work, hey, its not my fault, but it worked for me!!

the folllwing screenshots are from my bios setup. if you have a gateway 7322 it should look like this:


fixed my issue

I killed the power during another attempted normal windows xp media center failed boot, this intern forced windows into a chkdsk, this intern sorted me right out! Hope this can help some one - if it does let me know eh?

XP reboots during startup

tweekyd and techman, my gateway 507gr has recently started doing this & I tried following your steps. In order to get to a c prompt I used a win98 boot disk, which of course does not have te convert command. My question is how do I know if my windows xp was installed in fat32 or ntfs? Since my xp is OEM I do not have a bootup disk for xp. Is there an easy way to make/get one just to get to the c prompt?

Thanks for sharing!
i have a generic gateway laptop (Pentium 4, running XP SP2) i recieved through my school which has been having this problem off and on for almost a year now. thankfully, i've finally been able to resolve the problem (again, and hopefully this time for good) by following a variation of # 2 on Solidox's list.

I say variation as my advanced options only had 2 of the fields his did, "USB Legacy Support" and "Hyperthreading" (and AutoDim if you want to get picky). After resetting BIOS to defaults and disabling these two fields I was able to get my comp to enter Recovery options for the first time in over 2 months! After doing a non-destructive restore and some trial and error I found out 'USB Legacy Support' was the guilty culprit, though I don't know enough about computers or what USB Legacy Support is to tell you why.

Hope this helps someone, and thanks to Solidox, and everyon else on this thread, it's been a light in the dark so to speak.

Sorry problem is not gone.

Happens to me on NTFS all the time
tried 2 different new Maxtor 200GB HDs on NTFS

Have AMD Dual Core Athlon 4400+ on Win2k SP2
2GB DRAM, 200 GB HD on A8N-SLI-Deluxe
Motherboard running on parallel IDE with all SATA disabled

Latest ASUS bios vs 1016 and tried even later beta version
Hangs on agpcpq.sys and won't boot in any mode

Give BSOD 7E stop error with no driver or other comments,if you are lucky enough to ocassionally get there, then sometimes 7B error and corrupts NTOSkrnl.

Running chkdsk fixes it and then happens again

Tried most bios settings, and PCI rather than PCI-E graphics card and various IDE driver controller software (Nvdia and Microsoft) and smaller DRAM memory (512MB)

Saw a Microsoft note that changing from Intel CPU to AMD on Win 2K can cause grief in sysprep because of registry esoterics left behind and is not supported.

My XP HD used in AMD dual core is a clone of a 2.8GHZ Intel Pentium 4 Win XP sp2 that runs AOK

All clones used Acronis not sysprep

Interesting problem because I tried putting in a cloned WIN 2K SP4 on same AMD dual core machine and it runs AOK on exactly the same hardware with no boot issues

Noticed VMware post on this board so it may be an XP cloning issue
or another new Intel/AMD changeover issue, and I plan to try a fresh Win XP SP2 install
works for me

It seems everyone is having this problem after a crash or shutdown. For me I took the cmos battery out to check the volts. This of course resets the bios settings. My fix for a GX150 was to re-enable the IOAPIC support in 'integrated devices'
Thanks for all the clues.
Not open for further replies.