1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP locks up when loading AGPCPQ.SYS

By mdrkjr ยท 57 replies
Feb 18, 2005
  1. Wolfdogg1984

    Wolfdogg1984 TS Rookie

    Sorry for the long post last time guys the scan just finished and it failed to boot normally. Just trying safe mode now and we have lift off so at least I can get at his files.

    I am thinking that AGPCPQ.SYS is the final one it loads anyway, which is why you are all apparently encountering the same error. It's pretty misleading because as it has already been said, AGPCPQ.SYS is displayed, meaning it has loaded successfully.

    I'm going to save some files and make a note of what he has installed and then I'll have a mess about and see if I can fix it at all. I'll keep you posted.

    Oh and thanks for everyones input in the thread as you helped point me in the right direction! Much appreciated ^^
  2. kaba

    kaba TS Rookie

    Hi all,

    ive just been searching why there was a kind of bug in that damn acer aspire 5100
    Well, im just repairing a friend's computer
    Never had the time to read all those pages

    Anyway, just thougt maybe there's a solution if the problem are persistent,
    even, when you reinstall...

    just try to format your mbr (in your favorite dos mode)
    That might format your Master Boot Record
    A tiny place where some data could be hidden...
    But never been used under windows

    Well, ive just done my subsciption earlier to maybe help someone .. someday
  3. Spandrel

    Spandrel TS Rookie

    I am now getting this exact same problem with my Gateway desktop, and I was wondering if anyone ever had an answer to this? Thanks.
  4. Nikke

    Nikke TS Rookie

    I'm quite sure this is a HAL-issue. I was able to solve this exactly the same problem by changing HALs.

    1) Boot with WinPE 2.0, 1.5 or BartPE

    2) Copy or expand Multiprocessor HAL.dll (halmacpi.dl_) and proper ntoskrn.exe + ntkrpamp.exe to your Hard drive -> %WINDIR%\System32 and replace existing files

    ACPI Multiprocessor PC
    - halmacpi.dll (renamed to hal.dll)
    - ntkrpamp.exe (renamed to ntkrnlpa.exe)
    - ntkrnlmp.exe (renamed to ntoskrnl.exe)

    Edit: You can find these files from your XP installation CD (i386-folder)

    3) Reboot
  5. TimL

    TimL TS Rookie

    Same Problem, Driver Upgrade Fixed it

    Nvidia graphics driver updated, problem gone.
  6. Emilliard

    Emilliard TS Rookie

    I'm trying to build an image in VMWare, sysprepping it and taking an image of the sysprepped image. Then pushing the image to another computer. But it fails every single time.
    I'm pretty sure what is causing it to fail is the SATA controller. Because using cretney's solution, works for me.

    This is not an option I'm afraid since forcing the system to run ATA makes it run slower.

    I have tried to add the drivers to the sysprep.inf file like this:


    PCI\VEN_8086&DEV_27C1&CC_0106 = %systemdrive%\drivers\sata\iaahci.inf ; Intel(R) 82801GR/GH SATA AHCI Controller (Desktop ICH7R/DH)
    PCI\VEN_8086&DEV_27C5&CC_0106 = %systemdrive%\drivers\sata\iaahci.inf ; Intel(R) 82801GBM SATA AHCI Controller (Mobile ICH7M)
    PCI\VEN_8086&DEV_2652&CC_0106 = %systemdrive%\drivers\sata\iaahci.inf ; Intel(R) 82801FR SATA AHCI Controller (Desktop ICH6R)
    PCI\VEN_8086&DEV_2653&CC_0106 = %systemdrive%\drivers\sata\iaahci.inf ; Intel(R) 82801FBM SATA AHCI Controller (Mobile ICH6M)
    PCI\VEN_8086&DEV_27C3&CC_0104 = %systemdrive%\drivers\sata\iastor.inf ; Intel(R) 82801GR/GH SATA RAID Controller (Desktop ICH7R/DH)
    PCI\VEN_8086&DEV_24DF&CC_0104 = %systemdrive%\drivers\sata\iastor.inf ; Intel(R) 82801ER SATA RAID Controller (Desktop ICH5R)
    PCI\VEN_8086&DEV_25B0&CC_0104 = %systemdrive%\drivers\sata\iastor.inf ; Intel(R) 6300ESB SATA RAID Controller
    PCI\VEN_8086&DEV_2652&CC_0104 = %systemdrive%\drivers\sata\iastor.inf ; Intel(R) 82801FR SATA RAID Controller (Desktop ICH6R)

    But this does not work either.

    I have tried the HAL.dll solution and this does not helt either. I have tried both at the time.

    Anyone have any experience with this? Help would be highly appreciated.
  7. DrAT2

    DrAT2 TS Rookie

    appears fixed, but no clue how, really

    Guys, this problem seems to be pretty hard-lived and mysterious.
    I had it on my acer aspire one 150 and managed to fix it, although I don't know how and why.
    AA1 150 with windows XP SP3 preinstalled, bought in december 2008 in Hong Kong.

    So it all started when I right-clicked on "My Music" and said "play in VLC". I'd done that before, I think, but this time, there was a lock, a freeze and then a blue screen. and on reboot, the "agpcpq.sys" problem (in normal mode windows loading screen would appear for a while, then blue screen).
    My problem : I could not find any "recovery" option for my netbook. I was surprised by how empty the aspire one's BIOS is, btw. Luckily i could change the boot order.
    Then I had to, first, find a usb stick, then spend hours figuring out how to get my brother's vista-empowered laptop to recognise the usb drive - a whole mess in itself, but my bad, i suppose.
    This got me quite tired, so I don't really know which of the actions I performed next was responsible for fixing the problem.
    First, I updated the BIOS to latest version (3114 as of now) with the help of Unetbootin and Freedos. Didn't fix the problem.
    I then wanted to fiddle around while in DOS, try that fix by TECHMAN, converting disk to NTFS - but it was already NTFS, so I could not access the HDD under Freedos. I went on to search tools for accessing NTFS drives in a DOS environment (figuring out along the way that techman's fix wouldn't save me).
    I am very chaotic, so I tried several tools one after the other.
    The one did the trick appears to be NTFS4DOS. I ran some disk scans (or checks).
    Then I located AGPCPQ.SYS and wanted to delete it. First, i tried to copy it to system32, whereupon my netbook froze. I unplugged it and took out the battery, tried to boot into safe mode and lo! it worked! I rebooted in normal mode and it worked and still does (the day after).
    Still don't know what is really the matter and how it was fixed. I hope this "success story" can help a techier person shed light on this error.
  8. xeper

    xeper TS Rookie

    Had the same issue on a Dell Lat D610 this morning. Running checkdisk on C with a /r switch worked perfectly. [ran chkdsk from BartPE in case you're wondering]
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...