XP locks up when loading AGPCPQ.SYS

By mdrkjr · 57 replies
Feb 18, 2005
  1. Thickdrew

    Thickdrew TS Rookie

    Lardy1664 - Thank you so much!

    Thank you for your message Lardy1664!

    I replaced a motherboard in a PC, but turned off the power management as I always do. The recovery media required that it be turn on.

    Thanks to your message, I turned power management back on, and voila!

    Thanks again.

  2. photon

    photon TS Rookie

    Visiting my folk’s house, I found their computer had been down for 8 days. It was the same story as everyone else here has already told.

    in ntbtlog.txt:
    <long series of "Loaded driver XXX">
    Loaded driver agpCPQ.sys
    Did not load driver ACPI Multiprocessor PC
    <more “Did not load driver YYY">

    After, messing around with various settings in msconfig.exe, I went to the BIOS. Long story short, it finally worked when I went into BIOS and disabled hyperthreading. Of course, while in BIOS, I was only changing one setting at a time (change one setting, test, change it back, pick another setting, repeat ad nauseum.)

    my latest entries in ntbtlog:
    <long series of "Loaded driver XXX">
    Loaded driver agpCPQ.sys
    Loaded driver \SystemRoot\system32\DRIVERS\intelppm.sys
    <more of the same>

    So I don’t know if or why hyperthreading was the problem, but this simple solution worked for me. I am just really really glad I didn’t have to format the hard drive and/or reinstall XP, so I decided to share. So, 9 hours later I can say Thanks for all your help!
  3. cheerioes

    cheerioes TS Rookie

    my laptop locks up when it is loading AGPCPQ.SYS in safe mode command prompt

    I got a new laptop not too long ago, and lately, it won't start up. At first, I thought it was a virus, but now, when I start safe mode command prompt, it's stuck at AGPCPQ.SYS. I don't know a thing about laptop issues, and I hope it will be fixed soon from the manufacturer.
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Best to do a reformat and reinstall, then if you have the same problem, get it back to the manufacturer under warranty.
  5. mick2

    mick2 TS Rookie

    hi, a workmate gave me his laptop to look at for him which was also stalling at agpCPQ.sys
    to fix it i booted from the windows disk and went into recovery console and ran chkdsk. it booted up perfectly after that.

    cheers mick
  6. agenthandyman

    agenthandyman TS Rookie

    Okay I have something for those with Windows XP w/SP2, who cannot boot to 'Safe Mode'.

    If you can change your boot.ini, then this will work... Easy as pie:

    I too was getting agpcpq and/or Wup(??) lock-up at boot (only when going to 'Safe Mode'. Otherwise it booted fine.) The following options added to the end of the "multi(0)disk(0)rdisk(0)partition(1)..." enabled me to get into Windows XP 'Safe Mode' and replace a dll which was normally loaded upon boot. After you have made your changes in safe mode, just open msconfig to change the boot.ini back to 'normal' settings.

    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS.0="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /safeboot:minimal
  7. John Paul Cook

    John Paul Cook TS Rookie

    Different causes, different solutions, here is a new one!

    Those of you who have image copied from one machine to another (either physical or virtual) have a good chance of running into both HAL and video driver problems. For VMware and Virtual PC users, this is a common problem when doing a Physical To Virtual (P2V) conversion.

    Here is a series of four links that conclude with a description of how to replace the HAL. This technique applies to moving from any machine to any machine regardless of whether the machines are physical or virtual. The overall series was written for those doing P2V, but general principles apply.

    Even after replacing the HAL, video driver problems can prevent you from fully booting into your machine and using it. If you edit the boot.ini file and add /basevideo to force VGA mode and ignore the existing video driver, you will probably succeed.

    Add a line like this to your boot.ini

    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS.0="Microsoft Windows XP Professional VGA mode" /noexecute=optin /fastdetect /basevideo

    How do you do that on a system that won't boot? Using the Recovery console is one way. Another is to attach the disk to a functioning machine and use the functioning OS to edit the boot.ini file. This even works on a virtual machine. Add your virtual machine file to a working vm and use the working vm to edit the file. Then boot the broken vm and select the option to boot into VGA mode using the /basevideo switch.
  8. Trevor

    Trevor TS Rookie

    AGPCPQ.sys and Dell D800


    My situation is a little different. I am receiving this error when trying to create a universal Ghost image created on an Intel DUO, and installing it on a Intel Centrino laptop. I have tried everything in this post to no avail. I did find the below link which pushed me in the right direction.


    It did not solve my problem but the info was useful, and I am pushing this patch on my installation point just in case.

    After much reading I am pretty sure it has to do with the Microcode Update and the Update.sys file, which is also having issues with XP SP2.

    Resolution was to create the image on a Intel P4 laptop (could use workstation) which worked on both the older Centrino and the new DUO processors.

    Funny how the image created on the DUO would work on a AMD X2 but not a older Intel chip.
  9. DHall15

    DHall15 TS Rookie

    Ok guys i am brand new to this forum and I have the same problem all of you have, however I did get the PC to finally boot in safe mode.

    After I rand during chdisk it fixed a lot of corupt files then it locked up saying there wasnt enough memory. So I rebooted then I got a Partmgr.sys error. I restarted again and went into safe mode and after about 30 min I am in windows (in safe mode) I am however afraid to restart is there anything I can do while in safe mode to stop this problem.

    Machine Dell Inspiron 8600 NSTF XP Pro

  10. bam2811

    bam2811 TS Rookie

  11. dazedjosh

    dazedjosh TS Rookie

    same problem extra twist

    all this has been really helpful but i've got a friend who has an extra twist to their tale

    their using a phillips freevents (think it's an x50 or 51) and a little while ago the cd drive doesn't appear in the my computer disply (no biggie here as i know that's just a matter of changing some settings in regedit) but as this agpcpq.sys problem also occured and the cd drive isn't appearing i can't boot from cd-rom to get into command prompt and change the partition to ntfs, unfortunately she only brought her pc round after both problems occurred.

    does anyone know of a workaround that i could use to force her laptop to boot? or is there another way of solving this problem?
  12. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Both Phillips Freevents X50 and X51... Have early failure rate on the optical drives... but they should be good for the first year.
    What is the build date on the bottom of the laptop.
    When the optical drive dies, its main symptom is that it can no longer be detected. But first, try to get around that issue. There is no way to test for it until you try a few other options.
    Remove the CD drive. It has a special clip. Shut down. Restart.

    If it boots up, I would update the BIOS to assure it is the latest, then download an install the chipset.
    Usually the updated BIOS will fix all related problems, if all your SP2 files are up to date, and all the Microsoft updates are installed.
    Then reinstall the optical drive.
    There were some good microsoft knowledgebase articles on this error, last time I checked. There are some helpful clues there..
  13. swe

    swe TS Rookie

    Hi all!

    I found that my Thinkpad had this exact problem this morning, the boot process halted when loading the agpCPQ.sys file, so I did exactly has mick2 did, i went into the recovery console and ran CHKDSK with the /r option to repair problems and after that it worked again.
  14. Cuddlywuddly

    Cuddlywuddly TS Rookie

    I have an ACER lappy 5633 Windows XP Media Center and tried the above as I couldn't get into SAFE mode (boot halted at the agpcpq.sys file) but I could get into Windows normally.

    Now, after doing the above, I can't get into windows at all - there's BSOD, which can only be read if I disable reboot on error and I'm stuck in a loop with the machine rebooting and failing constantly. And to add to my woes I don't have a Windows XP CD just a recovery one and I don't want to go back to factory settings *groan*.

    So my advice is DONT DO IT! :(
  15. Cuddlywuddly

    Cuddlywuddly TS Rookie

    PS if anyone has any advice on how to somehow revert the ACPI setting back to what it was I would much appreciate it.
  16. raybay

    raybay TS Evangelist Posts: 7,241   +10

    This fix is VERY model, mainboard, and hard drive specific. You are taking great risks on several different models of the same manufacturer of ACER, ASUS, Gateway, Lenovo Thinkpad, and Alienware... perhaps several others... If your drive is larger than 80 GB (and with certain BIOS installs), you might be at risk...so do your research.
  17. Cuddlywuddly

    Cuddlywuddly TS Rookie

    The post by TWEEKYD with the fix in didn't imply that it was anything other than simple. No posts since then have intimated that it should be done with caution either - or that it should not be done on similar ACER models.

    That's why I felt compelled to register and post - in the hope I can stop someone else following that advice and ending up in the same mess as I am now in.

  18. raybay

    raybay TS Evangelist Posts: 7,241   +10

    We agree that you did the right thing. It is not simple, and on certain systems it is indeed very risky... as you have learned. In our experience, the problems seem to revolve around very large mobile 2.5" drives 80 GB and over from Seagate and Hitachi, when combined with certain runs of motherboards.
    There are only 7 laptop manufacturers in the world nowadays... but they are sold under 87 different brand names. This makes it very difficult for users to get accurate information.
    Strangely, the problems only occur on certain models. For instance, IBM Thinkpads, which are superb, will have the errors on some and not others.
    The Gateway problems are also spotty. Alienware problems, Acer, and ASUS units seem to be more severe across more models.
  19. a_w_sarcastic

    a_w_sarcastic TS Rookie

    I'm having the same problem with a friends Gateway MX 6930....endless reboots. Disabled automatic restart to read the BSOD and got stop error
    0x24. Cant even get to a C: prompt to run checkdisk.
    Will not start Normally, Safe Mode w/Comand prompt, Safe Mode w/network, last known good configuration..etc. In safe mode it hangs at AGPCPQ.SYS and then reboots.
    Used the recovery disc and nothing happened. Used the Operating System Disc to try to get to the recovery console , selected "R", begins recovery and hangs at "please wait". I left it for a few hours and all it did was start the rebooting process all over again.
    I trieid putting a WinXP disc in from another computer to try and repair from that and had no success. The hard drive is recognized in the BIOS.
    I tried the other applicable suggestions above and had no success with them.
    I'm suspecting a bad hard drive sector (boot?)
    Any ideas or other suggestions would be greatly appreciated
  20. mmjk1

    mmjk1 TS Rookie

    XP locks and takes 19 minutes to load windows

    my windows does not start. i found about 20 minites before it loads. I ran the safe mode and it halts at agpcpq. tried reloading all software from factory settings still no improvement.

    However, when i start in safe mode and the get out of the mode and restart the computer, windows starts properly. The moment i power down (not restart) and start in normal mode, windows halts and does not start for about 20 minutes. Going to safe mode and then restarting is the only thing I can do.

    Any body, please help

  21. mmjk1

    mmjk1 TS Rookie

    my windows does not start. i found about 20 minites before it loads. I ran the safe mode and it halts at agpcpq. tried reloading all software from factory settings still no improvement.

    However, when i start in safe mode and the get out of the mode and restart the computer, windows starts properly. The moment i power down (not restart) and start in normal mode, windows halts and does not start for about 20 minutes. Going to safe mode and then restarting is the only thing I can do.

    Any body, please help

  22. bmoody33

    bmoody33 TS Rookie

    Chkdsk /r fixed the agpcpq.sys hang for me

    I had a Gateway desktop winodws xp with sp2. Some windows automatic update ran on March10, 2008 and when the computer rebooted it would get about 10 seconds into the windows startup and reboot. Safemode would hang on the agpcpq.sys file and then reboot. I used an XP install cd to bootand chose the R option to get to a command prompt. I could change to C: but when I typed DIR it said the directory couldn't be shown. So I type chckdsk /r from the C: prompt and it ran for about 3 hours, fixed one error and rebooted and was back up and running again with one error at the login about a windows restore file being corrupted and to run chkdsk. I'm going to make a complete Ghost backup before I do anything at this point then maybe run chkdsk again.
  23. cretney

    cretney TS Rookie

    SATA Operation in BIOS

    Try setting your SATA operation to 'ATA' in the BIOS.
  24. gold-blend

    gold-blend TS Rookie

    Finally fixed it !! SATA - ATI

    I had all the same problems with my Dell Precision 390 after cloning the original disk. I tried everything listed in this thread to no avail.

    I finally fixed it by changing the BIOS setting, SATA Operation from AHCI to ATI

    Now works a treat.
  25. Wolfdogg1984

    Wolfdogg1984 TS Rookie

    Hi guys I've been following this problem since yesterday. I've read all the posts and I think I have something worth while to add here.

    I have been given a computer by a friend at work to fix and I have been encountering the same problem (XP locks up after loading AGPCPQ.SYS).

    Initially the system would not load windows. It went through to the windows loading screen only briefly before entering an infinte reboot cycle. The first thing I did was load the recovery console and run chkdsk. Having read the forum and seeing all the trouble everyone has been having I was amazed to find that the machine started normally after chkdsk reported some errors and repaired them. I restarted several times and everything seemed to be working but the machine was very slow. I decided to install some anti virus and spyware removal tools and did some scans and they turned up minimal results. By then it was late so I shut the machine down and I went to bed.

    However, that was last night and today I turned on the machine only to be greated with a slightly different problem. The machine began to start normally and went through to the windows loading screen but this time after about 10 or or 20 seconds the screen went blank and my monitor showed it was receiving no signal from the computer. The machine itself was still on and showing the HDD light however. After a couple of minutes the machine restarts on its own and takes me to the boot options prompt.

    I decided to run chkdsk again from the recovery console and it returned the message that it found errors that were unrecoverable. Much to my distaste. So I decided to use the commands FIXBOOT and FIXMBR (master boot record) and see if that might aid me. When I ran FIXMBR I recieved the warning "*caution* it appears the master boot record is invalid or non-standard...etc" I decided to continue with the process.

    I tried safe mode with command prompt and that worked so I decided to try full safe mode. When it restarted this time it decided that it was going to run the disk scan before it started windows so I let it carry on with it. To my horror it began returning "File record segment XXXX is unreadable" errors. Litterally hundreds of them.

    It's still scanning now and I decided to do some resarch on what causes this error while I wait and it appears that it could very well be that the HDD has had it's chips. DskChk showed that the machine is only 4 years old (Disk partition created 2004) which surprised me. I don't know the full spec of the system as I can't get in to windows to look. All I know is that it is a Pacard Bell approximately 4 years old and uses an NTFS file system.

    Hopefully when/if it completes the scan I will be able to get into windows and back up my friends files. If even in safe mode at least but I am seriously beginning to think that the machine is on its last legs. If all else fails I have another system in which I can install the HDD and take the files that way, using my friends HDD as a slave.

    I am begining to think that not everyone here has been experiancing exactly the same problem. Especially since there are those who could not get their system to boot even after installing a fresh copy of windows and then there are also some who can use the CD to use the recovery console, enter safe mode or start windows normally. In this case it means that anyone else encountering this problem may find that some of the fixes posted here are not going to help you at all and could actually be counter productive. I would strongly suggest that before you try the most simple, least intrusive fixes like chkdsk in the recovery tool before you attempt anything serious like a reinstall or a repair.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...