Yet another crashing Windows XP

By ender ยท 23 replies
Dec 18, 2005
  1. I've been getting about 4 BSOD's a day for more than a week now. The error messages seemed random and the only common cause I could find in the Microsoft Knowledge Base was faulty RAM. So I checked my RAM quite thoroughly and right now I'm convinced that it's ok.

    Running out of ideas, I figured a reinstall might do the trick. So I wiped the entire drive with Daryl's Nuke disk and reinstalled. I ran windows update as soon as the install was finished and got a lovely BSOD while downloading the first batch of updates. I got pissed, wiped the thing again and tried to reinstall. The next 2 installations died with a BSOD while "installing devices": Stop 0x24 Ntfs.sys. This was about 24 hours ago.

    In the meantime I checked my hard drives (installed the os to another drive, ran seagate's checkdisk utility and chkdsk), changed my video board and removed my LAN board. Nothing seems to work though. I already have 6 BSOD's since my last reinstall a few hours ago and absolutely no ideas about what to do next.

    My current system is
    Windows XP Professional Version 2002 SP 2
    Soltek SL-DRV75 motherboard
    AMD Athlon XP 1600+
    768 MB RAM
    NVIDIA GeForce2 MX 200 32 Mb VRAM
    Surecom EP-320X-R PCI Adapter

    All minidumps from my current installation are attached.

    Thank you.

    Attached Files:

  2. ender

    ender TS Rookie Topic Starter Posts: 94

    Barely finished my first post and I got 2 more, one when I tried to start Matlab and another right after reboot. Here go 2 more minidumps.
  3. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Faulty memory


    The culprit is faulty memory. You can run memtest to stress the ram. If memtest reports the ram is faulty, ram is bad. However Memtest is not a perfect tool to test the memory as some faulty ram can pass memtest.

    1. Check the temperature of the CPU and make sure that it is not overheat (ie temperature < 60C)
    Make sure that the CPU fan works properly
    2. Reseat the memory stick to another memory slot. Reseat video card as well.
    3. Downclock the ram. Check to default setting if you video card is overclocked.
    4. Clean the dust inside the computer case
    5. Make sure that the ram is compatible to the motherboard
    6. Check the bios setting about memory timing and make sure that it is on
    For example : DIMM1 and DIMM2 do not have the same timing.
    DIMM1: Corsair CMX512-3200C2 512 MB PC3200 DDR SDRAM (2.5-3-3-8 @ 200 MHz) (2.0-3-3-7 @ 166 MHz)
    DIMM2: Corsair CMX512-3200C2 512 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz)
    DIMM3: Corsair CMX512-3200C2 512 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz)
    7. Make sure that your PSU have adequate power to drive all the hardware including USB devices
    8. Run chkdsk /r at command prompt
    9. Run 3DMark 2005 to test your video card
    10. Upgrade BIOS and make sure that the motherboard has no leaking capacitor

    If it still crashes, diagnostic which memory stick is faulty
    Take out one memory stick. If windows does not crash, the removed memory stick is faulty.
  4. ender

    ender TS Rookie Topic Starter Posts: 94

    Nothing is overcloacked and the CPU never goes over 55 degrees celsius.
    I cleaned the insides pretty well (I do that about twice a year anyway).
    The RAM is compatible and I've set it at the lowest frequency that my BIOS allows.
    There's no fast write to AGP, even though the video card supports it.
    I've disabled BIOS shadowing and just about everything else that is supposed to improve performance but might be a risk.
    I've taken out all USB devices (I only had a stupid mouse on USB anyway). I think I'm gonna try disabling USB altogether from the BIOS.

    I checked all 3 RAM sticks individually for 15 hours and even moved them to another computer. Nothing bad happened. :suspiciou I don'y think it's the RAM.. maybe the slots on the motherboard? But I'm afraid I dunno how to test those. :confused: They're all full, btw. I have 3 RAM slots and 3 RAM sticks. And I did try to switch them around... nothing happened though (nothing good that is).

    I ran chkdsk several times and used SEATOOLS (I have 2 Seagate hard disks) to test the hard drives and file system on every partition. chkdsk says everything is ok. SEATOOLS however says that the ntfs partition on which I installed my system has critical errors. Unfortunately it also says this right after I install Windows on a newly created partition after I 0 the entire hard disk with Daryl's Nuke Disk. Now this is somewhat funny since there wasn't much of a chance to ruin the file system cause nothing was installed except for Windows.
    I also tried installing Windows from several CD's and using 2 different CD drives.. just in case that might have been the problem.

    BTW should this be happening if the PSU is bad?... I mean, I get a blue screen, the computer doesn't just restart. If there is no power it should go down... right?
  5. Arcanum

    Arcanum TS Rookie Posts: 181

    Well, since you mentioned it even happened during the windows installation, the cause must be hardware related.
    I was thinking of asking if you were OCing, but you said you're not...

    From the way you checked the RAM (working fine in another computer, memtest 15h+ passed), I'm guessing the RAM inst faulty...

    So, the quickest solution to get to the bottom of this is - get into BIOS and load safe defaults - that settings are generally so safe (and performing badly :) ) that if it's some setting causing BSODs, it'll fix it.

    Now, if you load safe defaults and the windows installation BSODs, you've got a real hardware problem - RAM seems fine, so its either a flakey MoBo, CPU, or PSU (if it comes down to a pure hardware problem I'm betting on the PSU not providing steady current/voltage).

    EDIT: since you mentioned that there were critical errors on the ntfs right after you installed windows, have you checked your ide cables? Try switching the cable with another one and see if you still get the error (switch before the reinstall).
  6. ender

    ender TS Rookie Topic Starter Posts: 94

    The BIOS settings already have ridiculously safe settings. It was one of the first things I did. So I figure I have a real hardware problem. :( Big booboo is I can't tell which piece of hardware is giving me all this trouble. :mad:

    Anyway, I just replaced both my ide cables with new ones. I've also removed one of the harddrives and my dvd player. I hope this will stress my PSU less. If the system works ok for a couple of days with these settings I'll add the other harddrive & so on. If it fails again at some point I guess it's the PSU's fault. But, as I said in my prevoius post, it seems awfuly stange that if the PSU crashes I still get a BSOD instead of a restart.
  7. Arcanum

    Arcanum TS Rookie Posts: 181

    Actually no, the more logical thing would be for the PC to BSOD than to restart - as the power and/or voltage fluctuates on bad PSUs by a small amount - not enough to do massive memory corruption and/or CPU fatal errors (resulting in restart), but enough to cause an error(the kind when you OC to high and tend to get a freeze/BSOD - thats the memory corrupting or CPU miscalculated a few operations, though it was not that serious - just stopped the thread from being further processed by the CPU).

    I hope the IDE cable switch will help you, as I was the solution for a problem that a friend of mine had (very similar to yours).

    If not, try borrowing a PSU (though I dont know how many people would let you borrow the PSU :) ) and trying it out - if the crashes stop, it's time to get a new PSU.

    But I hope the new cables will stop the BSODs :)
  8. ender

    ender TS Rookie Topic Starter Posts: 94

    OK.. dunno if this will help anyone but something really weird is happening now. :confused: I have been trying to stress the system to see if I get any more BSOD's. And just when I think a BSOD is on it's way the screen flickers. I mean it turns black for a full second or even more. And I think ok this is it, there we go again. But then the screen comes back to normal and everything works. No minidump and nothing in the event log either. :confused:
    This is really spooky!
  9. Arcanum

    Arcanum TS Rookie Posts: 181

    Do the lights in the room flicker too when this happens? (they dont have to flicker much or long) - it may be that the power grid in your residential quarter is being overloaded (perhaps even in your house/apartment, but not that likely), therefore not delivering the standard/required voltage, or the voltage may be fluctuating too much.

    Either that or it's the PSU - so by taking out all you didnt need for reinstallation you have removed the load from the PSU by that amount that it doesnt cause a BSOD, but you can still see the effect of not enough voltage being supplied... have you got any way to try out a different PSU and see if it helps?

    Without another PSU to test with, it's going to be pretty long and tough to debug/troubleshoot :(
  10. ender

    ender TS Rookie Topic Starter Posts: 94

    :haha: No it's not the power. It's just my screen. I've had enough power problems in the past and I know how they look like. :D

    Thanks for your interest anyway. You rock. :grinthumb

    EDIT: I'm gonna get a test PSU first thing Thursday morning. And speaking about PSU's.. how much power does my system really need when fully loaded? I'll write the power drainers for you:

    Slotek SL-75DRV motherboard
    AMD Athlon XP 1600+ (no overcloaking wanted)
    768 MB DDR SDRAM at 133 MHz (currently running at 100 :( )
    2 Seagate Barracuda hard drives at 7200 rpm (one has 20 GB and the other 80 GB)
    Asus RW 52-24-52
    Pioneer DVD-ROM (4 years old... don't remeber any details about the model or speed)
    NVIDIA GeForce2 MX 200 with 32 MB VRAM (thinking of upgrading to GeForce4 with 128 MB VRAM if I can find a reasonably priced card that works on AGP 4X)
    Surecom EP-320X-R1 Ethernet Adapter (PCI)
    CPU cooler (big fan and heatsink.. dunno what model or maker though)
    one little fan on my motherboard's NorthBridge
    USB mouse

    I think that's the entire list. I would sincerely appreciate minimal specs for a PSU that can handle all of this without a hitch.
  11. Arcanum

    Arcanum TS Rookie Posts: 181

    It'll take a 300W PSU, but not some fake/bad brand 300W PSU.
    When I say 300W, I mean it must be real 300W PSU (not the ones who claim 500W, yet they are 300W).

    However, if you mean to upgrade it, I wouldnt go below 350 real Watts.

    In any case, I would go for a PSU with 350 real Watts, just to be completely sure that you'll have no problems, and get a decent brand, PSUs are a bad thing to save your money on -
    getting a bad PSU is like spitting in the wind - the spit will come back in your face (or in this case, you'll get a BSOD) :)
  12. ender

    ender TS Rookie Topic Starter Posts: 94

    I haven't had a chance to stress the system a lot lately but it seems to be working smoothly without one hard drive, the DVD drive and 2 memory sticks. So maybe power was the problem afterall or maybe it was just one of the components I removed. I'm still testing. ;)
    I've just changed the PSU with a newer one I borrowed. This one's supposed to support constant 220W and peaks of up to 400W. The old one was a 'fake' 300W... it supported only 160W with peaks of 300W. What puzzles me is that I haven't made any changes to my hardware in almost a year (I added a memory stick sometime in March or April). It seems strange that I should be having hardware problems so late after my last configuration change. :confused: I guess my PSU just got a bit old. :p

    Thanks for your help.
  13. Arcanum

    Arcanum TS Rookie Posts: 181

    Your old PSU isnt by any means good for the rig you currently have - if you could get all of the hardware to work at its maximum consumption, your old PSU would fall short in a couple of seconds/mins for sure, BSOD more than likely...

    Get yourself a brand name 350W PSU (the price difference between 300 and 350W is low, and you'll be sure the PSU wont be a problem anymore) and I think you'll be okay, even if you add a card or two, or a new hdd/optical drive.

    Hope everything works out and at least some of my responses were helpful :)
  14. ender

    ender TS Rookie Topic Starter Posts: 94

    Just got another one. :mad: And it appears that sombody else got one earlier today while using my computer. Minidumps attached in case anybody cares to look.

    P.S. It was scnning for viruses in both cases. First minidump is with NOD32 and the other with ClamWin.
  15. Arcanum

    Arcanum TS Rookie Posts: 181

    Hmm, both of them are:
    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high."

    Frequently caused by incompatible/bad drivers...
    Your board is based on an KT266 chipset - what Via 4in1 drivers are you running?
    Have you tried installing WinXP on an FAT32 partition and seeing if it makes any difference?
  16. ender

    ender TS Rookie Topic Starter Posts: 94

    Sorry about the late reply. I was offline for 2 days. :mad: My internet provider sucks big time. :mad:

    First thing I did after getting that BSOD was to reinstall everything (on a NTFS partition). I didn't get crashes anymore. However, I had some very strange errors when I tried to install software (they usually said that archives were corrupt). One such example was Firefox not installing because it thought that the instalation file was corrupt. Very fishy thing since I had just downloaded it from the main Mozilla site. :suspiciou I was also seeing a lot of file system problems every time I ran chkdsk and, on top of this, Partition Magic 8.0 believed that my NTFS partition (which has about 8 GB and was mostly empty) contained more than 6 billion files. Yup, I wrote that right... 6 BILLION! :eek:

    So I figured something was definitely wrong and I reinstalled everything on a FAT32 partition. For some reason I haven't had any more problems or BSOD's and the computer will soon have 24 hours of uptime. :D

    Right now I didn't install any VIA 4 in 1 driver but when I got my last BSOD I had just got the latest one from :
    I also think that my BIOS is up to date. It was updated when I bought the computer about 4 years ago and Soltek hasn't released a new BIOS version since 2002 (or at least that's what their web site said).
    I always get the sound driver from Windows Update. It's the VIA Crystal smth. I don't remember having any sound problems and I wasn't listening to music when I got BSODs.
    Also, last week, when I the computer started crashing big time, Windows was on a FAT32 partition. I have not used NTFS much in the past because I also need to run linux at times and NTFS is read-only for linux. So I don't think that was my initial problem and I don't understand why it should be a problem anyway. Shouldn't NTFS be better than FAT32? It's supposed to be an upgrade afterall. :confused:
  17. Arcanum

    Arcanum TS Rookie Posts: 181

    Well, I tried converting two of four partitions on my rig to NTFS from FAT32 to NTFS a year ago, I formatted them first then did it with partition magic 8.0 - and boy oh boy was I in a surprise - had the same symptoms as you, files corruption, insane filesize or number of files, so I reverted back to FAT32, never knew why it happened :(

    Anyway, try staying away from chipset drivers a while and update the rest of the drivers - if it doesnt BSOD anymore, probably the latest Hyperion drivers dont like your MoBo...

    BTW since your mobo is based on KT266 which is older than KT333, the newest Hyperion drivers arent recommended for installing - Via recommends you dont install the newest drivers on boards older than KT333, as you could run into problems, maybe that was the catch...

    I think the last recommended drivers for your chipset were 4.43 if I remember correctly.
  18. ender

    ender TS Rookie Topic Starter Posts: 94

    I didn't install the Hyperion driver! The 4 in 1 driver is at the bottom of the page (if you visited the link I gave earlier). ;)
  19. Arcanum

    Arcanum TS Rookie Posts: 181

    Hyperion is 4 in 1, just a new name for it :)
    So you installed the 4.43 4 in 1 and had problems?!
    Weird, that's one of the rare releases that noone had problems with, even my current KT133 is happily chugging away on that version :)

    Well, the WinXP comes with driver version 4.38 just for the info, so it ain't that much older - only 5 revisions from the newest for your board, and it only has minor bugfixes, dont bother with it!

    If it works with the WinXP 4.38 version, be happy with it :)
  20. ender

    ender TS Rookie Topic Starter Posts: 94

    There I go again. :( I just had another lovely BSOD (minidump zipped and attached as usual).

    Anyway, this time I think I know what's causing my trouble. I was trying to download some pictures from my digital camera when it happened and the error said something about an USB driver. Nothing very strange about that except for the fact that I have been using this camera for 2 years and I never had any trouble with it. It never needed a special driver. The installation CD that came with it has drivers only for Windows 2000 or lower. The manual also said it didn't need a driver for Windows XP. The camera is a Minolta DiMage E323. But I really don't think it's the camera's fault. More likely it's my USB acting all wrong.

    Any ideeas on what I should try next? It's a rather busy time for my camera and I'd really like to be able to use it. ;)
    BTW : Merry Christmas everybody! :p

    EDIT: It almost happend again (twice actually), but I managed to disconnect the camera in time. :D It seems that when I'm about to get a BSOD my screen flickers, just like I said in a previous post. If I manage to get the camera disconnected within a couple of seconds I'm safe.
    Another interesting thing that I noticed is that some of the photos I was downloading when I got the BSOD were corrupted. They look like something you scanned wrong, each half having a different different resolution and colours. :confused:
  21. Arcanum

    Arcanum TS Rookie Posts: 181

    Just checked the minidump - yup, definately USB driver fault, really weird, cause I have never seen that, guess there's a first time for everything.

    Nothing to do with the camera, it's the usbuhci.sys.

    Normally I would recommend reinstalling chipset drivers, but you said that causes BSODs. On the other hand, that was on the old 'corrupted' XP, so you could try installing newer Via 4in1...

    Other than that I'm really at my wit's end, I don't have any more ideas, sorry I couldn't bring happier news for Christmas :(

    I wish you a merry Christmas, have a good time, and try not to think too much of this :)
  22. ender

    ender TS Rookie Topic Starter Posts: 94

    Thanks a lot. I'll try to upgrade the VIA driver and see if it works this time. I'm gona be away for a while though so I'm not sure when I'll be back to post the results.

    Have a happy happy holiday. :giddy:
  23. ender

    ender TS Rookie Topic Starter Posts: 94

    I'm back. I installed the 4.43 4 in 1 driver and tested it for a while. Here's a short version of the story.

    The first time I tried to connect my camera my screen flickered again. :blackeye: Bad omen... I disconnected it immediately and I downloaded the photos on another computer.
    However, I didn't want this to remain a problem so, everything being securey backed up, I figured I might as well try again and see what happenes. Nothing bad has happened so far (no more screen flickers either) and I've downloaded the initial pictures at least 6 times. :D I've also taken 'test' pictures several times (just to fill the memory card with something new) and I've downloaded those too. All in all I think I've downloaded a full memory card for about 20 times and I've never had a single problem. :grinthumb

    Seems like this problem is fixed. The fact that my screen flickered that first time still bothers me though. :confused:
  24. Arcanum

    Arcanum TS Rookie Posts: 181

    Thanks, I wish you happy holidays as well :)

    I'm crossing my fingers in hope this is the end of all the problems for you :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...