4GB USB drive shows only 64MB. Any idea how to fix?

By sharjeel ยท 8 replies
Feb 6, 2011
Post New Reply
  1. Hope this is the right forum for this topic
    any way
    I got a Sandisk Cruzer palladium 4 gb usb drive. I gave it to a friend and after getting back it shows only 64mb of space, and it cannot be formatted and cant be opened as well.
    IN disk management the partition option is disabled. ANd it was a u3 cruzer drive but now the software cant be installed on it.
    I have also tried Hp usb disk format tool but that still doesnt format the drive
    One more thing is that the usb light is not on continuously, it keeps on blinking.

    Any ideas how to fix the usb drive?
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    A couple things:

    Sandisk Cruzers are often faked. Its possible yours is, especially if you ordered it real cheap from somewhere online or ebay. There are a few websites that can help you identify if its genuine or not.

    HP Format tool usually fixes these type of problems. So since it didn't the drive simply may have died.

    If you have a virtual machine with 9x on it, or access to a machine running 9x, try formatting it with that machine. I don't know exactly why that brings some drives back to life, but several years ago when people were dual booting XP and 98 I saw a couple unformattable (in XP) drives get fixed by formatting in 98. I've never tried it, but whatever 98 does differently might be similar in Linux, so you could try booting off a live linux disk and formatting it that way - I have never seen this work, but I've also never seen it attempted. Both of those suggestions are kind of a long shot though and I wouldn't get your hopes up too much.
  3. sharjeel

    sharjeel TS Rookie Topic Starter

    thanks 4 replying. but is there any other way except formatting on windows 98? like any software or something like that which can be done through xp?
  4. mike1959

    mike1959 TS Evangelist Posts: 1,034   +55

    You could download and try; http://www.partitionwizard.com/free-partition-manager.html
    After you have installed it, and when you launch it, there is a delay of 10 seconds before the screen appears, don't think it's crashed.
    It is very similar to Easus Partition master, but with no time limitations.
  5. sharjeel

    sharjeel TS Rookie Topic Starter

    didnt solve. but thanks. i ll send it back to sandisk and have it checked
  6. jobeard

    jobeard TS Ambassador Posts: 11,128   +982

    Any Linux can format that device; just set fs=vfat
  7. pahmmz

    pahmmz TS Rookie

    Try to download winsetupfrom USB and install it.,try to format the flash drive using USB formatter.,
    ravefuturemusic likes this.
  8. ravefuturemusic

    ravefuturemusic TS Rookie

    thank you
    u saved my 64gb usb stick :D
  9. Ateeq Ra

    Ateeq Ra TS Rookie

    Mine got fixed simply by 'error checking tool' in properties of drive on 'windows 10'

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...