Acer 5535 won't accept my new 12-cell battery

By davidwoog ยท 8 replies
Jul 1, 2011
Post New Reply
  1. I have a new 12 cell battery for my acer 5535. Computer beeps a warning and shuts back down on start-up. Incorrect battery message. battery is a 12 cell, 10400mAh, AS09A41. The battery is made for an Acer 5517-5535. Does something need to be re-configured in the computer to accept the battery? The battery will run the computer if the computer is plugged in to the AC first and then the battery is installed, then unplugged from the wall. Both batteries are 11.1v
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The Acer Specs say "48.8 W 4400 mAh 6-cell Li-ion battery pack" The 12-cell may not work here
  3. sigmat

    sigmat TS Rookie

    I am having the same problem. Is there a bios update available that will accept this new battery?
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I'll repeat my answer!
  5. sigmat

    sigmat TS Rookie

    I understand what you mean, but the battery does in fact work, its just a matter of having the BIOS recognize it. I'm currently trying to contact tech support with Acer to see if they can release a BIOS update. The battery has the correct voltage rating, which is the part of the rating which may be incompatible with a computer. the mAh rating indicates its capacity, and this varies from battery to battery (12-cells have more capacity, 6-cells less, etc).

  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "12-cells have more capacity, 6-cells less, etc"...

    I understand this too, but the laptops charging circuits may not be able to recognize or "charge" the additional cells
  7. sigmat

    sigmat TS Rookie

    Thanks for the speedy reply.

    I've been able to charge this battery to what I thought was maximum capacity (since status is not reported anywhere), and then used it for approximately 5 hours while it was discharging. I then repeated this exercise...

    I took that as an indicator that the computer is able to charge the additional cells fine. I've actually had this happen before on a Sony Vaio, however that 12 cell battery came with a cd for flashing the bios, after which the battery was recognized and worked fine.

    From what I understand, to the computer's charging circuits a 12-cell and a 6-cell are identical, it just feeds it current until the battery is charged. Correct me if I'm wrong though.

  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You're the one having this problem, not me. If you have seen this happen with a Sony Vaio and that a bios update solved the problem, but no bios update is available for the Acer, why ask here?
  9. sigmat

    sigmat TS Rookie

    hahaha alright. i'll post here if i can get them to release a solution, maybe it'll help the other guy out too...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...