Acer Aspire M5641 Nvidia LAN drivers

By Alexexex · 7 replies
May 6, 2012
Post New Reply
  1. Hi guys, my friend accidentally uninstalled his nvidia lan drivers for his acer aspire m5641 computer, and cannot find proper downloadable drivers anywhere else. The closest thing I've found was this link: however, when I do download the Lan file, it extracts into a bunch of .dll and .sys files, which from my understanding are unusable. I've looked at different sources to download the files, however they end up being the same, as from the acer website. Hopefully there may be a way to find drivers with an executable file that will easily install onto the computer.

    Thank you very much guys!​
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

  3. Alexexex

    Alexexex TS Enthusiast Topic Starter Posts: 106

    I've followed the steps suggested, and the result is windows telling me that my network adapter is already updated? I'm not sure what that means, since it clearly isn't due to the fact that I'm still not able to access the internet. Maybe I'm missing devices in the device manager?
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    List any Problem devices
    • Make sure devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
    • On the other hand, if no devices are listed, tell me so
    Generate and attach a DirectX report
    • Click Start->Run, enter dxdiag and click OK
      ===> If you’re running 32 bit Windows, dxdiag will launch on its own
      ===> If you’re running 64 bit Windows, you’ll see 64-bit DxDiag. Click it to launch the 64-bit version of dxdiag
    • Notice progress in lower left window corner
    • When done, click Save Information button and save to your Desktop
    • The upload and include the file to your next post
  5. Alexexex

    Alexexex TS Enthusiast Topic Starter Posts: 106

    There are 2 devices under the "Problem Devices" section.

    Device: Not Avaliable
    PNP Device ID: PCI\Ven_10DE&DEV_07DC&SUBSYS_01371025&REV_A2\3&267A616A70&78
    ErrorCode: Drivers for this device are not installed.

    PNP Device ID: ROOT\*ISATAP\0000
    Error Code: This device is not working properly because Windows cannot load the drivers required for this device.

    My DirectX report is attached.

    Thanks for the speedy responses.

    Attached Files:

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    That #1 Problem Device is your Nvidia Ethernet Controller. So we know it's there and detected. But a couple odd things

    1. You ran a 64bit version of DxDiag but it shows odd results. Are you running 32 bit Vista?? Click for how to check if 32 vs 64 Windows

    2. When you tried to update the driver using DeviceManager, are you sure you selected the right device? The device will probably appear in DevMgr with name "Not Available". If you right click it->Properties->Details tab its Device ID string will begin PCI\Ven_10DE&DEV_07DC

    /* edit */
    It might be appearing DevMgr listed under Other devices or Network

    / EDIT 2 */
    forgot one more thing... For Vista, when you check in DeviceMgr for PCI\Ven_10DE&DEV_07DC on the Details tab, you may need to select Hardware IDs from the pull down menu. You only need look at the string at the top of the Hardware ID list
    Alexexex likes this.
  7. Alexexex

    Alexexex TS Enthusiast Topic Starter Posts: 106

    Thanks for your help. It so happens that I was trying to update my network adaptor instead of my "Unknown device".
    I am running a 64-bit version of Windows Vista.

    Thank you so much for your help!
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    so try updating that unknown/other device. I also think that 2nd LAN driver on nvidia site is the 64 bit lan driver. let us know how it goes

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...