Social All images won't load on Facebook on any computer on my network

Dhakos

TS Enthusiast
A few weeks ago I started to notice a few photos I'd try to see wouldn't load, but I thought nothing of it. Then I realised it was the same pictures that would never load, around 5-10% of any photos would just not load for me. Frustrated I viewed the image directly, and still no photo, then I viewed the image directly through a proxy, and hey presto, it appeared, so for some reason my network was being denied that photo? :S

Anyway, now it seems to be happening with every single profile picture, including ones on peoples profiles, and all the thumbnails, not a single one loads, and its the same on all computers I have at home (on my network)
I haven't tested whether these load on a proxy because that would mean logging into facebook on a proxy which I don't want to do.

The only suggestions I've found on the internet are ones to do with loading image exceptions, caching etc, but its nothing to do with my browser (I've tried all the suggestions, even tried IE anyway) and it happens on all my other computers too, so can't be computer specific.

I've just tried rebooting my router too, no joy

Anyone got any ideas to this crazy problem? Much appreciated
 

Ghost360

TS Rookie
I have the same problem on my desktop computer. I don't have the problem on my laptop so I'm guessing mine isn't to do with any network problem but you might of installed a certain program on you computers that made the problem happen in the first place. I noticed my desktop didn't let me view photos on facebook and other websites when I was in the time period of installing programs on my computer, it might of even been an anti spyware software I can't remember since I installed alot of things including updates from windows ... It didn't bother me until now since my brother keeps complaining about the problem but I'll be sure to post it here if I come across anything ...
 

Dhakos

TS Enthusiast
I posted this almost 11 months ago haha, eventually I managed to fix it, well, find a nice workaround anyway, hopefully it may help you? I accidentally discovered that if I viewed facebook over a secure connectoion (https instead of http) the images would load fine, so all I did was change the setting in facebook to make it so that all my pages are loaded in https and I haven't had a single problem since (Account Settings > Securtiy > Secure Browsing > Enable) Good luck :)
 

Avinash Mishra

TS Rookie
I had the same problem..moreover my wifi connection being far slower than the ethernet...now I browsed the facebook in secured browsing..disable it..and now the pictures are loading :)
 

AxelRFoley90

TS Rookie
I had the same problem. was using chrome with a timeline remover extension, disabled the timeline remover and the pictures loaded almost instantly! Facebook's sneaky way of getting everyone to have timeline I reckon!
 

DonRonBon

TS Rookie
If all above fails (as in my case), try changing your DNS server address. That worked for me! (just use any big public DND server)
 

ris_yaj

TS Rookie
Yo dhakos, thanks,your post really helped.:)

I posted this almost 11 months ago haha, eventually I managed to fix it, well, find a nice workaround anyway, hopefully it may help you? I accidentally discovered that if I viewed facebook over a secure connectoion (https instead of http) the images would load fine, so all I did was change the setting in facebook to make it so that all my pages are loaded in https and I haven't had a single problem since (Account Settings > Securtiy > Secure Browsing > Enable) Good luck :)
 

ScottyTheBody

TS Rookie
I have no problem loading photos to Facebook that I have scanned onto my computer. When I load pics from my Minolta Maxxum 7D using the USB cable or the card reader slot, they load onto the computer with no problem, but when I go to upload them to Facebook I can't even see them. I need help with this one.
 

majidf

TS Rookie
Hi I have same problems but I could not find anything on google. just found this forum.
for some reason my ethernet wont work so I bought a wifi dungle usb and wireless modem. now I get internet using wifi but at start I could not even load facebook! I could load other websites except facebook. I add dns too my network and it works, facebook came back. but some of pictures wont load. since there is no secure browsing in settings anymore and it takes me too https automaticlly I cant find a way to see full fb.
and the other problem is I can not load soundcloud website too! (I could before that)
sry for my bad english.
 

Julio Franco

TechSpot Editor
Staff member
Those of you arriving here in 2019, know that Facebook is experiencing outages this morning due to a server configuration change. The global outage is only affecting certain features, particularly new posts and loading of photos.

The service interruption extends to WhatsApp and Instagram, also owned by Facebook.
 
  • Like
Reactions: MattS

Latest posts