ASRock Extreme 3 Gen 3 -- can't access BIOS anymore. Computer boots fine though.

By munch2477 ยท 14 replies
Jan 27, 2012
Post New Reply
  1. I just built my first PC last week and things have been fine for the most part. A few little problems here and there though. This might be a little long-winded but I would rather give as many details as possible.

    My problem started with finally organizing my cables and peripherals. I plugged in my 2 external hard drives (2 different Seagate drives) into 2 rear USB 2.0 connectors and when I booted up, my computer kept going straight to BIOS without me touching any buttons. I would try to exit BIOS and start windows but I would keep looping back to BIOS everytime. When I unplugged them before I booted up, my pc would be fine. I could also access the data on the drives when I plugged them in after the boot.

    I posted somewhere else about my issues and someone recommended disabling my usb and usb 3.0 legacy support. They also recommended updating my BIOS if it wasn't up to date.

    Sure enough, I went into my BIOS and my version was 1.20 (newest version is 1.30). While I was in BIOS, I disabled my USB and USB 3.0 legacy support. Saved and exited and my computer booted up.

    I downloaded the windows option for BIOS and tried to run it but I kept getting "Error : Firmware does not have flash (AFUWINGUI) support". So one question would be, is this error a big deal? I'm not going to try to install it from windows so I feel like it won't matter. After doing a little research I now see many people recommending not to do a windows installation of BIOS. I should be flashing it with a USB drive.

    I downloaded the flash version and put it on a USB thumb drive in FAT32 format like ASRock suggested. When I turned on my computer I attemped to enter the BIOS by tapping F2. Windows ended up starting without going to BIOS. I tried this several times as well as F6, F8, F11, and DEL but nothing seemed to get me into my BIOS.

    So this is where I stand now. I can't access my BIOS and my PC automatically boots to Windows even with my USB stick in. I have a feeling it has something to do with the USB Legacy Support I disabled, but I also don't know how to enable it without going into my BIOS.

    Core i5-2500
    ASRock Extreme3 Gen3
    Corsair Vengeance 8GB (2 x 4GB) DDR3-1600
    Corsair Force Series 3 60GB 2.5" SSD
    Sapphire Radeon HD 6870 1GB
    Corsair Enthusiast Series TX V2 650W
    Windows 7 Ultimate SP1
    Microsoft Sidewinder X4 keyboard
    Logitech Anywhere Wireless Mouse
  2. sheft

    sheft TS Rookie

    Is your keyboard USB or PS/2? Normally a USB keyboard will not work before booting until you've enabled it in BIOS already. So basically you need to use an older keyboard (or an adapter) the first time, and then enable USB in the BIOS to use your USB keyboard.
  3. munch2477

    munch2477 TS Enthusiast Topic Starter Posts: 104

    I see what your saying and that's what I suspected. My keyboard is USB. It used to work in my BIOS before I disabled the USB Legacy Support. Now I feel like I shot myself in the foot by disabling it. Are there any other options if I don't have a PS/2 keyboard?

    EDIT: I've read that I can reset the CMOS to default settings by hitting the button on the back of my PC. Unfortunately I'm at work so I will give this a shot when I get home.
  4. sheft

    sheft TS Rookie

    That's always worth a shot, but it depends on whether USB is supported by default or not. If not, then you either need a PS/2 keyboard or a USB / PS/2 adapter
  5. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    I suggest resetting CMOS and installing all drivers from the asrock disk that came with the board. Don't attach the mouse and just use the keyboard. Some people have to try 3-4 different keyboards to find one that works.
  6. munch2477

    munch2477 TS Enthusiast Topic Starter Posts: 104

    Well it seems that USB is supported by default since I used the same USB keyboard during the setup process. Hopefully this should take care of my problem.

    I already installed all of the most recent drivers for my ASRock mobo. Would I really need to use the older drivers on the disc?
  7. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    If you reset the BIOS you will have to start all over with the flashing process.
  8. munch2477

    munch2477 TS Enthusiast Topic Starter Posts: 104

    Ok so resetting CMOS seemed to fix my issue. Everything starts up fine now.

    On to my next problem - I can't get my BIOS to update at all. I tried in windows but that failed (see initial post). I tried using instant flash with the .exe on my usb thumb drive but it's not working. Basically it recognizes the file in instant flash but when i select it it restarts the BIOS. Then if i hit exit, the screen will be black with a white bar at the very top and bottom and the white cursor block at the top left.

    I tried to make a bootable USB drive using the dos file from ASRock's website but I got the same frozen black screen.

    Am I doing something wrong? I'm losing my mind here.
  9. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    Start by only having the bare minimums in your PC. Read your manual and MAKE SURE YOUR RAM IS IN THE RIGHT SLOTS What Firmware version do you have, 1.10b? Borrow a normal/standard USB keyboard for the setup if you are having keyboard issues. Do you have a SATA HDD?

    Only install these components until you can get to your BIOS. The more components installed the more troubleshooting there will be.
    Core i5-2500
    ASRock Extreme3 Gen3
    Corsair Vengeance 8GB (2 x 4GB) DDR3-1600 (At least one put in to the correct slot)
    Corsair Enthusiast Series TX V2 650W
    Microsoft Sidewinder X4 keyboard
    reboot and CONSTANTLY keep pressing the delete key....Can you enter BIOS?
  10. munch2477

    munch2477 TS Enthusiast Topic Starter Posts: 104

    I'm back to one of my original problems it seems. My computer boots to BIOS automatically now. It used to be only when my external HDs were plugged in but now it boots to BIOS no matter what. I just discard changes and exit and my pc boots windows after. I guess it's not that big of a deal but it's just a really frustrating problem.

    My BIOS is also on the last version 1.20 (it should be 1.30). I honestly don't know how to update my BIOS. I can't figure it out.
  11. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    did you "save and exit" your bios?
  12. munch2477

    munch2477 TS Enthusiast Topic Starter Posts: 104

    Whenever I try to save and exit it ends up just looping around back to the BIOS again. The only way I can start windows is by discard and exit
  13. Buckshot420

    Buckshot420 TS Enthusiast Posts: 301

    what is the BIOS boot order?
  14. munch2477

    munch2477 TS Enthusiast Topic Starter Posts: 104

    I have the SSD HD in the 1st slot and my dvd drive in the 2nd slot. There's nothing in my DVD drive either.
  15. munch2477

    munch2477 TS Enthusiast Topic Starter Posts: 104

    So I think I figured out my issue. I was digging around on google and I found people with similar problems with my mobo. Apparently when your peripherals are in certain USB spots, it will cause the boot loop that I was seeing. I isolated the USB slot on the back panel that was causing my issue and plugged in my keyboard and mouse to different spots. I left everything else unplugged. I restarted, bypassed my BIOS automatically, and windows started normally.

    Then I downloaded my BIOS to a USB drive in FAT32 format (used the instant flash version) and my BIOS updated succesfully. It also looks like this BIOS version fixes USB compatibility. Sure enough, after I shutdown, I plugged in all of my peripherals (webcam, both external HDs, keyboard, mouse, and wireless internet USB adapter), restarted, and windows booted normally. My issue has been solved. Thanks for your help.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...