"AutoChk.exe not found"... As XP Boots...

By Toast0r ยท 26 replies
Feb 27, 2003
  1. Okay, I stuipedly 'accidently' deleted some random registry files... The result is as XP boots it gives my a error that AutoChk.exe cannot be found... XP still boots fine.. But I would like to fix the error. What exactly is AutoChk? Do I need it?.. I have AutoChk, I did a file search. So I must of removed something that links bootup with AutoChk.. Help :blackeye:.
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    First of all, what the hell were you doing deleting things in the registry that you did not understand? As far as I can see, you have got what you deserved.

    Anyway, try loading the "last good known configuration" which should have a backup of the registry from the last time everything booted properly.

    here is how you do that : http://support.microsoft.com/default.aspx?scid=kb;EN-US;315222

    Hopefully it will work, but if not then to be honest I think you will have been taught a valuable lesson.
  3. StormBringer

    StormBringer TS Maniac Posts: 2,244

    I just hope you haven't disabled System Restore ;)

    The registry is a place of great wonder and can unlock many wonderful things for your system. It can boost performance, enhance stability, and make Windows kneel to your superior power. Although, in the hands of ignorance, it can mean certain doom for all you hold sacred. Don't go tampering with forces you cannot possibly comprehend. :dead:

    OK, so maybe that was a little too dramatic. If you don't fully understand the registry and how it works, you shouldn't mess around in it, for sooner or later you will screw something up, looks like sooner in this case. If you wish to learn more about the Windows Registry and the power it holds within, go here
  4. Toast0r

    Toast0r TS Rookie Topic Starter Posts: 22

    :( Didnt work. Mut have something to do with Bootexecute...It gives a error saying where the directory of AutoChk can't be found but it is there..
  5. Toast0r

    Toast0r TS Rookie Topic Starter Posts: 22

    We must have posted at the same time.. System Restore is disabled too heh. I'll check out that link..
  6. StormBringer

    StormBringer TS Maniac Posts: 2,244

    The link won't help with this, it might help prevent future screw ups though
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    where do you have autochk.exe?
    It has to be in \windows\system32
  8. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    The main problem is that he deleted or changed something in the registry, and he has no idea what. that's like looking for a needle in a haystack....
  9. Toast0r

    Toast0r TS Rookie Topic Starter Posts: 22

    Yep its in \windows\system32... But at bootup it dosnt think so..
  10. StormBringer

    StormBringer TS Maniac Posts: 2,244

    that is because of the keys you deleted from the registry. If you had thought to back up the registry, you could have restored it. You should always backup the registry before making changes. It also isn't a very good idea to disable System Restore. The trade off of being able to correct a serious problem is not worth the resources you are saving.
  11. Toast0r

    Toast0r TS Rookie Topic Starter Posts: 22

    Hey, I did a little research and screwed around with the BootExecute & autochk strings... They wernt there so it must of been those I deleted? So, yea I was makeing new reg keys/varibles in different ways and such because I didn't know how they should exactly be put... Looks like I got lucky LOL.. The error dosnt show at startup anymore.. I was pretty suprised.
  12. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Can you tell us what you did? I think so should. After all we tried to help you. And the info could help someone else with a similar problem.
  13. Toast0r

    Toast0r TS Rookie Topic Starter Posts: 22

    Okay, I didn't write the solution because I didn't know what exactly did it with different theories I put it into it.. Though, luckily I got it on my second try and removed the useless other tries in the registry. So here whats I did for Home XP:
    Went into registry

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\

    In session manager (to the right) I created a Multistring Value and named it BootExecute.

    In value data I put:
    BootExecute : REG_MULTI_SZ : autocheck autochk *

    Tada :chef:

    Yeah, something I did notice was that boot up was faster when the error was around. Probably because auto check was dissabled.
  14. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Well done!
  15. DigitAlex

    DigitAlex TechSpot Paladin Posts: 536

    It's very funny guys :)
    I really like the style of the first answers of Phant & SB, you really rock :)

    It's also funny to notice some of you are less serious and stuff on the IRC channel :p
    BTW the other post (UT contest) where a noob tried to explain to Phant what a router is and Phant's answer is great, I really enjoyed :D
  16. GuGoRaKu

    GuGoRaKu TS Rookie Posts: 20

    My XP installation had the same problem. This problem was caused by partition magic. I really don't know what happened after PM reboot..

    Problem was solved by adding

    "BootExecute : REG_MULTI_SZ : autocheck autochk * "

    After the next reboot this entry dissapeared from the registry.

    :D :grinthumb
  17. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Wow thanks for the help there GuGoRaKu.

    And :wave: :wave: Welcome to TechSpot :wave: :wave:
  18. GuGoRaKu

    GuGoRaKu TS Rookie Posts: 20

    Thanks! :)

    I forgot to mention:

    When this problem occured Partition Magic 8 stopped working and gave me an 504 error and quit. Disk Image reported an error number greater than 10,000! and quit.

    I did not connect the two issues, but after fixing the "autochk.exe" boot problem according to Toast0r (Thanks)..
    Both PM and DI started to work properly! :grinthumb two problems solved in one!
  19. Toast0r

    Toast0r TS Rookie Topic Starter Posts: 22

    Wow somebody else actualy had the same problem lol. Glad I could help :eek:.
  20. Shade[ST]

    Shade[ST] TS Rookie



    I also had the same problem though it is linked with diskkeeper in my case. How do I access the registry to add the required string if I can't boot??
  21. Gibson

    Gibson TS Rookie

    I can't boot either...

    How can I get this entered into the registry too?
  22. Gratemyl

    Gratemyl TS Rookie

    i've got a similar problem! Though I did not change any registry settings, the same thing happened to me, but after the error it will only show the "Blue Screen of Death".
    Since I cannot access my registry anymore, waht can I do?
  23. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

  24. barkway

    barkway TS Rookie

    didn't work for me

    I'm STILL getting autochk not found at bootup....and furthermore when I tried system restore, I got a message that THIS was corrupted (too).

  25. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Follow the instructions in the link provided by Mictlantecuhtli. That may sort your problem out for you.

    Regards Howard :wave: :wave:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...