autochk.exe not found

By bquery ยท 79 replies
Sep 17, 2003
  1. Bl4de

    Bl4de TS Rookie

    Chkdsk /r didn't help (though it fixed some problems on the HD, but not the problem I was having).

    I tried making a MSDOS boot disk in XP on another machine and it didn't work, I'm guessing the floppy was bad, after an hour or 2 I tried with another floppy and it worked, then ran PTEDIT on another floppy and got it all to work. Mine was set to 44 (which wasn't even in the PTEDIT list lol), changed it to 07 and now I'm on my PC. Thanks for the help everyone!

    Gonna be backing my info up then probably buying a new HDD, and a portable external.
  2. gummel

    gummel TS Rookie

    Thanks bbrass10 for your replies.

    I have read and applied your sugestions about the hidden partition, etc, but still the problem remains .

    My problem is that after the "autochk.exe program not found - skipping autochk" message, I get a blue screen with the following error:

    STOP: c000021a {Fatal System Error}
    The Windows Logon Process system process terminated unexpectedly with a status of 0xc000003a (0x00000000 0x0000000)
    The system has been shutdown.

    and then the system restarts.

    The computer do not start in any mode (safe mode, safe mode with networking, etc, etc).

    The computer is a Dell Latitude c640.

    I am looking forward to reboot the machine and save the data currently in there. If someone has any idea on how to resolve the problem I would appreciate.


  3. Chesta1485

    Chesta1485 TS Rookie Posts: 16

    Have you tried the chkdsk /r command in the winxp startup recovery prompt, it worked for me. Where are those programmers when you need them who know what the heck these numbered error codes are anyways. I wish it were as easy as editing some notepad file and changing a few values. If u have no luck with all ure options,...there is always that last one: reformat and save data, unfortunately to many times things come down to this. But if your computer is jacked up and you really don't wanna take the time to mess around with all the little fixs that seem to do nothing and you wanna start fresh, then reformat..whatelse..
  4. trauph

    trauph TS Rookie

    That was a lifesaver!

    I found this post via google and it was a lifesaver. I wouldn't have had a clue how to get around this problem save reformatting etc. Thanks a lot for the help!
  5. southbeachmach

    southbeachmach TS Rookie


    I booted up and ran ptedit.exe and the partition type was already set to 07... I've got the same problem computer just continuosly reboots after recieving the autochk message. Any other ideas?
  6. thefink

    thefink TS Rookie

    I had the same problem today. But I might have found something.
    I am reinstalling my computer with XP and to be sure I did this on a new primary partition. I used Partition Magic to switch (make active) between the partitions. At some point I decided to use Ghost 9 to restore an older image I had made and let Ghost make the partition active after imaging. This went fine and it booted to the new installation. So far so good...
    I then changed back to the old partition, using PM, and I was treated to the dreaded Autochk not found message. After trying some tips from this forum I saw that my new partition was visible and the old partition was hidden like it should. And like with some others here, checkdisk found errors but didn't solve my problem.
    I saw a mention of boot.ini on a website somewhere and thought it was worth looking into.

    With the browse function in Partition Magic I copied the boot.ini file from the hidden partition and changed the lines that look like this:
    [boot loader] default=scsi(0)disk(0)rdisk(0)partition(1)\winnt
    to this:
    [boot loader] default=scsi(0)disk(0)rdisk(0)partition(2)\winnt

    And that worked..... strangely enough, because I don't think it should.
    The first partition is hidden so the bootloader shouldn't see it and shouldn't start counting there. And it didn't the first few times that I switched partitions.
    It might have been caused when I used Ghost to activate the partition because it failed to hide the other one. So mayby now Windows remembers two active partitions and acts accordingly.

    I am sure that there is a perfectly logical explanation for this behavior, there usually is, but I don't know what it is.
    Anyway, it works, and I hope this of help to someone with the same problem. Just remind me to change the boot.ini back when I delete the old partition. :approve:
  7. download120

    download120 TS Rookie

    how to start ptedit.exe

    Hi, this problem has happend to my pc all of a sudden.

    I am trying to start ptedit.exe

    I run the startup disk (6 disk) then i got the c:/ prompt

    so i changed it to

    c:/ a:

    which changed the prompt to:


    so i typed


    It says unreconised command.

    Please tell me how to start the program.. i.e. what dos command do i need to start ptedit.exe

    and yes, ptedit.exe is the only thing in the flow disk.. hence a:/ptedit.exe is the location of the file.
  8. download120

    download120 TS Rookie

    Oky problem soloved no need to get any partition manger

    just download autochk.exe and then put it in a floppy..
    when it asks you for it give it the location of the floppy and it fixes the problem :D
  9. inxs

    inxs TS Rookie

    Win2K same message but boots OK

    I had the same "autochk not found - skipping autochk" message after initially installing Win2000 (SP2) then SP4 on a new harddrive, but Windows would continue on to the login screen and function normally.
    I basically copied the autochk.exe file from C:\WINDOWS\ServicePackFiles\i386 to C:\WINDOWS\System32 and the message disappeared.
  10. BillyChan

    BillyChan TS Rookie

    Very useful program to boot up my XP without any programming knowledge

    I had the same problem before didn't able to repair my C: drive using XP CD, and I didn't want to format my drive either. I received all kind of error message after accidently renamed all my drives' name and defraged my drives with errors and power outage (really bad luck).

    After 2 days (I mean really 48hrs) searching online trying all kinds of possible rescues. I finally got back most of my data (not all as I'm still trying now in day 2). And I really feel that people are so kind to share their expertise to help the others on this problem (especially those who made the program and let people use it for free, like PTedit.exe and TestDisk.exe, they should really get credits).

    I tried Norton Antivirus 05 rescue bootable disks and hope it would fix my drive somehow but no luck on that (or it did, but I just didn't notice, cuz still unbootable after that). Later I tried Partition Magic 8 resuce disk (you have to have PartitionMagic to make that resuce floppy) and once it loaded in DOC, it realized there's error in my boot drive and fixed the partition table. So I tried to reboot but still XP didn't bootup. But this time I was able to repair my XP using XP CD (repair XP I don't mean using "Automated Recovery Console" which is kinda technical, even I did try some comment like fixboot, fixmbr. Luckily I didn't erase all my data in my drive. I suggest try this at last after you have tried all I said in this message) I mean using XP CD to boot and don't hit "R" for repair, instead hit "Enter" to install XP, go to lincese agreement page, press F8, then you MIGHT have the option to "repair previous version of Windows" or "just F3 to quit". If you don't see the repair option, try to use TestDisk.exe, which I mention above, or PTedit.exe (which is downloadable for free and included in Nortion Antivirus Resuce Disk and PartitionMagic 8 resuce disk)to modifiy the PartitionTable, change the "Type" to 07 (which means unhide NTFS, You can find your TYPE using "set type" button in PTedit if you use other format instead of NTFS).

    After that I was able to boot to Windows XP but my other 3 drives are gone. After this I found the TestDisk.exe (I wish I found this before, it might have fixed everything in the first place) and it fixed two of my drives. I give up on the third one since there's only some songs in that drive. Only problem is some of my programs don't run anymore and I think I have to reinstall them. But I think a better way is to format all my drive and reinstall everything again after I save the data that I need.

    Hope this will help you. :angel:
  11. sheraz

    sheraz TS Rookie

    i hanve also this problem..

    autockack not (autochk.exe ) not in my Windows Xp becoz when i instal it the autochk.exe where not in the CD there for in is not instaled.
    Where i can download it ??????????
  12. Koyuki-kun

    Koyuki-kun TS Rookie

    like a lot of other ppl im having the same problem

    ive read everything said here more than once and im trying to use the ptedit.exe but somehow i cant get it to run.

    ive downloaded it, put it om my USB stick and im trying to run it but i get the error ''unknown action'' or whatever.
    ive also copied it to the HD but it still wont work.
    also ive tried to copy autochk.exe in the right folder, but it says that i do not have permission or that something went wrong....
    if i copy it into the windows map(only place i can get in btw) then i have no problems.

    this is very strange. i can not permit to format the HD cuz i have a 600 euro program on it with a contract that does not permit me to delete it (yea sounds really serieus doesnt it)

    i can not change folder maps so i can get the data from that HD and i do not have an other computer where i can put it in so the only option left is to fix this.

    do you guys got any idea to run the ptedit.exe?? or place the file in the right map? thx
  13. mick662

    mick662 TS Rookie

    I hope someone reads this.

    I notice that this thread is kinda old, but I just had this problem. I used ptedit to change the partition type and I can get WinXP to start now. The problem is, all of the other partitions on the drive are gone (hidden, I assume). It's a 300GB disk and the first partition that holds WinXP is only 50 GB. Originally I changed the partition type to 0x0c and then read this thread and tried changing it to 0x07 but to no avail. Partition Magic 8 shows the drive as 300GB, but shows it as one 50GB partition (c:). Any help would be greatly appreciated. The drive is well over half full and I'd really hate to have to do the dreaded format and reinstall, but I'm quickly running out of options. TIA.
  14. Koyuki-kun

    Koyuki-kun TS Rookie

    today i got my pc back from local store that has great service and fixed it very fast.

    the problem was that the partions were all gone.
    the computer could only see 1 big partion (the entire HD) and that one was also unknown for some reason.
    now that store used a program to look for all possible partions that exist and restore them or something.
    what program that was? i dont remember anymore but you DONT have to format the entire HD for sure.
    ill ask them again for more details. but the ptedit didnt work for me and wasnt needed
  15. mick662

    mick662 TS Rookie

    Thanks for the reply. I hope you can find out the name of the program. Maybe it will work for mine, too. Thanks again.
  16. victor_st

    victor_st TS Rookie

    a quick fix

    If you've got the message "...autochk.exe not found" during the WinXP boot and (after a few seconds of pausing) the boot process has finished properly, there is an easy way to solve the problem:
    1. WinKey + r
    2. type "regedit" + OK (without quotations, :))
    3. go to the following key: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

    Here, you're most likely missing an entry called "BootExecute", so, right click wherever on blank area of the "Registry Editor" window and choose New + Multi-String Value. Then select the new entry, right-click and choose "Modify", type "autocheck autochk *" in the Edit Multi-String diag. win.

    That's all. Reboot and the message has disappeared, hasn't it?
  17. mick662

    mick662 TS Rookie

    Thanks for the suggestions. I got it fixed using Test Disk that was mentioned in an earlier thread. I used it to fix the MBR and when I rebooted, it still wouldn't start. The partition type had been changed to a Norton GoBack partition (44, i think). So I had to change the partition type in the partition table back to a Win32 type (0c). Now everything is back to normal. Needless to say, I uninstalled Norton SystemWorks 06 and I'm pretty much done with Symantec products forever! Thanks Again.
  18. Newbie:)

    Newbie:) TS Rookie

    Can't locate HotFix KB824105

    I have the same problem where I can't the can't find autocheck error. But then it says skipping autocheck and everything seems to boot up fine. It only seems like an annoyance and slows down my reboot time but I would still like to get rid of it. It all started when I picked up some sort of browser hijacker. After most google searches in IE, when I click on a search result link it will take me to ebay. For instance when I did on a google search on the autocheck error, it would bring me to different items on ebay related to checks. Weird. So I used Norton and some other programs to try to get rid of it and ended up deleting everything it couldn't identify that I also didn't recognize. When I rebooted, It did NOT get rid of the browser hijack but did give me this autocheck problem.

    Anyway, I downloaded firefox and accessed this page. I don't know what half the stuff you guys are talking about means, but deleting the hotfix sounds like the easiest way to fix my autocheck problem. Only problem is when I go to add/remove programs, this particular hotfix isn't listed with the others. Any other ideas where I can find it or if I don't have it, how else I can fix this? Thanks!
  19. BigApe

    BigApe TS Rookie

    Recognition of a Fix

    Sorry about opening this thread again, but it has been a tremendous help.

    I was having the same problem. I'm running WinXP SP2 with no partitions on my hard dive. XP is my only OS. I have had no new additions in hardware. The only changes in my system was a failed external network. That seems to up and working again.

    My fix was to run chkdsk /f. After it ran on the next reboot, I stopped getting the "skipping autocheck" error.

    Just thought I would share. And, thanks for the advise.


    PS: I do not have that MS Hotfix on my computer!
  20. iddqd

    iddqd TS Rookie

    I've had the same problem as this one on my ASUS z70va laptop (WinXP SP2):
    Exactly the same. I tried running Partition Magic, but the Partition Code was correct (07, NTFS). After that, I booted from an WinXP install CD and ran the recovery console, where I did the following command:
    C:/WINDOWS/ chkdsk /f
    It took a while to do something (and it said it fixed something afterwards), so I rebooted it, but the problem didn't go away. In fact, it got even worse. Now when I try to boot WinXP in any mode, it BSODs almost instantly. The only solution so far was unfortunately, to reinstall the OS. In future, I will simply avoid installing that stupid hotfix.

    Oh, and just for the record, my laptop is indeed capable of network booting. It was like the 4th boot priority. I disabled it since then.
  21. jeff1244

    jeff1244 TS Rookie

    Autochck.exe error

    Dear Brian,

    Your autochk.exe MAY BE mistakenly placed in yoiur \1386 Folder or elsewhere. Do a Start > search > "for files and folders" > "all files and folders" and enter autochk.exe. When you find it, COPY it and place it in your Windows\System32 folder. Then Run Chkdsk. This will probably correct the error. Of course, double-click "My Computer" icon, RIGHT-click on drive C: and choose "Properties" then "Tools", then "Check now" and place a check in each box. You will be asked if you want to check for errors the next time you boot. Click yes. and Reboot. You STILL may have some bad sectors on your hard drive.

  22. BKCH

    BKCH TS Rookie

    Hi - I have a strange one - I get the "autochk not found - skipping autocheck" message only when I try and boot my XP PRO system without a keyboard and mouse.

    The goal for this PC is to be a NAS so I need it to book without a keyboard and mouse.

    I'm not keen to try the PTEDIT method suggested in this thread becuase I don't have the problem when the keyboard / mouse are connected (so I wouldn't have thought it was to do with hidden partitions).

    Any input would be really apprecaited.
  23. flyboy

    flyboy TS Rookie

    I have the "autocheck not found. skipping AUTOCHK" appearing on my laptop but unfortunately it doesn't have a floppy disk drive. How if at all do I get into DOS to coorect the hidden NTFS volume?

    PM8 is definately the culprate here. I just extended a drive and then next time it came on it didn't want to know and just kept rebooting over and over again.

    Sounds like a tough one to fix please please help.....
  24. Peddant

    Peddant TS Rookie Posts: 1,446

    If your laptop will boot to the CD drive,put the PM8 CD in it and see if you can unhide the partiton with that.

    There is also an interesting tool HERE One of the things it claims to do is "Unhide partitions".

    It`s in a zip file.When you have unzipped it look for the .ISO file.

    You have to burn that to a CD.Open your burning program and select burn .ISO from the file or tools menu.
  25. fullcircle

    fullcircle TS Rookie

    Here is a solution that worked for me.

    Originally Windows would load, then I'd get an error message saying "autochk not found", and a second or two later I'd see a blue screen of death and I'd have to restart the computer. When I checked the partition it was not hidden, so that wasn't the problem.

    Then I ran chkdsk /f but still when I started the computer, I'd have the same problem as before.

    BUT THEN when Windows was loading, I hit F8 and selected the option that says "Last Known Good Configuration".

    And hey presto, problem solved! Hope this solution works for others too, because I was pulling my hair out after trying everything I could think of.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...