autochk.exe not found

Not open for further replies.
I ran into this today, but my case was a bit different.

I got into the recovery console, found out that auotchk.exe was in fact missing. I replaced it, but it just meant that it got to rebooting even quicker (just before the Windows login prompt would display in the classic style).

Turns out my partitions got misordered. C: (windows boot) became D:, D: (programs) became E:, E: (just plain ol' disk space) became F: and F: (5GB swap file) became C:.

I don't have Partition Magic, so I got to running ptedit.exe, the drive types were 06, 07, 07 and 0F, but I also don't know which partition is which, aside from the fact that 06 has a boot record so it's the old C:, now D:.

Things are worse now, after running ptedit, the now D: and F: partitions are listed as [Type Unknown] in the recovery console using diskpart, and appropriately, the PC doesn't boot at all now, having no MBR. Checking back in ptedit, everything seems to be the same as it has always been.

So my 2 questions:
- Would mislabelled drives be cause enough for the machine to restart when Windows attempted to boot?
- Can Partition Magic solve my current problem?
Here's the printout from running partinfo... It doesn't look so good.

I know that the files on the drives themselves are good, but... any help?

update - It would appear that my original problem was the relabeling of the drive letters. Running ptedit destroyed my partition tables. I just need to be able to go back in time...

update - How Windows reports my partitions using diskpart:

131072 MB Disk 0 at Id 0 on bus 0 on atapi [MBR]

C: Partition1 (Swap) [NTFS] 5120 MB ( 5191 MB free)
F: Partition2 [Unknown] 151213 MB (151212 MB free)

131072 MB Disk 0 at Id 0 on bus 0 on atapi [MBR]

D: Partition1 [Unknown] 5120 MB ( 5120 MB free)
E: Partition2 (Programs) [NTFS] 151213 MB ( 124606 MB free )

The disk sizes appear too small, but partitions C and E are both enumerable and partitioned correctly. The BIOS reports the drives as 163GB.

update - Playing with DiskPatch to see if it gives some useful results
Just Thanks

Hi people,

I subscrived just to give you all my thanks, I too had the autochk.exe problem. And I swiched my c: HDD from 44 to 07 and it worked fine, afterwords I had to do the same with my other 2 HDD and change the boot sequence from 80 to 00.

Anyway, after reading your coments on this topic (on my labtop), I was able to save my computer. It was just perfect, thank you all very, very much.
BigApe said:
Sorry about opening this thread again, but it has been a tremendous help.

I was having the same problem. I'm running WinXP SP2 with no partitions on my hard dive. XP is my only OS. I have had no new additions in hardware. The only changes in my system was a failed external network. That seems to up and working again.

My fix was to run chkdsk /f. After it ran on the next reboot, I stopped getting the "skipping autocheck" error.

Just thought I would share. And, thanks for the advise.


PS: I do not have that MS Hotfix on my computer!

There is no Windows XP HotFix: KB824105 in my add/remove programs as well. Any idea why is that? I have the same problem.
I,m also getting the same "auto check not found" message, i'am not a technical person so some of the help surgested is a bit hard for me to understand, what would happen if i just reloaded XP.
Same Problem as this poster...

JohnnyBlaze said:
I believe I might have the same problem as Trevor. I'm running a Toshiba Satellite notebook and it's been loaded with a Windows XP OEM CD. During boot-up I get the dreaded blue screen of death showing an UNMOUNTABLE_BOOT_VOLUME error. I've downloaded the 6-disk XP boot disk set and managed to run the recovery console, but when I use the "chkdsk /r" command the RC is unable to find the "autochk.exe" file. I also ran PTedit as Brad and found that my NTFS file system is type 0x07 and therefore not hidden. Im just about ready to mount my boot in this thing :unch: , but before I do that, any suggestions??


Has anyone been able to find a resolution to this problem? I've got the same problem, but I have no idea why is would happen... I have not tried PTedit, but have not heard anyone say it solved their problem...

Any help would be greatly appreciated!

Here's one for you guys that puzzles me thus far.

I've been given the task of fixing a family friend's computer, and, as with the rest of my lost colleagues, I received this doom-saying statement about autochk.exe not being found.

Now, I read most of the posts and determined to try the ptedit.exe path.

However. Every time I make it into the program, I receive an error.

The MBR could not be loaded from this sector.

Or something to that extent. Now, I was wondering, and will review this forum, what causes this to happen? How can I make it not happen so that I can even be able to check if the partition is hidden or not? For, at this time, all the fields are filled with 0 or 00.


Is there a different approach to take to fixing this issue?

Many thanks in advance guys.
Hi guys! I'm new to this forum and this is my very first post. I found you guys just because I experienced the same problem, autocheck not found. I have not tried all these suggestions yet, I will try later on.

Bye for now!
Alright, I have the same endless reboot issue.

Did windows recovery from the CD, ran chkdsk.exe /r it apparently fixed some problem. Also prior to that copied a new copy of the autochk.exe file to my windows directory. Neither did anything.

So I was about to do that ptedit thing, and then realized that my buddies laptop has no floppy drive. What the hell do I do now? I am pretty sure it is a partition issue.

This started after I was running smitfraud.exe in safemode to kill the SpyLocked spyware program for him. It had an error and froze. I waited and waited, nothing happened so I just held down the power button. Restarted after a few minutes and have had the endless reboot cycle ever since. Anyone have any ideas? or should I just give the computer back to him and tell him he is on his own?

Thanks in advance for your help.

My situation is just like yours - I started getting this error after the program to remove the Spylocked malware crashed on me. It doesn't seem to be a partition issue with my machine though. I tried out ptedit and the partition is still labeled as NTFS (non-hidden). I went so far as to do a repair install of Windows, but that didn't help either.

I'm just about at the point where I'm going to try to attach the HD to another machine and try to salvage what I can from it and do a clean re-install.

Have you had any luck yet?
autochk.exe help please

My computer won't start at all. It begins to start with the window logo then goes to the blue sceen that says "autochk.exe not found skipping Auto Check. Then it won't start up it just keeps trying to reboot. I am also having a problem with a start up error message saying that "Primary Slave Drive Fails" I have the option to press F2 to bypass and I have been doing that and it has worked fine not any more.

So my question is my cd drive or my second hard drive my primary slave drive and what do I do about the autochk.exe with out being able to boot up.
Hey Guys! I fixed the problem. In my case, it is the problem with Norton Goback.
When I disabled completely Norton Goback and restarted my PC, everything is just fine.

Why Norton Goback cause the problem is beyond my knowledge. You may try this way if you have Norton Goback installed. Make sure you disable Norton Goback completely, i.e. you will see pop up information that Goback file will be deleted.

Hopefully this helps!
after using smitfraudfix
to remove a trojen

and all of a sudden it could not complete the cleaning and i had to rebot the computer by hand

now i get the autochk programe not found

i tired the

reapir windows
i used all the boot options in dos

i i instaled widows on my drive d
and i can get on the computer but cant get in the system32 folder for the first windows
becouse my first widows was set to were only the admistreator could acces the files

i tried pasting a new autochk file in system32 folder but its allready their

ok i got found a way in

if u have ur hard drive split like me or have 2 hard drivers ur in luck

1. reinstall winows xp or what ever u have on the other drive
2. from thier u can replace the autochk and chkdsk in the system32 folder in windows on drive c
.copy the new files from the new winowos u installd..delet the old files and past the new ones in


if u cant can in and wont give u permision
acces denide pop up
check this

1. boot into safe mode on the new windows u just installd and login as adinistrator

2 right click the folder system32 folder in winows on the c drive
3 hit properties
4 click on sucurty tap at the top of the pop up
it will say u dont have permision or somthing but will still bring up the pop up

5 click advance
6 click the tap called owner
7 chose the administrators for the new windows the one ure using right now
8 click ok on all the taps
9 right click folder and hit propertys another time
10 hit securty...this time that warrning wont pop up
11 ull see a butting called add
12 hit it and type the ur compurter name u gave for the new winows
13 also type administrator so u can open it from their
14 alow those names to do what ever they want to the files
15 hit ok

now click the folder u should beable to get in it

16 now u have to do the same procces u did for the folder for the files u want to delet
witch is chkdsk.exe and autochk.exe
delet and copy and past the new winows files

and thier u have it

if u can still get it to work

do what i did

go to all the folders and files and change the properties as u did in the steps i listed above

u can highlight all files at one time and change the permisions
but u cant do that with folders ath the same time

same go's for the folders u can hight light all the folders and change the propertys one one shot but u cant do it with the files

also get ur self a external hard drive so u can copy and past all the files u want to save to it

after ur done u can wipe ur hard drive and start from scratch

hit this up tell me if this works and show ur thanks

this took me hours to find out
..and im not a computer geek or nothing like that i barly know my way aroung the damn thing

sorry if it aint that clear and for the spelling



Posts: 40   +0
try 100pr00f suggestion...

i have try 100pr00f guide.... (even though it hard for me to understand :stickout:)
but it seems have resolve my problem.... and now my pc is fine again :D

for those who dont want to formating their harddisk then you should try it.

THANK YOU 100pr00f
Hello, I'm having a slight variation on this problem:

I cannot finish booting into windows. No error. When trying to run chkdsk i get autochk.exe not found.

Drive A = 80GB SATA connected to mobo. Win2003.
Drive B = 40GB IDE connected to mobo. Fedora7

I was messing around with the boot.ini on the windows drive, experimenting with bootup procedures. I added additional boot menu options trying to address different controllers/drives. I do not remember altering the primary entry in boot.ini. I rebooted windows and the problem began:

It loads fine to the multi-boot selection. I select the win2003 partition (which worked before reboot) and i see the white status bars fill up at the bottom of my screen as if its booting into win. At that point it REBOOTS. rinse repeat.

I checked my drive with ptedit and found both partitions were 07. When i got to the recovery console i copied chkdsk to another floppy, ran it and got the error everyone is talking about: autochk.exe not found. It asks me to specify a path. ??

If i boot from a win98 floppy, i cannot see any of my HDD's at the command prompt. If i boot from win2003 CD, i can see my C: drive fine. I tried copying boot.ini at the recovery console but any file i try to copy from C, i get an errer simply stating that the file is not found. This is strange because i can DIR and see the drive contents...

I have a good feeling that if i can get at the boot.ini it may be the issue.. but how?

Any thoughts?
When i tried installing windows over it it found 2 paritions - 30GB C drive, and the other was a - (a dash instead of a drive letter) and pertition type unknown. What i didn't mention above is that i tried FIXMBR FIXBOOT or whatnot in the recovery console, which forced me to do a chkdsk, which i can't do due to the error we're all talking about - autochk.exe not found..
My father is also having the same problem. His norton subscription was up so i ran the removenorton tool from and after reboot, the autochk.exe not found error pops up and reboots. Ive been reading these forums and ran the ptedit utility from page 1 and edited the partition table "type" to 07 to make the NTFS volume unhidden. (table After making that mistake, i get an error saying that norton goback (STILL on the computer somehow) cant find the partition and it auto-reboots yet again. Now when i go back into the winME dos boot disk, i cant change directories to even run the tool again to change it back.

I have run the chkdisk /r tool through windows recovery and it said there was problems and it fixed them. ALSO i took his hdd out of his tower and attached it to my computer through usb. I can see his volume through disk manager but cannot explore it. (thats why i thought it was a hidden ntfs volume).

Any help or additional advice would be greatly appreciated.
Solution --Fixed it myself.

when resizing partition using Ubuntu Linux,
I had it installed on virtual

I got operating system not found error.. even though I resized using free space... so thats the last time I do that ...

one I did resize, it said OPERATING SYSTEM NOT FOUND

SAFE MODE, last known good configuration and other stuff will not work..

1.I BOOTED FROM XP CD, ensuring cd was a boot device.. (on dell inspiron 6400 you press f12 and then select cd-rom from the device list)
2. see if Repair Installation is available
if yes.. do a repair installation I guess...
if no... restart machine, boot from XP cd again, then
go to RECOVERY CONSOLE (press r when prompted)

3. in recovery console it should fix c: and say unreadable perhaps... when you try dir ..

it will say ONLY do this if you can't boot, which should be the case.

could not load autochk.exe
now you shoudl be able to see the windows loading screen.
The problem is a HIDDEN partition.
when windows loads it will say
could not load autochk.exe

Now I have a LAPTOP with no floppy drive, and I wasted a good at least 10 CDs trying to get the thing to boot, and fix what I needed.

Basically you need any tool that can create a bootable CD(for laptops ..) allowing you to hide or unhide partitions
i.e. changing the partition type number.


I am not sure if the trial can burn to a cd, but the professional version can, and then you boot from this CD, and follow the instructions at
which basically involve changing the partition to NTFS type(assuming it was NTFS originally I guess..)
if you tried to install Ubuntu Linux the number will be some Linux number like 0x17... so change to 0x07
(right click hard drive and click advanced... after booting from that cd..)

Alternate Solution: get a bootable floppy with ptedit and boot from it

The number here should generally be 07 (hex), meaning the partition is an "Installable File System", in other words a bootable drive. If its anything else its not bootable.

Using your tab key, tab down to the Type box and hold down ALT + T to open the Set Type menu, then with your keyboard arrow, select 07, tab down to Ok and press Enter

8) Hold down ALT + S to Save Changes to the partition table and then Press CTRL +C to exit out of the program.

the problem is if the number is not 07... it is a hidden partition.
Simple FIX

Don't know if it will work for everyone but it did for me and it will for most using Norton GoBack program.

After you install or unistall GoBack (included with Norton System Works), and attempt to start your computer, you may receive an error message similar to the following:
C000021a (fatal system error).
The session manager initialization system process terminated unexpectedly with a status of 0xc000003a (0x00000000, 0x00000000)

This error can occur when you have GoBack installed on your computer and it is present in the boot sector.

To resolve this issue, disable GoBack, and then uninstall GoBack. To do this, follow these steps.

NOTE: You cannot uninstall GoBack in Safe mode.

1. Restart your computer.
2. During the startup process, press SPACE to access GoBack's menu options.
3. When prompted, enter the option for Disable GoBack, and then allow the computer to complete the startup process.

Up until this step it should be fix and your computer should be able to load windows, after this if you want to continue with unistall follow next steps:

4. Click Start, and then click Control Panel.
5. In Control Panel, double-click Add or Remove Programs.
6. In the list of installed programs, click GoBack, and then click Remove.
7. Follow the on-screen instructions to complete the uninstall process.
If you want to continue to use GoBack, or if you need help removing or disabling GoBack, contact Symantec. Alternatively, visit the following Symantec Web site for support and information about recent upgrades that are compatible with Windows XP:

Hope this helps.
I Solved Problem Of Autochk not found...

After I uninstall Norton GoBack unsuccessfully. I got the "Autochk Not Found..." text on my screen and my pc rebooted and shut on and off like that for ever. It took me a day and I finally got the bastar. I solved this autochk not found issues
Turn off and on the power button by hand and press keys: Ctrl+Alt in two finger and repeatedly hit the G key (if it's not working try again by press them three the same time down).

You will see the screen goes through some texts and codes. And look at the bottom it say to hold down the F key to uninstall Goback.

I held the F key for a while and let it go.

Turn the power button off by hand and back on again.( try this method a couple of times) Voila. I solved the problem. Windows start as normal.

If that doesn't work then try this link
Good Luck


autochk not found bug

Create the following file using notepad and name it autochk.reg:


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]

Save it as "all files" in notepad. Click on the reg file you have saved and it should work after a reboot. Partition Magic or a similar tool was the culprit in my own case
Not open for further replies.