Bad pool caller and system32\config\system error

By bhashous ยท 7 replies
Aug 12, 2008
  1. Hello,

    I currently have an issue with my PC, a Dell Dimension 4600. I am unable to load up WinXP. I have been putting in countless hours of research and inquiries into this problem. I have found others who have written about similar situations on various forums, but have yet to come across a solution. So, here it goes:

    As previously mentioned I own a Dell Dimension 4600 (I know, get a new computer right?).

    Windows XP Home Edition. Intel Pentium 4 Processor: 2.8
    Level 2 cache: 1 MB Integrated
    BIOS version: A09

    Power on the computer and it briefly loads before showing me a black screen with white lettering that states:

    Windows could not start because the following file is missing
    or corrupt:

    Try to load from every option from the "Windows Advanced Options Menu" (ie. Safe Mode, etc.) and none of the options changes the outcome.

    Ok. So, I go into setup and change the boot sequence to load the WinXP Reinstallation CD. It does it's thing, loads up and brings me to the "Windows XP Home Edition Setup" screen. I have 3 options (as I'm sure whoever is reading this already knows); (1) set up WinXP now, press ENTER; (2) repair using Recover Console, press R, (3) quit setup.

    Now, going through the process of either option 1 or 2 results in the same error message screen or BSOD. Option 1, I get the BSOD after pressing F8 for the licensing agreement and option 2 I get the BSOD after selecting "1: C:\WINDOWS."

    The specific BSOD is: BAD_POOL_CALLER
    0x000000c2 (0x00000043, 0xc217c00, 0x00000000, 0x0000000)

    There hasn't been anything installed on the computer for awhile. I'm not too concerned with what caused the problem as I am how to fix it. At this point I can't even use the disc to reinstall windows. I can't do anything. I've ran all the tests provided from the "IDE Drive Diagnostics" option, all have tested good.

    Any and all help would greatly be appreciated, I am at a loss for what my next step should be in fixing this problem. My apologies for the book that I've written, I just seen way too many posts on various forums with incomplete/useless information. Thank you.
  2. woody1191

    woody1191 TS Rookie Posts: 572

    It is good you have written this, its hard when we don't get any Information, you've told people on here everything they need to know :).

    The 0xC2 errors are caused by either Faulty Drivers Or Buggy Software, since it seems you can't access the OS try running Memtest86 to test your RAM.

    Memtest86 Instructions
    Download the pre-built version of Memtest86 (Link Below) and burn it onto a CD using ISO Recorder (Link Below) other ISO burning software will work as well (E.g. Nero). After this boot off the CD and start the test going and let it run for 3-5 hours (Minimum of 7 Passes) or Overnight which is best.

    Memtest86 -
    ISO Recorder -

    Here are a few links that may help with your problem as well, but quite a lot aren't finished but they do include steps you could take to fix the problem. You could continue searching through Google for these if you want, just type in the Bugcheck Code and First Parameter like this but without the outside brackets ("0x000000c2 (0x00000043") pool caller 0x000000c2.php
  3. bhashous

    bhashous TS Rookie Topic Starter

    thank you for your time, I will look into these steps and report back to the thread.
  4. bhashous

    bhashous TS Rookie Topic Starter

    still goin

    From another forum, I was given a series of checks to do...this is what I've been able to do thus far:

    Ran Memtest86 for 6 hours, no errors.

    I was able to get the diagnostics for the hard drive cd that I created to work, it didn't find any errors.

    I tried resetting the BIOS, removed the battery for 15 change.

    I disconnected all added hardware, ie. cd/dvd/floppy drives. No change.

    Please let me know if there is anything else that I can do, thank you for your time.
  5. woody1191

    woody1191 TS Rookie Posts: 572

    You could try testing your CPU as unlikely as it may seem. Run Prime95 on all 3 tests and report any errors it may find, you need to run each test for about 15 mins and if it finds any errors it may force the test to end.

    Prime95 -
  6. nickc

    nickc TechSpot Paladin Posts: 923   +11

    u really need to run Prime95 over night to test things right, nothing can be tested right in 15 mins. anything can pass that long if it is not overclocked way out of proportion.
  7. woody1191

    woody1191 TS Rookie Posts: 572

    I only say 15mins for a reason because Prime95 will find errors in minutes it doesn't take hours and if it does find errors it will shut the program down.

    Although Prime95 wasn't designed for Hardware testing, it is 1 of the most Intolerant for errors in Hardware, he could run it all night but I think he would be wasting his time unless he was testing a Overclocked system which he isn't. 1 hour at most is enough, but anything around 15-30 mins I've found is enough for testing the CPU and RAM for faults.

    It sometimes causes the system to Freeze or Crash during testing and then obviously points to 1 of the 2 Pieces of Hardware it tests.
  8. jobeard

    jobeard TS Ambassador Posts: 11,122   +982

    Typically the Bad-pool stuff is from a bad i/o; ether bad data was recorded or good data was not correctly read.

    Memory had the HD are the prime suspects. Find the issue and get that solved.

    As for \WINDOWS\SYSTEM32\CONFIG\SYSTEM corruption ---
    gulp; that's one of the system registry files and can be recovered.

    If the HD is replaced, you've got a lot more than that to deal with.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...