Bios corrupt, no post to bios, msi z170a gaming pro board

By Mothyle ยท 5 replies
May 21, 2016
Post New Reply
  1. I have a msi z170a gaming pro motherboard with the new lga1151 socket.

    Ok here's my issue, during a Windows 10 update my screen went black and I can't get anywhere when j turn the computer on. I repaired Windows on the hard drive on another computer but it makes no difference because all that happens is the fans turn on and led lights and whatnot but I don't hear the beep after turning the computer on, I get nothing on the monitor and not only that but it seems only some of the USB ports work and the ps2 works of course(keyboard lights up) and I can get the mouse to light up on USB.

    I have exhausted all troubleshooting measure and can conclude with 99% certainty it is a bios issue.

    Here's my main question. These msi boards have 3 lights to help determine hardware issues. One light for cpu, ram, and vga. My cpu light comes on when I turn on the computer but no light for ram or vga. Ram works on a lga1151 micro atx board so it is known to be working. I bought new ram and it still doesn't give me a light on for ram. I've tried cmos reset a variety of times and ways. I've tried putting the ram in all sorts of ways, I've tried other monitors , using graphics cards, all the ports associated with video.

    My question is if there's no way for my ram light to come on, is that requires to flash bios even if I'm able to somehow manage it with the monitor off(I've read of others pulling it off but I'm unable to confirm if they had the lack of a "ok" on the ram ability to be utilized.

    If this light is off is there any way to fix the corrupt bios despite it, and if so what is my next course of action? Replacing bios chip, flashing it, hot flashing it, or should I do another method?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Many newer motherboards have dual bios. You don't need to flash the bios, just reset the bios
  3. Mothyle

    Mothyle TS Rookie Topic Starter

    This particular board does not have dual bios so I can't just reset it, I already checked. There are boards that look almost identical to this one and do have dual bios, but mine does not.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    There is no CMOS jumper on the board where you can short out the pins momentarily and try booting?
  5. Mothyle

    Mothyle TS Rookie Topic Starter

    Yes there is cmos jumper, but that does not mean it has dual bios, it just means it has the ability to reset cmos to default settings. Bios and cmos are not interchangeable words that mean the same thing. I have tried to short it many times, or even remove the battery for 24 hours in addition to holding the power button to drain all the capacitors, but it has not changed the boards ability to boot.
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I know the CMOS jumper doesn't mean dual bios, I was asking if you knew if there was a jumper to reset the bios. My motherboard has dual bios and a button you push to reset the main bios. You can do this while the system is on... Really sounds like your motherboard is toast, and that failing after a Windows Update was just a coincidence...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...