BIOS freezes at "verifying DMI pool data" - probably HDD issue

Not open for further replies.
Hi, I have the following problem on the new box I just build (specs below): after bios init, it freezes at "verifying DMI Pool data". This is on a new box, unformated HD.

Things I have checked/tried:
- When I unplug the HD, it does not freeze and I can succesfully boot on a CD to run memtest.
- Removed HD and tested the sata connectors on the motherboard with the CD/DVD burner: all OK.
- Tested the sata cable by exchange it with the one of the CD/DVD burner: OK.
- SATA settings in the bios are set to Native IDE
- Boot order is 1)Floopy 2)CD/DVD 3) HD

As this drive should suport hot plugging I tried to unplug it and boot on my Windows XP install cd, then plug it back in. The HD seems to have been recognized, and I formated a partition. The instalation copied some files on it, and then restarted. But I am again stuck at the same point after that.
If I redo the same operation the windows instalation recognizes that a partition has been created and formated, so it has writen somthing on the drive.

Any idea of what I can do?

Thanks in advance.

Motherboard: GIGABYTE GA-MA74GM-S2H AM2+/AM2 AMD 740G HDMI Micro ATX AMD Motherboard
CPU: AMD Athlon 64 X2 5200+ Brisbane 2.7GHz Socket AM2 65W Dual-Core Processor Model ADO5200DOBOX
RAM: G.SKILL 2GB 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Desktop Memory Model F2-6400CL5S-2GBPQ
HD: Western Digital Caviar SE16 WD5000AAKS 500GB 7200 RPM SATA 3.0Gb/s Hard Drive
CD/DVD: Pioneer 20X DVD±R DVD Burner Beige SATA Model DVR-216D


Posts: 610   +4
It seems like something in the BIOS doesn't like your drive. I'm not sure if making your SATA settings Native IDE causes any issue with hot swapping. I guess not if you managed to get Windows to recognize the drive.

The weird part here is that Windows Setup isn't supposed to recognize anything that isn't there to the BIOS. Is there by any chance another HDD you can try with that particular SATA cable and port?
No, I can't test this drive on an other computer. My old box is IDE only.

But I did check that the motherboard recognizes the SATA dvd burner on all the ports, and with both cable.
Not open for further replies.