Bios update, odd thing

By nobardin ยท 8 replies
Dec 7, 2009
  1. Hello everyone,

    I apologize if this is posted in the wrong section. I am really hoping someone can help me figure this puzzle out. I was updating my laptop's drivers and such through the dell support site, when I came across a bios update. Usually I say nope, it's working fine. However, today I was ignorant and did the bios update.

    Here is where it gets odd..the bios update did its checks and then flashed the bios..the computer restarts and beeps at me 1 long 2 short..beep code for no video device or something of that nature and has a black screen..So, I let the laptop set for a min or 2 and thought i'll try to type in my password, because I saw a lot of hard drive my surprise I hear the XP startup music..So, the laptop is still working, it just doesn't display video on the LCD or an external monitor...

    Now for the question: Is there a way to downgrade the bios to an earlier version with a cd or dvd and a batch file with an autorun file? So, in effect "Put the cd in, and it loads and does everything on its own, presses okay if need be etc etc"

    I have a very basic understanding of batch files/dos commands. Any and all help would be appreciated. Even if it's another idea. Thank you in advance.

    Specs: Dell Inspiron 1501 laptop
    Amd Athlonx2 64 1.8GHz
    2 Gigs OCZ pc 5400 ram (if I am not mistaken) DDR2 laptop memory
    dvd rom/cdrw drive
    120 gig hard drive
    Windows XP Pro.
  2. pcaceit

    pcaceit TS Rookie Posts: 315

    Best contact Dell support.

    If there's Hard Disk activity! i would leave it for up to 15 mins.
    Dell have their own software that runs at startup and it might just be reconfiguring the system to run correctly with the new Bios.
    Windows might also need time to reconfigure.
  3. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Also try:
    • Disconnecting any externals (including network)
    • Removing the laptop main large battery
    • Removing the power adapter cord
    • Re-seating the Ram (or even just leaving 1 Ram card in only, for the moment)
    • Re-seating the Hard Drive
    • Then with all power out still. Hold down the ON button for 20secs
    • Plug the powered, power cord back in
    • Turn On
    Did it work? If so, then turn back off (or shutdown if Windows loaded)
    And refit the extra Ram card (if removed) and refit the main battery
    Turn back on again, and you're good to go.

    I don't think you need to downgrade or anything, but you can contact Dell HERE, and ask if there are any issues with the new Bios update.
  4. nobardin

    nobardin TS Rookie Topic Starter Posts: 256

    tried the suggestions

    did everything you said, even called dell..only to be told..your warranty is up, which I knew. However, to make matters worse I was told.."It's not our fault if you used our free public support page and did something wrong...Transfering you to our complaint department...

    So, now I guess it is back to square there a way to downgrade the bios or restore the old backup it made before flashing? It saved the backup to my desktop. I have looked and can't find any thing, but then again i'm not exactly in the best frame of mind at the moment.

    Thanks again for your assistance. I await your reply. If you need any more info feel free to ask.


    Well, I made a batch file to copy an earlier bios file from a cd to the C drive. I then opened up a dos cmd window and typed in cd C:\ then typed the name of the file..there was hard drive activity for a bit and then it restarted, but no change..still no video and it gives me 1 long beep and 2 short ones. That code means video device not detected....I guess maybe the intergrated graphics went...If it were a borked bios flash I wouldn't be able to get into windows would I?

    Or maybe, the intergrated graphics got turned off in the bios somehow...maybe if I took the CMOS battery out..
    My only problem with doing that is..I wouldn't be able to see to reset things if it didn't work...I may be able to blindly get a remote assistance connection going with the laptop...Not sure. What do you all think?

    *Edit 2*
    Well, I went ahead and connected remotely to the laptop..that was fun, not being able to see what I was doing..yay for alt functions...anywho..I go into the device manager and it says for my video card..device cannot start (Code 10)..Any ideas other than uninstalling and re-installing? Not sure how well remote assistance would run in crappy resolution..if that's the only way then I guess i'll have to try it..but I hope there is another way.
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That's not a good sign that Windows reports the Video card cannot start
    But since that is within Windows with the Windows drivers loaded it won't really matter if you uninstall the Windows drivers or not.

    You are trying to get the Video working from before you get into Windows
    This video display happens during the POST (info HERE)
    You may just need to run Bios Setup Defaults (as per normally required after a Bios update)
    I understand you cannot see anything.

    You need to press the key that allows you to get to Bios Setup screen
    Then run Bios Setup Defaults, then Save and Exit

    Hmm, whilst checking this out for you ;) I also confirmed your latest Bios update file
    You could load Windows up again and just try flashing again, just copy it to your Desktop and run again (ideally do this in Safe Mode with Networking, as you don't want your Firewall to pop up and stop any of the steps)

    Actually try that :), Hmm wait, I'm now reading up on the "Advanced Settings" when running the flash update

    There are 9 boxes leading from the top down. Please only tick these boxes: (ie the PIC above, was taken from the help file, disregard what is shown ticked)
    • Verify BIOS image size
    • Verify BIOS checksum
    • Zero block before erasing
    • Clear CMOS Checksum
    Clearing the checksum forces the BIOS to reset the CMOS with default values, so that's good :)
    Make sure to remove the tick from the other boxes not mentioned by me

    Anyway do that now :)
  6. nobardin

    nobardin TS Rookie Topic Starter Posts: 256

    Sorry I haven't been around. My dad died, so I have been dealing with that. I will give that a try asap Kimsland. Not ignoring your help or anything. I do appreciate the help. A little more info though. I went into the advanced display options then clicked the adapter tab and I see this

    Chip Type: <unavailable>
    DAC Type: <unavailable>
    Memory Size: <unavailable>
    Adapter String: <unavailable>
    Bios Information: <unavailable>

    If I click properties it opens up a window that states:

    VgaSave Properties.....that doesn't sound good to me..further If I click the resources tab I see this:

    *Note* the little icons next to I/O rangex2 and Memory range have a little chip looking thing with the NO sign on the one from the nosmoking signs

    Resource settings:
    I/O Range 03B0 - 03BB
    I/O Range 0C30 - 03DF
    Memory Range 000A0000 - 000BFFFF

    Under that I see:

    Conflicting Device List:
    Input/Output Range 03B0 - 03BB used by: PCI standard PCI-to-PCI bridge
    Input/Output Range 0C30 - 03DF used by: PCI standard PCI-to-PCI bridge
    Memory Range 000A0000 - 000BFFF used by: PCI standard PCI-to-PCI bridge.

    I am going to try what you said, just thought i'd throw that out there. Thanks again for your assistance.


    Well, I did what you said and guess what..I now have video on my screen. You are awesome. Once again you come through shining!! Thank you a lot. I appreciate the help. Now to get it back in order. Thank you again.
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thanks for the update
    I'm also incredibly sorry to hear of your loss. I don't really know what to say.
    My Dad died of cancer, its been many years now, and still obviously saddens me. Life goes on for others though, and the world keeps turning just the same.
  8. nobardin

    nobardin TS Rookie Topic Starter Posts: 256

    Thank you for your help and kind words. It stinks, but, it's life. I am really happy that we got this sorted out. Thank you again. You have been a great help, and I am very thankful and greatful for your time and advice. /Hats off to you! :D
  9. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    if you failed in your bios attempt, you could have a bricked motherboard which requires the EPROM to be re-burned. This requires you to send it to the manufacturer. If you completed the bios and it is the wrong kind, or you wish to revert, it is possible to go back if you have the old bios saved on a file. Read my updating bios guide in the guides forum. As a general rule of thumb, with BIOS, if it ain't broke, don't fix it.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...