Blue screen CLFS.SYS missing

By Stonking ยท 13 replies
Dec 3, 2009
  1. Hi, at boot up I got this message. Tried to repair with the vista disc but that did not work. Tried lasy known good configuration / safe mode etc etc and then suddenly it did actually boot up OK. Turned it off again, on again and same problem. Tried repair with disc again, still no joy. Tried and tried and then it booted up again. This time I tried system restore to a week before this problem started. Turned off, re-booted and blue screen again. Same old story, finally got it to boot up and now I have it on hibernation mode and am not shutting it down. Any ideas how I replace this file or am I going to be forced to do a clean install again. I really hope not.

    Regards to all.
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

  3. pcaceit

    pcaceit TS Rookie Posts: 315

    Try this:

    go to start > all programs > accessories then right click on command prompt and select "Run as Administrator"

    in the dos window that opens type "sfc /scannow" (without the quotes)
    wait for lthe filecheck to complete and observe if sfc made any corrections.

    if that makes no difference then try this hotfix from microsoft seems to replace that file whilst addressing another issue.
  4. Stonking

    Stonking TS Rookie Topic Starter Posts: 47

    Thanks for the quick replies.
    Route 44, not sure if that support is right as it talks about the message 0x0000C1F5. Is CLFS and C1F5 the same thing?
    pcaceit tried sfc but it says unable to fix problems. Went to the hotfix, downloaded it but when I try to run it it says download does not relate to your system but its a vista 64 download and that's what I am running, so not sure what to do now.
  5. pcaceit

    pcaceit TS Rookie Posts: 315

    Do you have Service pack 2 and all the latest windows updates installed?

    Have had a look around for a download of your missing file, with no luck, I've not got vista x64 installed at the moment have got x64 or i would post email you a copy.

    As SFC could not repair the errors i think you have more problems than just the missing file.

    you could try this: insert your Vista DVD and start the installation; when you get to option to Upgrade or perform a new installation select Upgrade and allow the installation to complete. Unfortunately if your Vista DVD does not have your current servicepack incoorperated then this won't work unless you uninstall any later service pack first.

    other than that save your files and reinstall Vista deleting and recreating the partition.
  6. Stonking

    Stonking TS Rookie Topic Starter Posts: 47

    I do not understand why both hotfix's say its not for my system when they are both for vista x64 systems. Does my PC not know what system is running any more? I will try sfc again and see if I can see what the issues are. Can anyone tell me how to make the log appear on my desktop?

  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    [​IMG] > type cmd in the Start Search > click Run as administrator

    Type the following command, and then press ENTER
    findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >sfcdetails.txt

    More info here:
  8. Stonking

    Stonking TS Rookie Topic Starter Posts: 47

    Kimsland, Thanks tried that but when I press enter it just goes to C:\WINDOWS\SYSTEM32>. I have tried scan now again and that once again said not able to fix some of them and that the details are in the CBS.logs Any other ideas how to get to see these logs?

    Thanks again
  9. pcaceit

    pcaceit TS Rookie Posts: 315

    Go to Start> all programs> accessories. right click on notepad and select "Run as Administrator".

    In the file menu of notepad select "open".
    In the bottom right , drop down the list on button that says "Text Documents (*.txt)" and select "All Files (*.*)"
    In the left navigation pane of the opened window navigate to:
    C: > Windows >Logs >CBS

    then open the CBS log file. it will take a while to open as it is usualy quite a large file.
    entries are in date and time order (latest will be near end). use wordwrap, you could use "find" from the "Edit" menu in Notepad to search for "Unable to repair" to locate the errors.
    if you like you could copy the errors and post it.
  10. Stonking

    Stonking TS Rookie Topic Starter Posts: 47

    Hi pcaceit, Thanks for the very clear and easy to follow instructions. I did as you said and I did not find any unable to repair errors but a number of unable errors like the one below:-
    "Stage (1): flags: 8 app: [Microsoft-Windows-OESpamfilter-DAT, Version = 6.0.6001.18344, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral]) comp: (null) man: @0x2068298
    2009-11-23 08:40:33, Info CSI 00000019 Unable to prestage file [l:32{16}]"OESpamFilter.dat" for component [ml:280{140},l:188{94}]"amd64_microsoft-windows-oespamfilter-dat_31bf3856ad364e35_6.0.6001.18344_none_4e7f7cd223f490f2".

    I am sorry to say the whole file is 21meg so best I do not post that. Does this move us along at all?
  11. pcaceit

    pcaceit TS Rookie Posts: 315

    Hi Stonking, Whilst you can still access your files, I would recommend that you save your important data on an external device.

    Try this tool to very the integrety of your hard drive:

    and see here for ho to test your memory:

    If you are sure that your system has no Virus or malware infections and that you have carried out all maintainance (run Chkdsk, disk cleanup, defrag, latest service pack and windows updates, Virus Scan using updated Ativurus etc..) then all thats left is to reinstall.

    When SFC cannot repair the errors it finds, this usually indicates Corruption of Vital System files. As you have tried the most of the restore options if you do not have a full backup to restore then to reinstall is next step.

    If you have to reinstall then do a clean install Deleting and recreating the installation partition of your hard disk.

    hope this was helpful
  12. Stonking

    Stonking TS Rookie Topic Starter Posts: 47

    pcaceit, Thanks for the advice. Windows update says I'm fully up to date.I will try Chkdsk etc tonight one last time. I tried to load AVG yesterday because this all went pants around the time it tried to update me from AVG 8.5 to AVG 9. Anyway, when I loaded AVG 9 yesterday and it asked for a re-boot, Blue screen again and it only got going again when it went to a restore point (I do not know which restore point). So right now I do not have a virus checker on the machine, can you advise a good(free) one? Preferably one that does not need a re-boot to activate. Can you advise a good malware program as well? I have Ad-Aware running a scan right now so lets see what that turns up.

    Thanks again for all the help.
  13. pcaceit

    pcaceit TS Rookie Posts: 315

  14. Stonking

    Stonking TS Rookie Topic Starter Posts: 47

    Thanks for all the help. Reloaded Vista and its working fine now. Also using Avira and like it.

    Regards to all.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...