BSOD "bad_pool_caller" after attempted OC, now no POST

By Jory · 11 replies
Feb 15, 2011
Post New Reply
  1. Hello,

    I was attempting to overclock my computer with the 'Dummy overclock' feature in the computers bios. I did a 5% step-up, (which seemed fine) then a 10% step-up, which made the system very unstable. I tried to shutdown the computer, but it wouldn't shut down so I pushed the reset button. Upon booting the system I received a BSOD with bad_pool_caller and with this stop number: 0x000000c2.

    I then tried to start windows normally, but got the same BSOD, tired in safe mode, got the same BOSD, tried to start it with last know good configuration, and got the same BSOD.

    I tried to boot with one stick of ram, didn't work, tried the other, and that didn't work.

    Now after all of that the computer won’t even reach POST. I tried to clear the cmos with the button on the motherboard, which didn't help. I am now in the process of leaving it unplugged with the battery removed. The post debug LED on the motherboard reads FF, which means boot, which is normal.

    I asked a friend who knows a bit more about this type of thing and he thinks that I fired the bios chip on the motherboard.

    A few questions:
    1: Do you think I damaged the CPU?
    2: Do you think I damaged the motherboard?
    3: Do you think I damaged the ram?
    4: D you think I damaged the bios chip like my friend suggested?

    The motherboard is a EVGA nforce 790i SLI FTW
    And the processor is a Intel Q9650

    If you need more information on the system let me know.

    I am at a lost here and any insight would be greatly appreciated.

    Thank you

  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    It is possible that you may have damaged the CPU, overclocking is not a good thing to do without expert knowledge.

    The error code you received suggests a bad driver.

    My only suggestion with this is to remove the CMOS battery for about ten minutes, replace it and then see if you get the post screen. If not you could try flashing the Bios. You will need to download the Bios from the mobo's manufacturers site.

    If you still cannot get the post screen then I suspect your CPU is fried.

    When you try to boot it is there any sound from the fans, can you hear the hard drive starting?
  3. Jory

    Jory TS Rookie Topic Starter

    Yes, all the fans start up just fine (except the exhaust fan), I can hear the HD kick in, but I can't hear the post beep from the PC speakers and there is no input from the monitor, just a black screen. So flashing the bios isn't an option at this moment. I was thinking of buying a replacement for the bios chip and see if that works.

    When I first was putting together this PC I had an Asus striker II. It had a similar problem, no screen and no post beep. I took it to a computer tech and they replaced the board with the current one I have and told me that it's a common problem with the striker II motherbaords. I can't remember if he told me it was a problem with the bios chip, or it was something I read online.

    Thanks for the quick reply,

  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Replacing the Bios chip is not a job I would envy unless it is in a plug in base. Trying to flash it first would be my first move. Why do you say you cannot do that?

    All I can add to what I have suggested is to check your power supply by testing the output with a volt meter paying particular attention to the supplies to the mobo. You will need to find the pinout diagram and voltages so you know what to look for. Why has the exhaust fan failed, could that be an indication that your power supply is faulty?
  5. Jory

    Jory TS Rookie Topic Starter

    Ok, I feel like an ***** (twice today) turns out that the reset switch was stuck down, which caused the computer to not boot.

    Now the only problem is the BSOD, which is a much easier issue to work through.

    You said that it was a bad driver, I am guessing that overclocking can damage the OS. Any suggestions on how to fix the BSOD problem, I read that replacing the system directory with the repair on that Windows creates when the OS is first installed.

    What do you think?

    Other wise I'll probably just run a chekdsk, then if that doesn't fix it try to back up any data that may still be on the drive (if any of the sectors got corrupt) and do reformat.

    Thank you again for the quick replies,

  6. Jory

    Jory TS Rookie Topic Starter

    I booted into puppy linux to look for the minidump files, but there doesn't seem to be any.

    Is it because I didn't get the bsod when windows was running?

    I am not quite sure how/when those files are created. So I tried to boot into windows to see if it made a minidump file at the BSOD, but it didn't. So unfortunately I can't give you one for further insight to the problem.

    Thanks for the help.
  7. Jory

    Jory TS Rookie Topic Starter

    Well, I managed to replace the registry with the back up from windows\repair in Puppy Linux, booted into safe mode, ran a .reg file I made before attempting the OC and then did a system restore from a couple days ago. It seemed to have fixed the OS. It said it had to rename a few files "to keep the information intact" (or something similar). Which i don't understand since some of the files weren't system dependent and system restore says that it doesn't mess with any of your data files.

    Anyhow, a strange thing happened when I booted into safe mode the first time, it gave me a message saying it couldn't log in to the default user account and made a new one (something along those lines). so I checked the user account directory in "documents and settings" and notice a new user account, with the old one renamed and empty. What I don't understand is how all the data from the old user account got transferred to the new one if windows couldn't log in to the old one.

    The desktop was blank until I ran the reg file and restarted the computer in safe mode. Another funny thing is, that that .reg file I ran before running system restore is now gone. So I think system restore deleted it. I realize now that I could have manually restored my registry from a point in the system restore directory.

    A few question:

    1: How did windows move the data from the old user account to the new one?

    (I think I know the answer to this, the data didn't actually transfer to the "new account" the new account was created so I could logon in safe mode)

    2: Is it possible that I may have caused some harm to the OS or will I have undesired effects because I ran system restore rather then manually restoring the registry?

    3: When you run a backed up registry file on an account (the new one) does it know where to put the entries or does it put it in the current user accounts registry?

    (I am thinking that it does because I couldn't boot normally into windows until I ran the system restore. But the desktop items where there when I booted into safe mode the second time). :confused:

    4: Is there a way to see a list of the files system restore renamed, as it wouldn't let me copy it.

    5: Do you think it's safe to delete the "new account" that it made.

    Sorry for the long post and the lot of questions. I am new to using system restore, and this is the second time I've attempted to repair a registry and have it work.

    Thank you again for your help and time, and if you have any other suggestions or insight I would appreciate the information.

  8. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Sounds like you have got yourself out of the woods.

    1. You have assumed correctly. The old account was obviously corrupt.

    2. Both System Restore and using a Registry Backup are quite safe and should not damage the OS.

    3. When you back up the Registry it makes a copy of the entire Registry, it is not related to any particular user account it stores the information for all of them AFAIK.

    4. None that I know of and it is unlikely to be stored anywhere.

    5. Only if the old one can still be used, which I doubt.

    I would recommend that you reset the overclocking to the correct setting for the CPU and then see if you get any more BSOD's. After a period of trouble free use you could try the overclocking again but for what it is worth I would leave it alone.

    Minidumps are so often just a hint at what is wrong, many times a driver can be blamed just because it was in the system when the crash took place. The one named in your dump file was part of windows that controls script and it is extremely unlikely to be the cause of the problem. My suspicion is that the overclocking has made the CPU unstable which is why I have suggested above that you reset it to the correct default level. Obviously if you still get BSOD's then we can look for something else.
  9. Jory

    Jory TS Rookie Topic Starter

    The CPU settings got reset because I cleared the CMOS and loaded optimum defaults.

    Is there any software that I can run for the CPU (something similar to memtest) to see if it was damaged in any way, or is it a wait a see sort of thing?

    I am going run memtest sometime today to see if there is any damage to the RAM.

    Thank you for your help.
  10. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Your welcome.

    There is nothing I know of that will test a CPU except for a program used to check overclocking stability which pushes the CPU and the RAM up to there limits, I haven't used it so I can't give any guidance. Only the manufacturer of the CPU would have the appropriate software to run a comprehensive test.

    The best way to test the RAM is by running with one stick at a time, if you get another BSOD swap the sticks and see if it happens again, if it does, then the odds are against it being a RAM fault. Memtest will find major faults but can miss the minor ones.

    Personally I would run the system for a while and see how it goes.
  11. Jory

    Jory TS Rookie Topic Starter

    Ok, good to know. I guess this topic can be closed now, as the problem seems to be fixed.

    Thanks once again
  12. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Your welcome.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...