Cannot burn audio cd

By JLVB ยท 4 replies
Nov 18, 2008
  1. Ok, I hope this is the right place for this (I searched for my problem and found something similar listed in this forum, so I figured it's a good place to start).

    I recently installed iTunes, on 10/31 and didn't notice any problems with the program or my computer. I went to burn an audio CD yesterday, and none of the programs I have (iTunes, MusicMatch Jukebox or Roxio) could identify the drive. After looking in the device manager, I discovered that both my drives (Samsung DVD-Roms, one is an RW) were marked with a yellow exclamation point and under properties was the error message Code 10 Device cannot start (or something like that). I did some research and found a number of articles that instructed me to delete the upper and lower filters from my registry. After doing this, both drives are now functional and marked as working properly.

    Here's the interesting part, that I can't seem to get past. iTunes says that the registry files it uses for its burning program are now missing. Obviously the ones I deleted that were causing all the problems in the first place. Now, my drives work, they will load software and recognize blank discs, but none of my burning software can find them when I go to burn an audio CD. I've already reinstalled iTunes but it either didn't fix the correct problem or the reinstall didn't repair the problem. I'm not sure what to do short of remove iTunes alltogether, which would make it difficult to use my iPod, but I'm up for trying anything to get my burning software functioning properly. I wanted to avoid restoring, since I've done a lot of other driver updates and windows updates since. I'm afraid I'm going to go in circles if I keep deleting, resinstalling and restoring ... Vista also claims all my drivers are up to date and all that.

    If anyone has been here before, I'd love some advice. Or at least encouragement. If anyone needs to know more info about my system, I'll gladly provide it. Thanks!

    PS I have Vista Home Premium on a custom built Dell system
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. JLVB

    JLVB TS Rookie Topic Starter

    Thanks, that's the exact page I used to the original fix. I am thinking I have to completely remove and then re download iTunes again.
  4. JLVB

    JLVB TS Rookie Topic Starter

    Ok, here's an update on my situation.

    I removed and reinstalled iTunes, to no avail. It did not correct the problem. I did a support search on their page and found a different method of correcting the drive problem, but I had to do a system restore. Following their directions also returned functionality to my drives, but I still cannot burn a CD.

    I had also uninstalled a few programs that I no longer used and when I did the system restore, I fould them back in my Add/Remove Programs list. However, they are already "deleted" and so I cannot remove them from the list. This is annoying, and if anyone knows how to removed previously deleted items from that list, I'd love to know as well. I've tried programs designed to remove any lingering aspects of a previously deleted program. It didn't work.

    Also, I removed the three other programs that utilized my drive for burning, and iTunes still doesn't burn, although my drives do work now.

    I'm annoyed. I'm thinking about trashing the whole computer.
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Download CCleaner
    Install and Run
    Click on "Tools" in the left hand column
    Uninstall\Delete any Add\Remove Program entries
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...