Cannot See External USB HDD in 'My Computer'?

By andyc2008 · 22 replies
Sep 16, 2008

    I Cannot See External USB HDD in 'My Computer'?
    I have just bought an external HDD Enclosure from Ebay. I have plugged in both USB cords (i beleive the caddy has two cords due to the power required). Then the little ballon pops up on the bottome right of my screen saying my new hardware is installed and ready to use. NOW this is where i get confused, there is no additional drive in 'My Computer' . In the Device manager, under 'Disk Drives' the device is shown as 'Generic External USB Device'. HOW do i get to access the files that are on my external drive?? (the drive comes from a laptop i have with a broken screen so as far as i know the HDD is in good condition) I have been reading up on the net about this issue and the consensus is that i have to assign a drive letter, when i try to do this, it asks me to initialize the disk, i have noot done this as i beleive initialize means 'wipe it clean and start again' which i do not want to do...I NEED THE FILES ON THE DISK........................PLEASE HELP ME :)

    Thanks everyone in advance!!!!
  2. rf6647

    rf6647 TS Maniac Posts: 829

    Watch the balloons - It appears that the USB enclosure is recognized, but there is no indication that the HDD is recognized. Try different positions for the jumper (master/slave). Check polarity of the cables/cords.
  3. andyc2008

    andyc2008 TS Rookie Topic Starter

    I cannot seem to see any jumper on the HDD ?? It comes out of a laptop and is a Hitachi 'HTS541080G9SA00' . Im not sure what the polarity of a cable means?
  4. rf6647

    rf6647 TS Maniac Posts: 829

    I am a fossil. My enclosure is for IDE drives. The connector is not keyed. This permits either orientation for the IDE connection (polarity) or a misalignment of the connection.

    Issue 1: What current is required by the HDD? USB hubs typically are limited to 500mA. Beyond that, get a powered USB hub.

    Issue 2: Your HDD is SATA - do you have the needed driver? "Jumper" does not apply.

    Issue 3: Does the enclosure support SATA?
  5. andyc2008

    andyc2008 TS Rookie Topic Starter

    Issue 1. i got the following from the Hitachi data sheet
    Requirement +5VDC (+-5%)
    Dissipation (Typical)
    Startup (peak, max.) 5.0W
    Read (avg.) 2.0W 
    Write (avg.) 2.0W 
    Active idle (avg.) 0.85W 1.2W
    Low power idle (avg.) 0.60W 0.85W
    Standby (avg.) 0.2W 0.4W
    Sleep 0.1W 0.2W

    What does all this mean?? Does the USB cable have enough power (with both cords from the caddy plugged in?)

    Issue 2.
    I searching the driver at the moment, have had no luck as yet, will let you know if i can find it!

    Issue 3.
    Yes it is a SATA enclosure.
  6. andyc2008

    andyc2008 TS Rookie Topic Starter

    Issue 2 can be wiped from the possibility i think because.......this is from Hitachi...
    Current operating systems, including Windows Vista, XP and 2000, and Mac OS X, already include pre-installed drivers for the hard disk drive itself. No additional drivers are required.

    If your system is requesting drivers you may need current versions of your controller or motherboard drivers. To obtain the most current controller or motherboard driver, contact its respective manufacturer.
    When i plug it in, vista finds and installs drivers and says 'Your new hardware is ready to use' or words to that effect!
  7. rf6647

    rf6647 TS Maniac Posts: 829

    Either the HDD is not being detected or it is not being configured. Which is it?

    The USB portion of the device is being configured. If device manager shows and Unknown device or a device in trouble, then there was an attempt to configure the HDD.

    Insufficient power can cause problems. You are silent about what you are observing about any status indicators and about the spinning of the HDD.

    If this is a desktop, you may have more than 1 USB hub. Power from the rear hub. Access via a different hub. (Check out device manager).

    Note: Startup current @ 1000mA puts a strain on the components. I cannot quantify the risk of failure from repeated startup operations.

    Once the circuitry has stabilized, use device manager to uninstall the USB enclosure, and then, go through the action to rescan for hardware changes. This is a "shot-in-the-dark" for the case that the effect of excessive power consumption on startup disappears once reaching a steady state.
  8. triiifashions

    triiifashions TS Rookie Posts: 129

    assign drive letter

    that is the way
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    A couple random thoughts of things and what to do next
    and i'm still just wakin up so my apologies if my typing is sloppier then usual

    1. Not clear from the post:
      • Were you plugging this thing into a USB hub or USB ports on what? (would like makes and models
      • I assume you tried plugging into different ports on your whatever.. Not just tested off the same port each time?=
      • Sounds like you looked at this thing from your desktop view, did you look at it using Disk Managment through MMC snap-in? If the issue is the hard drive space isn't formatted/badly corrupted /some other cases too.... you can get an indication that the lower level devices are being detected. The problem is mapping it to the next higher level (and functional) device level. So look at it with Disk Management
      • If the proud owner of this things wants to take a closer look under the covers (which i haven't played with much but do have the tool), we can monitor the commands sent over the USB bus and that MAYBE sheds more light or even an answer.
      • Like i said. just some thoughts.....

  10. grahama

    grahama TS Rookie

    If you are running Vista the problem will most likely be the USB drivers. I have had the same problem and the only way it will work is to have the most up to date motherboard USB drivers installed.
  11. andyc2008

    andyc2008 TS Rookie Topic Starter

    I do not think the HDD is being detected. The green status indicator light is on and it is green, the hard drive is humming and sounds like it is spinning in the enclosure, it is definatley getting power.

    Device manager says 'Generic USB Device' and thats it, i have uninstalled it and scanned for new changes but i end up with the same result. (I also tried plugging into the external USB ports in the rear of the desktop)
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    [post=662865]Look at this post[/post]

    Follow the steps and we can take it from that direction as well. However, in your case, we want a string starting USB (not PCI). ALSO ignore USB\ROOT_HUB strings

    But let me ask, (i forget, so asking) have u tried unsinstalling and reinstalling drivers for ALL USB controllers? Would do that before we go tracking down device id and hardware ID stuff from device manager
  13. andyc2008

    andyc2008 TS Rookie Topic Starter

    1. I am plugging the enclosure into USB ports on my Dell Inspiron 530s (i have tried front and rear ports)
    2. I have tried to look at this thru Disk Management, it asks me to initialize the disk (doesnt this mean wipe everything on it???) i dont want to do that. (what is MMC snapin??)
    3. What do you mean look under the covers?? look in the box?? what would i be looking for?
  14. andyc2008

    andyc2008 TS Rookie Topic Starter

    Device instance Path - i get this
    Parent - i get this
    Hardware ID - i get this

    (P.S. I am running VISTA not XP (your link to the devmgr changes was for XP OS))
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1. Good. Sometimes in these situations is easiest to use a different port and the dirver gets reinstalled for other port. Bad. Didn;t help in your case!
    2. MMC = Microsoft Management Console. A group of tools that "snap-in" to a generic console from MS so you can tailor all the things in the console you want to use E.g. The computer management console you see which includes Device Manager is a pre-configured MMC including several different snap-ins
    3. You know how one can use a network sniffer to see the data exchanged thru your network card? I have a tool does the same picking up the USB traffic. Tho not clear how much value would be just now (also as i;m still not REAL familiar with the tool myself.)

    BUt can try and see what's up if you do the Device Manager thing and we can at least see what's detecetd/happening there
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    1. i gotta run out awhile so can't look at those ids right away but....

    2. I don't know if exists but would think so.(maybe u google or i will look when back) For the Device Manager patch to show unconnected hidden devices to work in Vista too (device manager is very similiar XP/Vist)

    In this case, cuz i still think (dont know if u tried) easiest 1st step is

    1. uninstall/reinstall the usb controllers,
    2. Start device manger and View->Hidden Devices. There shouldn't be ANY ghost icons (i.e. devices installed but not connected. Particularly if it;s for your disk drive cuz sometimes to get clean re-install u have to assure any ghost installs are removed)
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    oh. and last thing.

    the important point (when u used Disk management) was that your drive at least appeared LISTED in disk management (when it wasn't appearing as a disk volume on My Computer)
  18. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    I'm thinking the main drive is Fat32 and the external is NTFS
    Also confirm rear USB is USB2, and the HardDrive USB data cables are USB2 compatible
    I also agree with the wattage issue
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK. The mind was working slow this morning. Shoulda connected the dots when you told me about Disk Management but it came to me while sitting in the barber's chair LOL

    Don't know if this is your problem but everything consistent with a problem i fixed for a friend (tho can't quite explain why it should ve happened in the first place)

    let's try this..

    do you have a good partition management tool? If no, can recommend Acronis Disk Director has always worked well for me and the first 15days are free.

    Download , install. Start it. It should find your hard drive and like Disk Manager tell you it's not formatted.

    But tell Acronis to do Partition Recovery, cross your fingers and see what it says
  20. andyc2008

    andyc2008 TS Rookie Topic Starter

    Acronis Recovery Expert cannot find any unallocated space(s) on your hard disk drive(s).
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    DARN! :(

    will look again at my Acronis and any other options in the morning but is sounding more and more like the disk itself is bad
    - That's why the USB message for the device but none for the logical volume
    - Why the physical disk appears in Disk Management but there's no logical volume displayed in Explorer

    And Acronis not reporting anything isn't a good sign either.

    You have any other enclosure or computer with which to test that disk? You might have to rely on data recovery software to get what you can if, as it's appearing, it's the disk itself. Never used them so can't recommend there tho.

    /************ EDIT ************/

    I just looked back in the thread and didn;t see it mentioned.. Out of curiousity, what file system was on the disk? What operating system was on the machine it came from?

    But looking back again, i didn't notice if you ever did uninstall the USB drivers for all the controllers? and then reinstall? or what have you done wrt driver uninstall/reinstalls/
  22. andyc2008

    andyc2008 TS Rookie Topic Starter

    Sorry i havent replied to this in a couple of weeks i went to Phuket in Thailand, it was BEAUTIFUL!!!!! highly recommend it!!

    Anyhow, with a fresh mind i ran the Acronis without plugging in the drives (obviously it did not find the external drive).
    i then plugged in the External drive opened Acronis again, and had exactly the same result...... So Acronis is not picking up the External drive....
  23. andyc2008

    andyc2008 TS Rookie Topic Starter

    Im not sure what the file system was, the disk came from a Dell inspiron 640m running windows XP Pro.

    i did disable the controllers and uninstall all the USB drivers then re-installed
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...