Canoscan 8400F driver not installed on Win 10

By fw2004
May 6, 2016
Post New Reply
  1. Hi;
    I upgraded my system from Windows 7 Ultimate to Windows 10 Pro. It was an in-place free upgrade, and I did not have to re-install any software or drivers. Everything just worked - amazingly!
    I have a CanoScan 8400F flatbed scanner connected to this system. It worked fine in Win 7 and worked in Win 10 after the upgrade.
    But recently, it appears that the scanner's lamp is going bad. After an hour or more of scanning, the time required for the lamp to adjust gets longer and longer. I am on the verge of replacing the scanner, but I wanted to rule out a driver issue, so I un-installed everything Canon from the system. Not only did I do an un-install, but I ran "Registrar Registry Manager" and cleaned out every "Canoscan" entry from the registry. Then I rebooted the system, and began the process of re-installing the driver and software.
    I have the latest driver for x64 system - the one which worked on Win 7, and ver 4.9 of the CanoScan Toolbox.
    The Toolbox installs properly, but when I install the driver (from file SetupSG.exe), it starts the install, and appears to complete without errors, but there is never any confirmation dialog telling me that the driver was installed. When I open the Toolbox, there is no scanner available. I have tried installing the driver before and after installing the Toolbox, and always get the same result. I have rebooted the system after each install.

    Doing a Google search, I found a blog describing a step that needed to be taken to add the path to the driver in the system environment variables, so I did that, making sure that the path pointed exactly to where the files were located. I rebooted the system after adding the path. These files are never installed in the Windows \system32 or Windows \ SysWOW64 folders - there is apparently a security issue here. In any case, this step did not solve the problem.

    After much frustration, I decided to restore a previous point - which was only 2 days old. After the restore appeared to complete, and the system rebooted, there was an error telling me that the restore operation had failed and that no files had been changed. Yet, when I powered up the scanner, it connected and I was able to do my scans. So I guess that, while no files had been changed, files which had been removed were added back.
    There are several files "CNQ8400" with different extensions in folders "C:\Windows\System32\DriverStore\FileRepository, and C:\Windows\twain_32, which were not in these folders after my re-install attempts. Perhaps this has to do with security on these folders. Yet, I did run the install as admin, and I also ran it with compatibility for Win XP SP2 or SP3.

    So at least for now I have my scanner working again - until the lamp fails completely and I replace it. I need to create a full disk image now so that next time something like this happens, I can just go back to the working install. This has always been my practice, but I haven't created an image for a couple months, and didn't want the bother of re-installing or changing settings.

    Any ideas on this, or is is just time to replace the aging 8400F?

    Thanks for your help, and sorry for the lengthy post.

  2. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +250

    Buy a new scanner. It's not worth all the bother of messing about and they are not that expensive.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...