Can't connect to wireless internet after installing Linux

I just finished installing Linux on to my Dell laptop. For some reason, it doesn't even recognize my wireless card when trying to establish my internet connection.

Could it be that my wireless card is not compatible with Linux?
Perhaps my service provider has something to do with it?

please help!!


Posts: 3,357   +116
More information is needed please:

  1. What is the model of your Dell?
  2. What's the tag no?
  3. What linux are you using?
  4. If you know the make and model of your wireless card this would be useful as well.

This information is important as we need to know what wireless card your laptop has, and what linux your running to advise you further.
Thanks Leeky. I am not sure if this is the tage: Dell LBL PIN DF643 400.
Its an old laptop so I the model no and other ID tags have been rubbed off, however I did a goodle search of the number above and it came back that it was a Dell Inspiron B130.

There were a few options of wireless cards:
Dell Wireless 1470 802.11 a/b/g MiniPCI Card, B130/1300/120L US (RoHS)
H8162 Dell Intel Pro 2915 802.11a/b/g MiniPCI card, B130/1300/120L, US (RoHS)
Y8029 Dell Wireless 1370 802.11 a/b/g MiniPCI Card, B120/B130/1300/120L US (RoHS)
C9063 Dell Intel Pro 2200 802.11b/g MiniPCI card, B130/1300/120L US (RoHS)

The Linux I installed is Fedora Core. I really hope this helps, thank you.



Posts: 3,357   +116
Sorry for the delay, been rather busy studying!

Dell always put the model no and tag no in the BIOS, so you can easily get them from there.

On the underside of your laptop, one of the small covers will likely house your wireless device. It's important to know exactly what wireless card you have as the proceedures will be different for different cards.
found the wireless card

Hey Leeky
Totally understand with work. I'm in the same boat. I found the wireless
card with your direction and it's dell y8029 dell wireless 1370 802.11/a/b/g mini pci.
I tried getting an external wireless USB over the weekend and I couldn't even get fedora to open the setup.exe because it needed an application to open it with. Not sure what my options are at this point. Thanks for any tips/advice. I owe ya one.


Posts: 3,357   +116
Hello Dan,

Head to this link:

That should give you all the information on how to get it working with ndiswrapper. Dell's 1370 wireless card is known to work, and in the working list, so following that guide should see you sorted with a little time.

You'll need the windows wireless driver, which will either be on your drivers cd, or can be downloaded from driver support pages.

.exe files are windows native executable files. They can be executed when running Linux, but only if your using Windows emulation, but it won't achieve what your trying to achieve. Put plainly, Windows drivers, and windows software does not natively work using Linux unless you have software that can interface between the two (Linux and windows software) to make it work.

Thanks for your help. I have been at it all day and was unsuccessful. The main problem holding me back is that I cannot run RPM Fusion Free and NON Free because:
A. I am unable to get to the site on the computer with linux becuae I have no internet access.
B. I went to the site with another computer and saved the files to a usbflashdrive but I am unable to mount it and therefore unable to dowload the files on it.

Any suggetions or tips on this?



Posts: 3,357   +116
Do you have anywhere you can use the internet by connecting it with a ethernet network cable temporarily?

That would be the speediest method of achieving this.
Yes I do. I tried plugging an Ethernet cord into it and directly to the router with no avail. When trying to configure the connection, it asks me to choose an Ethernet adapet from the list but its not there. According to the dell website the adapter is a broadcom. Is there another way to connect?