1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Can't install network card drivers, Access is Denied

By jbclem1
Nov 8, 2014
Post New Reply
  1. After a new WinXP Pro sp3 installation, I no longer had internet access. I discovered that the network card (Ethernet Controller) wasn't installed. I had the motherboard (Asus P4PE) CD so I tried to install the LAN drivers but everytime I try, whether from the CD or from a folder on the hard drive, I get the same error message telling me that Access is Denied. I've tried in Safe Mode, but that didn't help.

    I've checked some User Permissions, in Local Security Policy (Administrative Tools) and I seem to have permission to install and uninstall drivers. But I'm not very familiar with Permissions and Access Rights so I need some help with this.

    I've also run Dial-a-fix, but it didn't find any problem with permissions.

    Can someone help with this, my computer is pretty useless without internet access.

    Thanks, John
  2. jbclem1

    jbclem1 TS Rookie Topic Starter

    I'm now gone into the registry and checked the permissions for PCI. The admin is set for Full Control, and I'm the administrator. I tried changing Everyone else from Read to Full Control permissions, but that didn't make any difference. So I'm still stuck on this.

    BTW, I was able to install the Soundmax drivers (integrated sound chip) from the Asus P4PE installation CD.
  3. jobeard

    jobeard TS Ambassador Posts: 12,428   +1,410

    On XP, you need to login as Admin, NOT RUNAS admin.

    Normal users had SID like
    • HKEY_USERS\S-1-5-21-3496390126-4056983672-103562743-1000
    but the REAL ADMIN is
    • HKEY_USERS\S-1-5-21-3496390126-4056983672-103562743-500
    the NTFS perms are keyed to the SID
  4. jbclem1

    jbclem1 TS Rookie Topic Starter

    I don't know what SID is, and I'm using FAT32, not NTFS. Also, as I said, I logged in as Administrator, although I did say somewhere else that to get into the Local Security Policy folder I had to use RunAs.

    Anyway, this problem seems to be resolved. I tried running the troubleshooter in Device Manager/Network Adapters/(name of device)/properties...and it took me through the exact same procedure as when I tried to UpdateDriver, but this time I was able to install the driver without the denial of access. I don't know what the difference was, but it worked!

    Now I just need to figure out why my CD-ROM won't read or play a disk even though it's recognized in Device Manager as working properly, and works fine in DOS.

    Thanks for the help...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...