CD-ROM and HDD not detected in BIOS

My desktop had windows xp installed in it. Yesterday I tried to installed XP- sp2 in it. I inserted the bootable cd and repartitioned the whole hard drive. Then selected C drive for installing the windows XP- SP2. then the option came formatting the drive with NTFS format. I selected it and C drive was formatted. But after formatting, the system shows an error. The message was" The drive cannot be formatted due to an error, please use another partition for installing windows. Then I selected D drive and the same message was displayed again. Then it showed that there is an error in installtion and press F3 to quit setup.

Then I restarted the windows and tried to changes booting device priority. Now in BIOS, only floppy drive is being displayed. No HDD and CD-ROM is displayed in booting devices. But initially before installing XP- SP2 cd, I entered BIOS and changed the priority to CD drive. At that time, both HDD and CDROM was displayed in booting devices priority.

I dont know what to do now. Every time I open windows now it shows that "Reboot and select proper boot device or insert boot media in selected boot device".

And when I am entering BIOS and trying to change the boot devices priority, neither HDD nor CD-ROM is being displayed there. Hows that possible that both HDD and CD- ROM is not detected in BIOS?

Please help guys. Ur advice might be very helpful for me. Thanks in advance.



Posts: 1,020   +56
Hi Vishal, One simple thing you could try, is to remove the BIOS battery, leave it out of the pc for 5 minutes.
Fit it back in the pc, and try again.
Also if that battery is more than 5 years old it may be at a low voltage, so if you have a voltmeter you should get 2.5 to 3V dc, across the battery.
First Remove The Ram , CMOS Battery And Switch On The System .Then Turn It Off After 5 Minutes Then Put The Things Back In Respective Place Then Switch On The System , If You Still Get The Same Error Then Unplug DVD Writer First And Try , If This Also Doesn't Work Then Pls Check The Sata Cables , if it is still not working unplug everything then re-plug it on switch on the system your problem is solved...!