Computer is connected to Internet but Internet doesn't connect

By Max77 ยท 10 replies
Jun 14, 2012
Post New Reply
  1. Dear Techspot Forums,

    I am having some serious problems with my computer that I'm hoping you can assist me with. My computer is currently connected to my wireless Linksys 3000 device and everything is working properly. My laptop, that I'm typing this forum on now, is working great and always connects when I turn it on. My computer however, does not connect.

    The computer shows that it is connected to my Linksys device, but upon clicking on the internet button it says "webpage can not be displayed" The bottom right hand corner of my screen shows "limited connectivity" with a small yellow triangle. This icon has shown in the past, but I've still been able to connect with it.

    I'm not sure what to do, I've done everything from repairing, running full system Norton scans, to downloading a winsock repairer from a flashdrive, and trying that on the computer. When I run the winsock and click "fix" it says "registry import information not found". Because I cannot connect, norton security is out of date, and I cannot conduct buisness on it. Any information would be most helpful!
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

  3. Max77

    Max77 TS Rookie Topic Starter


    I downloaded malwarebytes and the temp file cleaner you reccomended, The malwarebytes would run on my laptop, but when I transfer to a flashdrive and download on the problem computer, it doesn't run, The temp file has worked, and is still running- should have a full report a bit later. Thank you for helping me- it means a lot.
  4. Max77

    Max77 TS Rookie Topic Starter

    I rebooted my computer from the temp file cleaner, and still have no internet. I tried tranfering Microsoft Security Essentials over but that won't run for some reason as well. Once I get internet I plan to get rid of norton and download MSE. What do you reccomend my next step should be?
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    MSE needs to have an active Internet connection to install... How is the desktop connected to the Linksys 3000? By wire? Can you re-run the install software? Doing this might give you a clue to what is wrong
  6. Max77

    Max77 TS Rookie Topic Starter

    The desktop is wirelessly connected by a Netgear Wireless-N 150 USB adapter. It has always worked flawlessly, and still does. It has recognized the Linksys 3000 upstairs, and shows that it is connected- and with 3 full bars. With that in check, I'm still finding it hard to believe I can't connect. I don't think I have the install software
  7. Max77

    Max77 TS Rookie Topic Starter

    Could we be looking at a winsock problem?
  8. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You can download the install software from Cisco/Linksys support website
  9. Max77

    Max77 TS Rookie Topic Starter

    How can I do this on my desktop without internet access? Will it work if I download on laptop and transfer over with a flashdrive?
  10. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Yes, that may work...
  11. gcarter

    gcarter TS Enthusiast Posts: 82   +23

    If this was a problem on one of my machines, the first thing I would try is forcing a manual ip and dns address... see the guides for different os's in the below link

    The most important step is to get your routers dns entered correctly... to determine this, on your machine which connects to the internet successfully, bring up a command prompt and type "ipconfig /all" without the quotes... your looking for the "default gateway" address...

    I've had a few machines in the past which refused to connect unless they were manually assigned an ip address and dns address... do let us know if this works for you?

    A manual ip address works with both wired and wireless connections... personally all of my machines have a manual address assigned to them, which makes it much easier to connect to them remotely

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...