Computer won't recognize AData flash drive

By paulwglass
Feb 21, 2011
Post New Reply
  1. i have a adata c802 8gb flash storage device (stick)
    the problem started when removing files to my desk top.then i formatted my USB flash DRIVE.After this i couldnt get back into it.says format drive again, this i tired but window came up cannot format this drive!! i have gone into properties looked for problems, even changed the letter on drive but to no avail!! im running windows xp pro. in propertis i can see the ADATA USB FLASH REMOVABLE DEVICE.also tell's me 0 space used 0 free space
    tried update , no joy,tried change letter no joy. some how my pc wont open it!?
    when open My Computer ICON the drive reads Removable disk,(should read ADATA UFD (F)
    IN computer manager it says Healthy but does not give the FAT32 file system(whereas the new flash drive gives this info.also it doesnt read as ADATA FAT32 (only as H drive)
    As it is i cant open usb flash drive. just keeps reading (format drive-then says cant format drive)
    anyone here have any ideas... regards
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You can take a look through here See [post=720762]Troubleshoot: Windows Won't Recognize Your USB Hard Drive[/post]

    tho my top guesses (see Guide for details)
    > Remove old USB storage drivers
    > Have you tried a different USB drive? If it also is a problem, then try fixing filters

    Otherwise, it's probably corrupt. Try data recovery
  3. paulwglass

    paulwglass TS Rookie Topic Starter

    ADATA usb flash DRIVE DEVICE

    Have tried the driver cleanup.exe yes it did clean up old usb reg files no problem!
    but still have the same problem!
    just wont open keeps say usb formatting ( after trying to format) then says cannot format this drive.theres no point in trying recovery files since they were taken off befor this happend.
    my new ADATA 16GB C802 HAS NO PROBLEM
    AFTER driver cleanup.exe both USB 8GB and 16GB CAME ON AS DRIVERS DOWNLOADED AND WORKING,yet the 8gb wont open.
    alas!! any other ideas i can try, but feeling that this 8gb is totally CAPPUT!

    THANKS ALL FOR YOUR HELP Regards paulwglass

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...