Constant BSOD's, Machine Check Error

By lisentia ยท 16 replies
Dec 23, 2010
Post New Reply
  1. Greetings Techspot!

    This is a complete custom machine. I have built it entirely from scratch, and typically am able to diagnose and solve most of my issues on my own. However this time I am unable to do so.

    OS: Windows XP w/SP3
    CPU: AMD Athlon 64 x2 3800
    Mobo: Asus M2V-MX
    RAM: Crucial 2G DDR2
    Vidcard: Nvidia Geforce 9800 GT
    Sound: Diamond Xtreme XS5.1
    430w Power Supply Unit

    I have already cleaned the dust, double checked the fans, installed Everest and Speedfan, run checkdisk, reset my pagefile, and defragged my HD. Speedfan shows all of my temps within normal parameters according to manufacturer specs, and the 12v rail runs at 11.26v steady.

    I'm unsure what exactly Everest is supposed to show me, so I'll answer what questions you ask or run a report and upload it.

    As it stands, I'm having to post this while I'm in SafeMode with Networking. I was able to completely defrag (14hrs!!!) in Safe Mode, but a restart into Normal mode caused more BSODs again. Because I'm in safemode I can't download the Windows SDK with Debugging to check these minidumps myself.

    Thank you in advance for any and all assistance you are able to give regarding my situation =D

    Attached Files:

  2. lisentia

    lisentia TS Rookie Topic Starter

    I'm so sorry. I forgot to mention: This issue began on Monday 12/20 and became progressively worse on 12/21 and yesterday 12/22 I could barely blink before getting a BSOD. On 12/21, after a couple BSODs I began updating drivers: Mobo, Vidcard, Soundcard, BIOS. Sadly because of the age of my mobo, even updated drivers are a couple years old.

    Again, thank you in advance =D
  3. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    All your errors are 0x9C: MACHINE_CHECK_EXCEPTION: This is a hardware issue: An unrecoverable hardware error has occurred. The parameters have different meanings depending on what type of CPU you have but, while diagnostic, rarely lead to a clear solution. Most commonly it results from overheating, from failed hardware (RAM, CPU, hardware bus, power supply, etc.), or from pushing hardware beyond its capabilities (e.g., overclocking a CPU).

    Honestly, this is a very difficult error to work with because as it says a clear diagnosis rarely comes forth and I have never seen a minidump with this error code give a definitive answer. I know IT techs that don't like working with it. What makes it so difficult is that it can be any hardware in your system -- and I mean any. Your dump simply cited atapi.sys but more on this later.

    Here are some of the causes that were determined to be the source of 0x9C errors from posters here and abroad: NIC, DVD/CD drives, dust build up around the CPU that caused overheating of said CPU, bulging capacitors hidden by heatsink, video card, psu, motherboard, and external harddrive connected by USB.

    * I have to leave for a few hours but do you know how to a) update your BIOS, b) update your chipset driivers, and c) do a harddrive disk diagnosis? What make is your harddrive?
  4. lisentia

    lisentia TS Rookie Topic Starter

    a) Already updated BIOS with the latest available from Asus
    b) ditto
    c) I'm not 100% sure what you mean by Harddrive diagnosis. I've run checkdisk /f /r and gotten no errors.

    I have a Seagate ST3500418AS 500G drive.
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Go to Seagate's website and download their free harddrive diagnostic utility called Seatools.

    In the BIOS place your CD/DVD drive as first bootable.

    Burn the utility to a CD and once burned reboot the computer with CD in drive.

    The test will take over. Run in this order SMART, Short DST, and especially the Long DST.
  6. lisentia

    lisentia TS Rookie Topic Starter

    I ran all the tools. SMART came back clean, with no errors tripping the SMART sensor. Short DST and Long DST both came back 100% with no errors.

    I've also run Memtest 2x with 3 passes each, and again 100% with no errors in both of my DIMM slots. I have a Kingston 2G DDR800 stick.

    I've removed my vidcard and soundcard, and am currently using the onboard VGA in Safe Mode with Networking. I had tried using my system again, and have uploaded those minidumps.

    I had a bit of a time trying to get the Seagate Tools and Memtest burned to CD in safemode, but I got it done! =D

    Attached Files:

  7. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    All are 0x9C errors and nothing definitive was cited.

    memtest needs to run a minimum of 7 Passes and the more the better because often errors don't show beyond the minimum number of Passes.
  8. lisentia

    lisentia TS Rookie Topic Starter

    Okay. I'll make sure to run memtest for 7 passes today.

    Do you know of any diagnostic tool or program for CPUs? So far I've eliminated the soundcard, vidcard and HD from possible sources. Mobo, and CPU are the only two left after I ensure the memstick is good. =)
  9. lisentia

    lisentia TS Rookie Topic Starter

    RAM is fine. I have disabled the onboard LAN port through BIOS to eliminate any NIC errors since I'm currently having to use a wireless USB adapter. I have already tried starting my machine without the wireless adapter plugged in. No luck. =)
  10. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Check your SATA cables. Make sure they are securly connected. we have lost count of how many issues are resolved due to either cables not connected securely or they have gone bad.

    CPU - I believe the Johnathan King of this article also posts here occasionally. I've never had the need to test so this is up to you but Prime 95 is used by a lot of system builders..
  11. lisentia

    lisentia TS Rookie Topic Starter

    I'll see what I can do about testing my SATA cable.

    I did some research on Prime95. Is it a true diagnostic? or is it only used to burn the CPU and thermal paste together?
  12. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    It should test the cpu but there are other offerings.
  13. lisentia

    lisentia TS Rookie Topic Starter

    Okay. I'll set it up and get you the results =)
  14. lisentia

    lisentia TS Rookie Topic Starter

    I've been running Prime95. The small FFTS cycles through all the integers fine, the large FFTS does the same but the blend test has failed twice. Here is what it says:

    [Mon Dec 27 22:14:10 2010]
    Self-test 160K passed!
    Self-test 128K passed!
    [Mon Dec 27 22:22:59 2010]
    FATAL ERROR: Resulting sum was 9.4374118181811e+017, expected: 6415148337516169
    Hardware failure detected, consult stress.txt file.
    [Mon Dec 27 22:35:00 2010]
    Self-test 64K passed!

    [Tue Dec 28 05:44:44 2010]
    Self-test 128K passed!
    Self-test 128K passed!
    FATAL ERROR: Resulting sum was -4.319029279798067e+016, expected: 1.328467436150953e+016
    Hardware failure detected, consult stress.txt file.
    [Tue Dec 28 06:00:34 2010]
    Self-test 64K passed!

    So 64k passes on one worker but doesn't pass on the other worker, and none of the other integers fail.
  15. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Hi lisentia, sorry for the delay but I was with my family on a short family Christmas vacation. :)

    Let me see if I can get someone else with my working knowledge than myself to look in on this thread.
  16. lisentia

    lisentia TS Rookie Topic Starter

    Thank you hun. I appreciate it! I'm fairly certain I have narrowed the issue down to my motherboard.

    Between the BSODs, the unresponsiveness of the USB ports, my constant disconnects with a connected wireless adapter and a couple other minor things I'm fairly confident this is the issue.

    I'll do my best to update this thread once I'm able to get a new one =)
  17. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Yes, please keep us updated.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...