Creative N400 SoundBlaster X-Fi problem

By Rezolution ยท 22 replies
Apr 18, 2011
Post New Reply
  1. HP d4650y Pavillion with XP(32).

    SB0670 X-Fi Soundcard.

    Problems - USB speakers not recognized regularly, headphones would not work.

    Soultions - Switch to SB X-FI or Creative Speakers in your sound and audio devices defualt devices to alternate between headphones and speakers.

    Driver Downloads- (USB Speakers) ( Browser/EQ )

    Hope this helps.
    If you would like to read how it went ,read below.
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Sounds like you may have some drivers missing. Take a look in Device Manager and see if there are any yellow warnings next to the list of hardware devices.
  3. Rezolution

    Rezolution TS Rookie Topic Starter

    Nope have installed, deinstalled and reinstalled them repeatedly.

    Tried the Bios (F-1 at startup) and switched between Auto and Enabled which recognized Realtek but am using the SB X-Fi, and even when I did the sound device(Realtek) would still not allow me to use it.

    After this I did deinstall the disabled driver it recognized from setting to enabled.

    Since it will Not allow me to use, it will also not allow me to use my headphones in either the front jacks OR the soundcard jacks.
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

  5. nismo91

    nismo91 TS Evangelist Posts: 930   +33

    have you tried other USB port? or even other computer?
  6. Rezolution

    Rezolution TS Rookie Topic Starter

    I have already tried deinstalling and reinstalling and have simply disabled the realtek device. Incase I need it later.

    It allowed me to have the speakers work after startup, but the Creative X-Fi Browser will still not function.
  7. Rezolution

    Rezolution TS Rookie Topic Starter

    Would the speakers being USB only be part of the problem if my sound card does not have a port for it?

    If so why won't my Realtek device work if enabled?
  8. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    I appreciate you have uninstalled and reinstalled , have you looked at the guide I gave?, this allows you to find drivers that are hidden from site anywhere else and can often solve problems with drivers not functioning. It may not solve your problem but it is worth having a go at.

    Have you any speakers that are not USB and can plug directly into the sound card to see if the card is actually producing an output, then it will be more of an issue to figure out why the USB port is not working by default.
  9. Rezolution

    Rezolution TS Rookie Topic Starter

    I did, the listed hidden devices were not capable of being deinstalled.
    (I do not have another set of speakers.)

    And for current info,
    The browser test works, yet music will not.(Also the headphones will still not work)

    Does it have something to do with what is being used for the master volume control?
  10. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Umm, the plot thickens, can you give me the exact details of the soundblaster device or better still a link, so I can read up on it. Is it the X-Fi Go.
  11. Rezolution

    Rezolution TS Rookie Topic Starter

    Model number is SB0670.

    Creative USB Speaker
    SB X-Fi, DR release 2.10.0
    Are my current updates.

    I am a little unsure as I bought my computer pre-owned.
  12. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    OK but before I do any research can you just confirm it is the "X-Fi Go" a small dongle like device that just plugs into a USB socket on your laptop? Or is it a desktop PC you have, searching for Pavilion comes up with laptops. But, the SB0670 appears to relate to a sound card for a desktop.
  13. nismo91

    nismo91 TS Evangelist Posts: 930   +33

    well one thing for sure, your speakers, that is Creative N400, is a USB speakers. that means it does not use your realtek device at all.

    so the problem with cutting sound and unrecognized usb device most probably lies in your speakers itself, although other things may have also triggered that.

    what i suggest is to uninstall the speakers thru the device manager and select "delete driver software" and click OK. then uninstall any X-Fi software (if any) and restart your computer. after that plug your speaker back and see if anything works.

    Creative website only provide BETA driver for the N400. it can be found here
  14. Rezolution

    Rezolution TS Rookie Topic Starter

    It is a sound card that plugs into a pci port on my desktop.

    It recognized the driver because I had to maually go into the sound and audio devices and set the defualt for usb speakers after it had been restarted.

    Also going into hardware properties and enabling the sound device.

    The Creative Beta Driver Nismo91 sent (dont know why I couldn't find it)
    now shows the driver as Creative instead of just generic.

    The problem lies when I turn the computer off for the evening and start up in the morning it is not recognized untill I take out and plug the speakers back in.

    And that the master volume / headphones / eq are not working on my SB browser, but the test does (except headphones).
  15. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    I appreciate you have already uninstalled and reinstalled but I think the best way to handle this is to go right back to the beginning and start again one step at a time. Using System Restore may be the quickest method, take it back to before you installed anything. Then make sure your original sound set up works, the original speakers and headphones.

    Then follow the instructions supplied with the card and go through it one step at a time, testing after each step.

    There is always a possibility that your new card is faulty, could you try it on another PC.
  16. Rezolution

    Rezolution TS Rookie Topic Starter

    It was just set back to factory settings, so there is no restore point.
    I think it has more to do with the browser than anything else.
    (Why else would the test in the browser work?)

    I will keep looking and if all else fails will eventually reset again and reinstall everything.

    And if not, repost untill someone else gets a a chance to take a look and try to diagnose.
  17. Rezolution

    Rezolution TS Rookie Topic Starter

    In my add/remove programs,
    there were 2 various creative programs (don't remember where both came from).
    And a Realtek from setting audio in bios to enabled (changed back to auto).

    I deinstalled the programs, then reinstalled the Creative Program again (done this once before) and presto.:stickout:

    But now my browser doesnt show headphones and will not allow me to switch to gaming mode. (Sighs)
    When will it end.

    Anyway Thanks Nismo91, you helped at least solve my problem with my speakers.
    I could not find the driver support for the N400's.
  18. Rezolution

    Rezolution TS Rookie Topic Starter

    The Sb X-Fi Audio Controller works for my headphones just fine,
    so it seems to be a problem with changing to the usb creative driver to get the speakers to work.

    So Funny :eek:how they are both made my Creative and not functioning together properly.
  19. nismo91

    nismo91 TS Evangelist Posts: 930   +33

    Rezolution, I just recall that I used to have similar problem in the past, with USB X-Fi Surround 5.1 sound card. It works fine in my laptop, but when I plugged it into the desktop and restart it, it would not be recognized first thing after the desktop turned on, and stuck unless i plug it out and in.

    Just read on other forums that there are similar problems to mine as well as yours with various Creative USB sound devices. I thought some Creative may have problems with startup. Regarding the SB Browser, I really have no idea, since I never used it.
  20. Rezolution

    Rezolution TS Rookie Topic Starter

    I have to take the usb plug out and plug back in and it recognizes it instantly.

    But still it gets annoying to constantly unplug and replug in since I turn the computer off nightly.

    But even more annoying sifting through alot of paperwork that most of the time has no set protocol or quicker/newer posts(information) on what they did or added.
  21. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    This is a shot in the dark, but it may just work. Back up your registry first so you can reverse the change if it does not work.

    Run regedt32.exe and navigate to;


    Create the Usb key if it doesn't already exist. Under this key, create a new DWORD value called DisableSelectiveSuspend and give it a value of 1. Then restart the PC.

    Also, what service pack are you on as there were some updates in SP1 & 2 that related to USB, you should be on SP3.

    Are the speakers plug and play?, check the device properties in Device Manager to ensure Plug & Play is enabled.
  22. Rezolution

    Rezolution TS Rookie Topic Starter

    After I get to Usb, I am given 6 various folders.
    audio, ccgp, behci, hub, stor,and uhci.

    As for the other corrective measures,
    yes I have sp3, and have enabled plug and play in computer settings and bios.
  23. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    As the instructions say, "Create the Usb key if it doesn't already exist." It may be worth a try as from what you have listed this key doesn't presently exist.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...