CS Source Help (Retrieving Server Info, etc)

By Swordey ยท 13 replies
Mar 19, 2008
  1. Ok first of all, I just want to say thanks to everyone who is reading this and might be of help to get my source back to normal.

    My problem is that, I will try to join a game and in the "retrieving server info" thing, it will freeze/or will just completely exit out of source and give me an error(I've had model erros b4..., cmdx8mesh similar to that, DX8, etc)
    This isn't the first time I've had to deal with this problem. It has happened to me two times before
    1.)Once where I didn't deal with it and just later completely reformatted it and fixed the problem I guess =/
    2.) After the reformatting, a couple months later I was having problems joining games(freezing, getting into games but then getting exited out of source, etc)

    So for # 2 I asked my friend for help and he tried reformatting my computer(But he wasn't able to do it because my HDD was corrupted)
    After we sent it to a shop and realized I needed a new HDD, I bought a brand new HDD

    After the new HDD, I was able to play source perfectly, best time playing the game in a while.
    Then about a month later, I received some virus and from there things went down the drain.
    I wasn't able to get any help from my friends so I sent it into a shop to be reformatted and they did it for me. When I came home and installed everything, everything seemed to work but Source :[
    Now I've waited like two months and I'm really wanting to get this fixed.

    I'm not very smart w/ computers and I dont know much, so if you need me to check anything, please just help me with some patience :D

    Also on a side note, I just got done reinstalling the latest drivers, reinstalled CS S, etc.

    Finally, I know this is a problem that I can fix by myself and whoever can help me through the way, I will greatly appreciate it.

    And if all else fails, could I possibly send it to a computer place to have Source fixed specifically???
    Edit:I run other games perfectly fine(WC3FT/CS 1.6)

    Edit: Here is one of the errors I would get...
    When I try to play CS:S, I get this error and then the game closes automatically.

    It says engine error, and the message is
    failed to lock index buffer in CMeshDX8::LockIndexBuffer

    Thanks guys
  2. Swordey

    Swordey TS Rookie Topic Starter

    bump :[

    plz helppp <3?
  3. Acclamator

    Acclamator TS Rookie Posts: 261

    Do you have DirectX 9.0c installed?
  4. Swordey

    Swordey TS Rookie Topic Starter

    IN CSS it says I have the harddrive thing at DX8 and software at DX9
  5. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Ok, that means your Graphics card cannot support DX9.

    What is it doing right now? Will it load?
  6. Swordey

    Swordey TS Rookie Topic Starter

    I dont think thats the case. I've ran source perfectly before with my graphics card.
    Like I said, I've ran source before fine and problems like this have occured, I just dont know what to do now.

    Heres what I can do for CS, I can load it and everything, but if I try to join a server, everything will be perfect till it hits the retrieving server info, then it will just never load :[
  7. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    No, I wasn't saying it was the gfx cards fault, I was just letting you know why it said 8, then 9.

    Mine is like that,too, you see.

    It may be a firewall blocking it...
  8. Swordey

    Swordey TS Rookie Topic Starter

    Umm I know I recently reinstalled my CS S and then did the latest drivers thing, I'll turn off my firewall and then see how it is.

    Ill edit soon.

    And btw thanks for help so far!
  9. Swordey

    Swordey TS Rookie Topic Starter

    Well I dont know what happened the other day, but now I have tried reinstalling steam but it keeps telling me I already have another steam running =/

    I have no clue what I did, but I can't even get steam to run now :[

    So what can I do?
  10. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Open up Task Manager (cntrl+alt+delete) and open up the processes tab. Right click Steam.exe and terminate it.

    Then, try running steam.

    If not, then you'll need to clean the registry of steam files. It takes FOREVER.
  11. Swordey

    Swordey TS Rookie Topic Starter

    Also I just want to say, when I try reinstalling steam, it gets stuck at 26% and then says"Steam is already running,you may only run one copy at a time"

    So I tried the task manager, and there wasn't the steam.eve file or w/e

    And can you tell me how I would do the cleaning registry of the steam files?

    Edit: I was looking up different errors for source and found one that is basically the one I get sometimes, its on the first post.
  12. Swordey

    Swordey TS Rookie Topic Starter

    Sorry for bumping again but I just want some final last advice before I send it in or w/e

    I know I can possibly fix this myself w/ your guys help!

    Edit:Fixed the steam problem
  13. Swordey

    Swordey TS Rookie Topic Starter

    For some reason, I can't buy CS S
    I try clicking purchase but it wont do anything when I do it =/
  14. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    If you already have bought it, then you shouldn't have to re-buy it. All you have to do is download it. Go to the My Games tab and click install on the CS:S listing under 'Not Installed'
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...