D:\ is not accessible. Incorrect function.

By Blink · 49 replies
Jul 6, 2005
  1. LaraPasfield

    LaraPasfield TS Rookie

    Hello High Voltage,
    When I had not yet found the fix which worked for me (as above) I had a temporary solution of formatting my new cds with DLA first. That's a pain, but maybe this works until you fix your system.... :) Lara
  2. BrianInVasastan

    BrianInVasastan TS Rookie

    This problem has been driving me mad for a long time. Last week I finally discovered that the problem is Norton, not Windows as I had asumed.
    Check out this link
    (link deleted. I am not allowed to post links! Go to Symantec.com and search for "drive is not accessible. Incorrect function.")

    After doing what it said there, I reactivated Norton Anti-virus and the problem was still fixed. I can access my floppy, CD and DVD drives again now.

  3. LaraPasfield

    LaraPasfield TS Rookie

    Hi Brian,
    I don't use Norton but NOD and have done so since many years. This just shows that with PCs there are different causes for the same problem with different solutions, we computer folks just have to be so bloody smart to outwit these machines constantly :) Glad you fixed it!
  4. HiVoltg30

    HiVoltg30 TS Rookie


    Well I tried Brian’s advice and went to Symantec.com today, followed all of the directions, but sadly it didn’t work for me. :(

    I also tried loading some other burning software (since I have always used Windows Media Player in the past).
    First I tried iomega’s “Hotburn”, but my model of CD/DVD burner wasn’t recognized by their system, so that failed.
    Next I tried Nero 6, with still no success.
    So I resorted to trying Nero 7 and later Nero 8… No luck with either.

    So I am a complete loss!

    Someone mentioned that it may be a problem with my Windows XP Pro - something may have gotten distorted or deleted at sometime… etc.
    I have the Master Disc, but not sure how to use it to check for that type of fix.

    If my memory serves, I believe all of this started around last May when I renewed my Norton online. :suspiciou
  5. LaraPasfield

    LaraPasfield TS Rookie

    Have you tried this from my first post: going to the Drive letter in Windows Explorer and right clicking on it. Go to Properties; Click on Recording; Check "Enable CD recording on this drive". If it wasn't clicked before this will probably do it.....
    Or formatting your disks with DLA? That's cumbersome, but at least you can burn CDs...
  6. HiVoltg30

    HiVoltg30 TS Rookie

    I can't find anything in Properties that says anything about Recording
  7. HiVoltg30

    HiVoltg30 TS Rookie


    Well off Yahoo answers I had someone recommend trying CDBurnerXP.
    Which is programmed for that OS.
    I loaded it and wow! It worked!!! I was shocked!
    Best of all it was free!

    It is missing some features I would like to have, but it’s working so I am not complaining.

    I still get the same response when I try to access the CD’s by clicking the Drive icon on the computer, so nothing that way has changed, which I would still like to solve.

    But going through the new burning software will keep me from pulling my hair out in the meantime.
  8. Braunsky

    Braunsky TS Rookie

    I have an internal CD drive and an external DVD/CD drive. If I check "enable recording" on one of them, it gets unchecked on the other. I do have Nero with IN CD, which I've just updated, as well as Cyberlink DVD Suite and Photoshop Elements & Premiere. Turning off Norton autoprotect does not help. Any ideas? Software conflicts between the different programs that can burn CDs & DVDs? A Windows XP glitch?
  9. Clobbohead

    Clobbohead TS Rookie

    Howdy, folks!

    I've searched all over the web trying to solve a pc problem, and of all the forums this one seems to be the best. Great attitude, here.

    I'm pretty ignorant with computers and not afraid to admit it. It's a love/hate thing. When everything is working I find it to be a wonderful tool. When something goes wrong I could cremate it.

    I have a HP with Windows XP, SP2. I use it mostly for picture editing (Love digital cameras!), and storage, and editing live audio recordings (legally). And of course to surf the internet, and email.

  10. Clobbohead

    Clobbohead TS Rookie


    Thought I was posting in the 'introductions'...maybe admin can move it?

  11. veena007

    veena007 TS Rookie

    I have the same problem but when I go to My Computer the D drive is not listed .I think I Uninstall the D drive What can I do to reinstall it . The laptop does not detect boot CD either. Help
  12. fpj10

    fpj10 TS Rookie

    D Drive has once again become 'not accessible incorrection function' . The same thing happened in Sept 2005. At that time , PC was under warrenty and they put a new drive.
    I can read all and any disks. I just can't write to blanks and partially used disks.

    I have tried all the usual corrections, ie: uninstalling and reinstalling drives. { I DO NOT have the availability to click enable CD recording on this drive.. { I tried both the Disk manager. and Device Mgr. NO LUCK
    So I bought a new memorex drive . After installing it, ~~ imagine my surprise when it has exactly the same error as the factory one.
    I called memorex support. They were as helpful as was possible. But, it all seems to boil down to the period of time when I last renewed Norton anri virus.
    This is a great story, isn't it ???
    However, here I am again, looking for some new help.
    Any suggestions ~~ PLEASE !!
  13. dushyant87

    dushyant87 TS Rookie

    I'm experiencing the same problem for the past 30 mins. That's when I decided to do a google and got to this link. The problem with me is that, first of all, instead of showing my drive as a DVD-Ram drive, it says CD Drive. I burnt a DVD just before this problem occurred and the DVD burning was successful. But when I insert the DVD, it does not show anything. When I insert an old CD/DVD it is able to read it. But when I insert a blank disc, it is unable to recognize it (But when I start Ashampoo Burning Studio, it gives me the message that the inserted DVD-R is OK, although I haven't yet tried to burn a disc after the problem started). I also, like many others, haven't been able to find the recorder tab. The worst part is that I've purchased the writer just 2 days back. The media I'm using is TDK DVD-R. My Writer is LiteOn LH-20A1S and my OS is Win XP.
  14. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    The quick test for an optical disk involves booting in to your install disk or any bootable optical disk. If your computer boots into the install disk your optical drive is probably good; if it doesn't boot into the install disk then the optical dirve is probably bad.

    The first thing you can do is reboot your computer and make your way into its BIOS. While in the BIOS make sure the first boot device is your optical drive. Change nothing else. You then insert your install disk into the drive and save the changes you made in the BIOS and reboot. Your computer should boot into the install disk. If it doesn't boot into the disk then your optical drive is probably fubar. If it does boot into the install disk then your optical drive is probably good. Don't tell the install process to continue; when you get a chance just cancel the install and take the optical disk out and reboot your computer. If you don't have an install disk you'll need to create (or borrow) a bootable optical disk. Memtest can be made as a bootable optical disk.

    The reason you do the boot test is to eleminate possible OS and driver problems.
  15. Tanzil

    Tanzil TS Rookie

    zomfg finally!

    i was looking round for ages, after buying 25 dvd-r's, as to fix the 'incorrect function' problem. After uninstalling-reinstalling-rebooting etc. i found your post. tried it and put the cd in...it worked! thanks. although if you can't find the recording tab i suggest updating drivers then putting your cd in. sorry if it doesn't help!
  16. newspeak

    newspeak TS Rookie

    Hi, all!
    I'm having problems which have just started today, and which seem similar to much that's been discussed here, so I just registered here to see if anyone can help with this.
    The problem is that a DVD containing data which I burned some weeks ago, and which was being read by my DVD/CD drive (drive "E" on my system) with no problems yesterday, is now inaccesible. (I did, ofcourse, try cleaning it!) When I try to load it I get one of the the following three responses:

    1) The DVD/CD drive (drive "E" on my system) makes some muted, little 'clunks" and then the computer freezes, leaving the 'egg-timer cursor' stuck on the screen. Task Manager doesn't recognise that anything is happening, so it can't be unfrozen by shutting a process down. After trying two or three times I can eject the disc and then escape from the frozen cursor situation.

    2) A message pops up asking for a CD to be inserted into the drive, as if it was currently empty.

    3) A message pops up stating "E:\ is not accessible. Incorrect function".

    The third one is the most common. I thought the DVD might be damaged, so I tried a back-up copy of it, and it produced the same results.

    Other DVDs, including data DVDs that I've previously burned, seem to be OK.

    I did a "sytem restore" to a point well before yesterday, when these DVDs were being read with no problems, but the situation stayed the same.
    I found this message-board and tried these suggestions:
    <<goto start-->run-->services.msc and double click "IMAPI CD-Burning COM Service" , its "startup type" should be set to "manual" , if it isnt alredy so then set it to manual and click "ok" and close the services window ,
    goto "my computer" and right click the E: drive , click "properties" and goto "recording" tab and check "enable cd recording on this drive" and click "ok" ,
    But this hasn't rectified the situation.
    (The operating system is XP. Is there other stuff that I need to add?)
  17. Arnvorax

    Arnvorax TS Rookie

    Similiar Problem

    I've got two dvd/cd burner drives - both are lite-on dvd/cd combos, neither of them let me write a cd/dvd or even detect a blank cd/dvd. I dont have norton - I hate norton - was using a software called deep burner, downloaded CDburnerXP tonight and it doesn't help any. Anyway, let me describe my problem in a little more in depth.

    If I put a cd that I didn't burn - (For instance my copy of windows xp pro) - into either drive, it works fine. If I put a cd/dvd that I have made into either drive, then the drive changes to "cd drive" in my computer and when I click on it it says "F: \ not accessible - incorrect function". I just updated the firmware for the drives tonight - still have the same problem - I've tried enabling cd burning on each drive (if I enable it on one drive it turns off on the other drive) - still the same problem. I'm going to try uninstalling both drives and letting windows reinstall them and see if that helps.

    Didn't notice when it quit working unforunately, as I dont burn a lot of cds usually, but I think it was sometime after I downloaded some updates for windows from the windows update site.

    If the uninstall/reinstall doesn't work, anyone got any suggestions? I'm pretty good at figuring hardware/software problems out, but some of this crap that pops up with windows xp is nothing short of mind boggling.

    Thanks in Advance,

  18. Marfoo

    Marfoo TS Rookie

    Well I've been having the same problem as most of you, and like some of you I don't have a recording tab either, but I found a solution to get one (if you know you have a burner).

    This is my first post so I can't post links, but go to Microsoft's Support page and enter topic number "316529", it should read "CD-R drive or CD-RW drive is not recognized as a recordable device"

    I'm still having problems with getting things to burn with Windows Media Player, but it's a step in the right direction for now.

    However I can make data disks with Explorer now, maybe a reboot will get Windows Media Player working.
  19. captaincranky

    captaincranky TechSpot Addict Posts: 12,967   +2,525


    Marfoo, see if you can get your hands on a copy of Nero 6 (full retail version). There should be plenty of these around. So, if you don't need Blu-Ray support this older version will do you proud, instead of futzing around with the Windows Media Player or Windows Explorer. IMHO, the only use I've found for WMP is ripping CDs in WMA lossless format.
  20. Marfoo

    Marfoo TS Rookie

    Nero is pretty bloated, not for me. The fact the the settings are incorrect in the registry obviously shows that the problem is deeper than Window Media Player and is a problem with Windows itself. Getting Nero wouldn't help if the Windows HAL is bad or the devices aren't correctly recognized and initialized.

    Anyway, I got my problem solved, a combination of the registry tweak I posted and and an uninstall and reinstall via device manager and a reboot cleared it all up. My burner is now accessible through Explorer and Windows Media player as well as my Zune software (which was also having problems.
  21. Krymson

    Krymson TS Rookie

    One thing I have learned recently, previously didn't realize that it could be an issue, is that you must make sure your DVD player can read the compatible media. Since there are two different types of DVD formatting (excluding Blu-ray). What I am referring to is the DVD-R(W), DVD+R(W), formatting.

    For example if you have a DVD+RW drive, it will not read a DVD-R disc.

    If you have one that is +/-, this should not be an issue. Just thought I would throw this into the mix.
  22. BMWX6

    BMWX6 TS Rookie

    Drive:\ is not accessible. Incorrect function

    The Problem: My DVD +RW media (3 separate disks) on which I had backed up data, pictures and video on a Sony DVD RW drive was now giving me this error :
    "d:\is not accessible. Incorrect function."

    The changes since I could last read the DVD's was that the same DVD drive was now installed on a different machine. I was still using Win XP pro, however with SP3 instead of SP2 on my previous computer. I had also installed Nero ver. 7. However I am not sure if this has any bearing.

    In addition, I also have a second brand new Pioneer DVD Dual Layer drive installed on this machine and it will not read the DVD's either. However it did not generate any error messages unlike the Sony and hence gave nothing for me to work on. The Pioneer however after a few re-tries did read one of my three DVD RW media but only the one with data files.

    The Solution (which worked for me):
    1) Find the 'My Computer' icon ( could be on your desktop or click 'Start' and you should then see it).

    2) Right-Click 'My Computer' and select 'Properties'.

    3) Click on the 'Hardware' tab then the 'Device Manager' button.

    4) Under the list of devices, locate the DVD/CD ROM Drives and click on the '+' sign to expand it.

    5) Right-click on the drive giving you the problem and select 'Properties'

    6) Click on the 'Properties' tab .

    7) You should see an " Enable digital CD audio for this CD-ROM Device' option, which is checked (enabled). Uncheck this setting to disable it.

    8) Re-boot your PC when prompted.

    After your PC boots- up and is ready, Try reading your DVD's . You should now be able to read them.

    Actually once I did this and was able to read my DVD's I re-enabled the 'Enable digital CD audio for this CD-ROM device' once more, rebooted and then was still able to read my DVD's.

    ps. You can also access the Hardware properties of the DVD/CD drive via Windows Explorer. Simply locate the DVD drive in the right panel, right-click it and select 'Properties'. Then click on the 'Hardware' tab. Then click on the problem Drive and click on 'Properties' Then click on the 'Properties' tab and then on the 'Properties' button. You should now see the 'Enable digital CD audio for this CD-ROM device' .

    I hope this helps.

  23. neddy21

    neddy21 TS Rookie


    Hi, My first post so I do not talk the talk. In laymans terms my cdrw/dvd integrated drive decided that it would read but not write a few days ago. The only things I did differently was download Audacity/Lame Vinyl to cd software and buy a new memory stick. Up came Error 39. I asked my daughter to sort it and she downloaded something from somewhere on the web which got rid of the Error 39 but when I tried to burn I got ..."not accessible. incorrect function". This is when I found Techspot, this great site.
    I started to read and try -
    Uninstalling & reinstalling did not work.
    I checked I had the latest version of the driver
    I do not have an "enable cd recording on this drive" in my driver properties
    I checked the Event Viewer and found several MSFW Event 9's amoungst others, remedies for these seemed a bit to advanced for me.
    I am tight, I am not going to buy a plug-in unit unless I am sure that it is at fault.
    Reformating discs sounds a bore.
    I ran my Windows Live One Care which did no good.
    I know my processor is slow its an old machine, I will upgrade it.
    I decided to go back to the begining, I searced the net again for Error 39 fixes. I found a "free error repair" site and typed in Error 39. I downloaded their repair. I can read and burn again. I did not have to register with them but I am going to see if the repair stays good. It was free.
  24. neddy21

    neddy21 TS Rookie

  25. Sweety1

    Sweety1 TS Rookie

    A more recent addition. Had no trouble with photo transfer to CD until I installed HP Photomart Printer software. Wcely 's advice worked... so thanks for that!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...