Data recovery SD Card not accessible, says incorrect function showing unknown format

By maniram99
Apr 12, 2014
Post New Reply
  1. I have a sony SD Card 16gb class 4 card. I did use the card for almost 3 months, when I tried to use it now, I am not able to access the card,

    SD1. SD2.

    I tried recovery softwares like recova etc to recover the file, but I was not able to recover even a single byte.

    I have many importants files in the CARD, PLEASE HELP ME...,.

  2. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,515   +978

    I think >>this thread<< could help you out :). He seems to have the same problem.
  3. Zi12345

    Zi12345 TS Rookie

    If chkdsk is not working than you could try to format the card and then run a recovery program. This worked for me.

    I had the exact screen as you.

    First try running just chkdsk X:
    To ensure that the computer is reading the disk (for me it read but said that there were errors).
    When I tried to run the /f and /r function the program stopped working.

    In a last ditch effort I formatted the card and ran recuva on it and was able to recover all my files and the card is now usable again.

    I hope you are able to fix your card.
  4. jobeard

    jobeard TS Ambassador Posts: 11,383   +1,063

    If you take the reformat and then run file recovery approach - - - PLEASE be kind to yourself and during the reformat step, be sure to use QUICK FORMAT which will correct the partition table and the Free vs. Allocated lists but not rewrite every sector.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...