Dell AIO 922 Printer Communication issue

Not open for further replies.


Posts: 101   +0

Short description: I cannot print.

Long description: After installing Avast! and ZoneAlarm my computer has stopped printing. I have the Dell AIO 922 Printer and everything was working fine before this. Whenever I try to print anything it just hangs in the queue and I eventually get a Dell Error stating that the printer cannot communicate with the computer. It's interesting because it never gives an "error" in the print queue just hangs on "printing" and never does anything.

I have a red error under "Application" in Event Viewer that looks like this:

Event Type: Error
Event Source: Application Hang
Event Category: (101)
Event ID: 1002
Date: 12/31/2008
Time: 3:15:40 PM
User: N/A
Computer: COMPUTER
Hanging application dlbtpswx.exe, version, hang module hungapp, version, hang address 0x00000000.

For more information, see Help and Support Center at
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 48 61 6e 67 ion Hang
0010: 20 20 64 6c 62 74 70 73 dlbtps
0018: 77 78 2e 65 78 65 20 32 wx.exe 2
0020: 2e 37 30 2e 30 2e 30 20 .70.0.0
0028: 69 6e 20 68 75 6e 67 61 in hunga
0030: 70 70 20 30 2e 30 2e 30 pp 0.0.0
0038: 2e 30 20 61 74 20 6f 66 .0 at of
0040: 66 73 65 74 20 30 30 30 fset 000
0048: 30 30 30 30 30 00000
And two under "System" which look like this:

Event Type: Error
Event Source: DCOM
Event Category: None
Event ID: 10010
Date: 12/31/2008
Time: 3:37:03 PM
Computer: COMPUTER
The server {3DD622FC-8844-430D-BF79-CAD8C795E336} did not register with DCOM within the required timeout.

For more information, see Help and Support Center at
Event Type: Error
Event Source: Print
Event Category: None
Event ID: 6161
Date: 12/31/2008
Time: 3:35:03 PM
Computer: COMPUTER
The document test - Notepad owned by COMPUTER failed to print on printer Dell Photo AIO Printer 922. Data type: LEMF. Size of the spool file in bytes: 9128. Number of bytes printed: 9128. Total number of pages in the document: 1. Number of pages printed: 0. Client machine: \\COMPUTER. Win32 error code returned by the print processor: 0 (0x0).

For more information, see Help and Support Center at

I uninstalled both Avast! and ZoneAlarm but the problem continued (so I reinstalled them). I have tried uninstalling the 922 Printer drivers (with Revo Uninstaller) and reinstalling them. I have run CCleaner as well. Additionally, the following Programs all have a "green check" in ZoneAlarm: Dell Dell 922 Button Manager, Printer Communication System, Printer Status Window Interface, and Spooler SubSystem App.

Does anyone have any ideas on what may be wrong??

Many thanks!!


Posts: 101   +0
  • Thread Starter Thread Starter
  • #2
Crisis Averted

Well, after some more digging I found a rather helpful troubleshooter on Dell's Support Page:

Dell Printer Troubleshooter

I'd recommend using it if you are having similar problems. Interestingly, it seems as if the uninstall was not completely successful before, even though I used Revo. I had to go into Device Manager and click on Show Hidden Devices under View and uninstall it there as well. This may or may not have been the final trick to get it to uninstall but the printer works successfully after using this step.

Also, after going through the troubleshooter above you will find the latest driver for download on one of the steps. Currently the driver is located here:

Dell AIO 922 Driver

Now, I think I actually had the latest driver...BUT after you unzip/install the driver I found an uninstall file in there located here: C:\Dell922\install\dlbtunst. This may or may not have been the final trick to get it to uninstall but the printer works successfully after using this step. Then I rebooted. [Note that when you unzip the driver it will ask you immediately if you want to start the process of installing the driver, but at this point you want to cancel out of that. You'll do that later...see below.]

Now, upon reboot I actually got the found new hardware balloon which is what you're hoping for to show that it was completely uninstalled previously. Note that during this process of finding and installing the new hardware it couldn't find some files. That's to be expected because you currently have no drivers installed, etc. However, after that process completes and it says that errors were encountered during the installation and some of your new hardware may not work (that's okay at this point), then you want to install the driver you downloaded (before you should have only used the uninstaller that came with it). At that point the software successfully installed and the printer started working again. [Note that the only way I could actually get the installer to run was to re-unzip the downloaded file. I just deleted the old unzipped files and re-unzipped it. This is the step that you previously canceled out of before...see above.]

Finally, when installing the driver I was asked whether or not I wanted the printer to be able to be used by the network. I clicked YES for this even though this is a standalone computer/printer. I'm not sure if saying no to this would have affected the results, but it may have. Perhaps this was necessary for ZoneAlarm to configure things correctly? I'm not sure, but it worked. Interestingly, I may NOT have done this when I first installed the driver originally.

Again, I'm not entirely sure which of these new steps solved the problem, but I'm working on someone else's machine and don't have time to go back and isolate the exact solution. At least this gives you some more things to try if you have this similar issue.

Hope this helps someone! :)


Posts: 6,430   +186
First, thumbs up on taking the time to write out the detail and info that went into your last post! But wanted to help clarify somethings

1.Old driver data
For a variety of reasons,(isn't frequent but still not that rare) for old driver data to hang around and screw up new installs. I'm guessing based on type of data you then found that BEFORE opening Device Manager to click View-> Hidden that you first set the Device Manager flag needed to really view ALL hidden….. In case not, see here. Is says XP but same true for Vista

2. Device Manager icons

Maybe you’re familiar but just in case not, good to know meaning of different Device manager icons
=> These indicate definite device problem
====> Black exclamation point (!) on yellow. Device error. Must be fixed even if device still functions in this state. Click for XP error codes.
====> Yellow question mark. Windows can’t find device drivers. This icon often appears under Other Devices but look through all of Device Manager as can appear elsewhere
=> These are informational but you may find they tip off a problem
====> Red "X". Device is disabled. (fyi.. Disabled devices still use resources)
====> Blue "i" on white. Resource usage forced by config data (not under Windows Control) Note: Forcing resource usage for any device may affect other devices
====> Semi-transparent (vs. opaque) icons “Ghost” device. Working devices are detected and have drivers loaded. A ghost device is not detected. Its drivers were previously, and are still, loaded. Only choose uninstall a ghost device IF a) it’s a sound device or b) you understand ghost devices. Some ghost devices should not be uninstalled.​
3 Found new Hardware
indicates the device isn’t correctly or fully installed (rather then just means fully uninstalled)

4 File not found messages
If the install shows messages about not finding files is usually NOT a good sign as it should be finding what it needs in the install package or what's already installed

5. Things like printer installs
Often install more then just drivers (e.g. control panel applets and sometimes applications as well). If it installs more then just drivers it typically creates an uninstaller in Add/Remove Programs. You should start by looking in there first for the uninstaller which usually addresses everything. DRiver only uninstalls can be done in Device Manager (rt click->Uninstall)

6. Local vs. network printers
Those darn printer installs never make it clear, but the real distinction of network vs. local connected printer:
=> Network: – Printer connects directly to your network (with an Ethernet cable) vs
=> Local Printer connects to one of your computers (typically with USB cable) and its the computer that's connected to the network. Computer must be set to then allow sharing of its "Local"


Posts: 101   +0
  • Thread Starter Thread Starter
  • #4
Thanks for the extra information. Over half of these things I was familiar with and just didn't include in my retrospect was a bad idea. I likely would've included more if I was answering someone else's post instead of my own. But this is a good reminder to be as clear as possible all the time; after all, the whole idea was for this to help someone else!

About a third of these things are new to me so I appreciate the clarification. In particular I have never dealt with "ghost drivers" before and am intrigued to learn more about those guys...I'll have to do some reading.
Not open for further replies.