Dell D620 mouse

By dnavoid ยท 4 replies
Aug 23, 2008
  1. i searched this section couldnt find info- so here goes i bought a 2nd user dell d620 & the trackpad mouse is kind of strange, it makes erratic movements e.g i move pointer but its not smooth & sometimes freezes very briefly.

    sometimes it works near enough perfect- i recently uninstalled the alps drivers & seems to work slightly better without drivers but only slightly, i googled & found lots of ppl with similar problems but no real solutions- some people say its some windows updates causing it some people say cut the cable/connection that goes from middle pointer. I read some places that on older dells there was some metal touching trackpad components causing this problem- I dont know whether to take this laptop apart, i dont want to end up causing any further problems. thanks for any help:)
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Remove the keyboard. Clean the keyboard, mouse pad, and visible components with a can of Dust Off or other treated canned air.
    Then go to the Dell site, and download the synaptics software, Chipset, and other files.. Disable or remove the old version in the Device Manager, and install the drivers once more.
  3. dnavoid

    dnavoid TS Rookie Topic Starter

    thanks raybay- ill try your suggestion however you state synaptics?? i see for this d620 ALPS glidepoint on dell site- i thought alps is different manufacturer than synaptics, or are they interchangeable/doesnt matter which driver? P.S the trackpad can only be accessed by removing/ disassembling the going to take the plunge & take the laptop apart as its really bugging me.

    [edit] i tried cleaning i ended up getting a hairdrier & heating up the trackpad, now it seems to be working much better :)
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Sorry. My bad. I have Dell's coming out my ears. But the drivers at the Dell support site will be for the right touch pad... Install it last after installing the updates for chipsets and all other hardware.
  5. dnavoid

    dnavoid TS Rookie Topic Starter

    thanks - i did the latest chipset drivers 1st before reinstalling 'alps' driver- also i looked on dell support & loads of other places, which advise ppl to go into diagnostics, which was a waste of time because diagnostics passes no problems, anyway after the hairdrier method worked considerably well/vast improvement but today i noticed the 'taps' not responding so i went into the mouse 'alps' options & checked then unchecked 'tap' then i clicked apply then the 'taps' started working again-dells are strange creatures lol I feel like getting a hammer & smashing it to bits grrrrr. nevermind
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...