Dell Dimension E510 won't turn on, please help

By ccnyc ยท 4 replies
Jan 3, 2010
  1. I'm trying to help my friend to figure out why her Dell Dimension E510 won't turn on anymore. I plugged in the power cord to a working wall outlet and pressed on the power button and nothing happens, not even the blink orange LED lights as most people have mentioned in the forums. The only light I see is a solid green light on the mobo. I tried to take out the CMOS battery and put it back in and didn't help. I unplugged the power connector from the PSU that goes into the mobo and replugged it back in and I see the computer was getting power for a few seconds (as the front panel power lid up for a few secs) and then it just shuts back down again. I tried this a few times and same results every time. Do you think the problem is in the PSU? Any advice is greatly appreciated.

  2. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,264

    Starting with the obvious-Is the 4 pin ATX12V1 power plugged in ?
    CMOS battery could be dead.
    Have you tried clearing CMOS (RTCRST Jumper pins 1 and 2)
    PSU could be dead.
    I presume that the four diagnostic lights on the rear I/O panel are non-functional ?
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Look carefully on the motherboard for those barrel-shaped devices sticking up from the board. If any are puffed on top, or split anywhere on the side, or leaking any brownish or reddish brown powder, they are the cause.
    Otherwise, Boards just go bad for no reason, and diagnostics are very difficult to run effectively.
    But as others have reported:
    Bad power supply.
    Bad hard drive.
    Bad memory module or damaged memory socket.
    Memory heat sink has lost its thermal paste, but replace in thin a coating as possible.
    Hold-down clamp that retains the CPU and heat sink to the board has snapped, or come loose.
    Bad CPU fan.
    All of dividebyzero suggestions above are good ones to examine.
  4. myrbailey

    myrbailey TS Rookie

    it is the power supply

    My Dell Dimension E510 had a blinking light for a while, then just would not power up. Nothing I did worked. It had a black screen and power button would not turn it on. when I pressed a button on the monitor it said "In Powe Save Mode, Press Any Key To Continue" but would not power up even when I pressed a key or moved the mouse. I took it to my computer repair guy and it was the power source. He replaced the power source for about $150 and it works like a charm. Was not the battery as I had thought. So get a repair person to replace your power source. Apparently they go bad on this computer.
  5. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Glad it is repaired... criminal to charge you so much, though..
    Appreciate the update.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...