DGL-4500 = Anti-Gaming?

By Exerticus
Oct 16, 2008
  1. The story below is kind of long but it is more detailed than the 'long story short'.

    Long story short:
    - Linksys router crapped out
    - Bought a D'Link DGL-4500
    - Internet works, gaming doesn't work nearly as well as before
    - All settings on factory default with latest firmware

    Also, before anybody asks, yes, I have to have a wireless router because even though I use a desktop, my sister has a notebook here that she uses.

    A few days ago, my Linksys BEFW11S4 Version 4 wireless router began to do what nearly all Linksys routers are known to do and began to drop my internet connection every fifteen to twenty minutes. After having done everything I could possibly find on it to try and fix it, still to no avail, I began to look at other routers to buy. Being big into gaming, I play in multiple leagues for Counter-Strike: Source and Call of Duty 4, I began to look for something that would last me for a long time and wouldn't interfere with online play. Thanks to Best Buy, the model of router I wanted wasn't available and so one thing led to another and I ended up buying the D'Link DGL-4500 wireless router.

    I set everything up with the router, turned my computer back on, used the quick-connection disk to get the router set up, and was able to get on the internet without any problems. My internet connection dropped once and so I installed the v1.20 firmware which caused all connection drops to cease. Once that was all done, I began to configure the security settings, all of which were merely standard configurations which I had on my old Linksys router.

    Everything seemed fine until I tried to start up Call of Duty 4. This game before would always start up in less than five seconds, usually almost instantly, and so when I saw that it was taking about as long as Mass Effect to start up, I began to feel something was wrong. I thought it could have been my firewall permissions and so I checked it, made sure the game and ports were allowed, and tried it again. The same exact thing happened. So, I just waited for about two or three minutes and the game eventually started up, just for me to find a blank server list. I knew that this wasn't right. Making sure it wasn't just CoD4 that was the problem, I jumped into Counter-Strike 1.6, and while the servers came up, I was unable to join them.

    So I did a factory default on the router and only put on an admin password, leaving everything else the same. Call of Duty 4 still takes forever to load but I can at least join the servers, though I am getting occasional lag, ping not fps, in some servers I used to play in, though I had never lagged in them before.

    The only thing that has changed between then and now is the router and I have tried starting the game up with Gamefuel turned both on and off so I know that isn't the problem. So basically, my question is, what can I do in order to make the settings back to the way they were before, back when I didn't get any lag and back when Call of Duty started up in an instant?
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Do you have XP, SP3 installed?
  3. Exerticus

    Exerticus TS Rookie Topic Starter

    Yeah, I do.

    KINGMEET TS Rookie Posts: 25

    Yeah i was going to ask the same thing. I had that problem because I am an extreeeemee gamer myself. when one of my routers went out I bought a cheap spare from netgear, and i couldnt play my games either. Like Madden, i could join rooms but not games. So I called Netgear and they remotely fixed my issue for me. I dont know exaclty what they did, but it worked. You should try the same.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...